summaryrefslogtreecommitdiff
path: root/dev-python/requests-oauthlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/requests-oauthlib
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/requests-oauthlib')
-rw-r--r--dev-python/requests-oauthlib/Manifest3
-rw-r--r--dev-python/requests-oauthlib/metadata.xml11
-rw-r--r--dev-python/requests-oauthlib/requests-oauthlib-0.7.0.ebuild34
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/requests-oauthlib/Manifest b/dev-python/requests-oauthlib/Manifest
new file mode 100644
index 000000000000..a453ecf441b3
--- /dev/null
+++ b/dev-python/requests-oauthlib/Manifest
@@ -0,0 +1,3 @@
+DIST requests-oauthlib-0.7.0.tar.gz 40641 BLAKE2B 3c8e498652df706223dc74404185c14c8f131e0578b1bd2671986507e9f09f7328af7193b0779615499240f67cf6a0c395c103afa63bd6d7c674f2672f64a471 SHA512 9de7f3e2f67507acbd6a711d7c3bc4d598214ab658e7e331f2c56d7a6d084e11df8bfc2449c3ec5e985016404a5e7920e26081bcc3af52d6c91b28d1a69f6ed2
+EBUILD requests-oauthlib-0.7.0.ebuild 800 BLAKE2B 2ac6d61e071621ee7e6491a62a03ac8bd9a19ad8bbe3c65601c915471121a442eb40dd359ad73e0cc9bc23ffefa6242104fdfdf8af822f855a0ca5679ef89098 SHA512 ea28f62d03a95e6d475a19b1b364d761d1116b11030857221114762cfa76de2274ff9cc94c14ba065977a91a9fa062edeb706fbbb2a86af9d8eb9b23bb531f9b
+MISC metadata.xml 331 BLAKE2B 7b904925adb6f8e39c1d1000e87c287ce5dbfa7a6e70544ab599b5ca8d254e70976d444149ee2727b4186d97326e662bcdacabc674f7bcc0e0193b2807e4c053 SHA512 871f44e56ecb16ea43e5702c30a43d24f911ae1b83fb2a5ba3ca4ab45b3676ee7d4841fc343f336c0249b0165777659bd393160728cb20e3484eee4854919d1f
diff --git a/dev-python/requests-oauthlib/metadata.xml b/dev-python/requests-oauthlib/metadata.xml
new file mode 100644
index 000000000000..58c53b538b89
--- /dev/null
+++ b/dev-python/requests-oauthlib/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">requests/requests-oauthlib</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/requests-oauthlib/requests-oauthlib-0.7.0.ebuild b/dev-python/requests-oauthlib/requests-oauthlib-0.7.0.ebuild
new file mode 100644
index 000000000000..d0ce442a11bb
--- /dev/null
+++ b/dev-python/requests-oauthlib/requests-oauthlib-0.7.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="This project provides first-class OAuth library support for Requests"
+HOMEPAGE="https://github.com/requests/requests-oauthlib"
+SRC_URI="https://github.com/requests/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="ISC"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+DEPEND="test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ )"
+RDEPEND="
+ >=dev-python/requests-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oauthlib-0.6.2[${PYTHON_USEDEP}]"
+
+#Refrain from a doc build for now
+#python_compile_all() {
+# use doc && emake -C docs html
+#}
+
+python_test() {
+ esetup.py test
+}