summaryrefslogtreecommitdiff
path: root/dev-python/restructuredtext-lint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/restructuredtext-lint
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/restructuredtext-lint')
-rw-r--r--dev-python/restructuredtext-lint/Manifest5
-rw-r--r--dev-python/restructuredtext-lint/metadata.xml11
-rw-r--r--dev-python/restructuredtext-lint/restructuredtext-lint-0.12.2.ebuild24
-rw-r--r--dev-python/restructuredtext-lint/restructuredtext-lint-1.1.2.ebuild34
4 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/restructuredtext-lint/Manifest b/dev-python/restructuredtext-lint/Manifest
new file mode 100644
index 000000000000..7ff8d9d7d7f3
--- /dev/null
+++ b/dev-python/restructuredtext-lint/Manifest
@@ -0,0 +1,5 @@
+DIST restructuredtext_lint-0.12.2.tar.gz 19141 BLAKE2B 69e0cf57540d5ccce8572a8c619506e3b76fd08e88019bb66c7a18a3ca2c2b91e72797c70428156e570143d6352d529088c324b18e2a08b67a8acddda7378352 SHA512 2634d740d30cafd446e3b5d3ad22e6942ec8e15d20440abe9c31ecfebebc7d1f50cc41492863ff1e6b01a8a3ad7139aa10e94022094dc7c314709e6f72176870
+DIST restructuredtext_lint-1.1.2.tar.gz 25061 BLAKE2B 5be51fb40ac3eb0ba58c053d5b54d79e0d1c0687786a877cc37d2e617dec788782e3d4aade62828a267c139b7e311405552cb61eefdbaed458c2c1206245a422 SHA512 f44eff61df3581ba345fb953a09d9bf6977003e05078bacbeea27287b0b14a6f16298db0bde5be4ebfd0843eac33de623db1e47ce6475b30dce47cdd3e9ea5d7
+EBUILD restructuredtext-lint-0.12.2.ebuild 680 BLAKE2B 634b8e29679179bb664124fe927b09ff0d96924897268f0f84ea06bb5d98a682af663681c549a4ab23517f28a9fc8631d4fc4fb385c2e51f2a4a2da4db54beab SHA512 c7a1d91c611f55b68feedd0dc8766c5e796bb28a67c30388801e6a3681c34542be02139746a4559d49ce5ee630f362cd07513321ee1cbf46e3dc012975b5aa39
+EBUILD restructuredtext-lint-1.1.2.ebuild 816 BLAKE2B f42584b191c55fb738a4ad0f52f437838c3608e02fe54a981460216cb25e7314ee341cf98ded2cf7330dbf7e0a1bd34c0b531f23e6e2c457099679ff33fc95cf SHA512 e83f0267d906be24966fc9d42d698b316a78d771e3124b7294abc2e2d1fb6d7b5690b16654bd0e4961af6aca60cff435c151ed90e6128b9463c1e6826689d1f3
+MISC metadata.xml 338 BLAKE2B c30f38fd31f802cfdb9dfd57839acc4269c793aedde4a2c17e937f62da0f04e94ccf2cd309b528f9c5753fdc747951ace9fd27a403d32907751ca1640955a3e9 SHA512 50f218c3b3fbdc1b639de1fbeb5adbcd6b6864027331f4521c4d52ba5a66d7ff98b75f746ce29dc8fc454ac8d3e12012cb53e8d8b0b157813a4b359d27760265
diff --git a/dev-python/restructuredtext-lint/metadata.xml b/dev-python/restructuredtext-lint/metadata.xml
new file mode 100644
index 000000000000..88898d732029
--- /dev/null
+++ b/dev-python/restructuredtext-lint/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">restructuredtext_lint</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/restructuredtext-lint/restructuredtext-lint-0.12.2.ebuild b/dev-python/restructuredtext-lint/restructuredtext-lint-0.12.2.ebuild
new file mode 100644
index 000000000000..4eb519e9d892
--- /dev/null
+++ b/dev-python/restructuredtext-lint/restructuredtext-lint-0.12.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Created out of frustration, it sucks to find out your reST is invalid after uploading it."
+HOMEPAGE="https://pypi.org/project/restructuredtext_lint/"
+
+MY_P="restructuredtext_lint"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_P}/${MY_P}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_P}-${PV}"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ >=dev-python/docutils-0.11[${PYTHON_USEDEP}]
+ <dev-python/docutils-1.0[${PYTHON_USEDEP}]"
diff --git a/dev-python/restructuredtext-lint/restructuredtext-lint-1.1.2.ebuild b/dev-python/restructuredtext-lint/restructuredtext-lint-1.1.2.ebuild
new file mode 100644
index 000000000000..333e56934ec1
--- /dev/null
+++ b/dev-python/restructuredtext-lint/restructuredtext-lint-1.1.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Created out of frustration, it sucks to find out your reST is invalid after uploading it."
+HOMEPAGE="https://pypi.org/project/restructuredtext_lint/"
+
+MY_P="restructuredtext_lint"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_P}/${MY_P}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_P}-${PV}"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ >=dev-python/docutils-0.11[${PYTHON_USEDEP}]
+ <dev-python/docutils-1.0[${PYTHON_USEDEP}]"
+
+python_test() {
+ nosetests -v || die
+}