summaryrefslogtreecommitdiff
path: root/dev-python/rfc3987
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/rfc3987
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/rfc3987')
-rw-r--r--dev-python/rfc3987/Manifest3
-rw-r--r--dev-python/rfc3987/metadata.xml17
-rw-r--r--dev-python/rfc3987/rfc3987-1.3.7.ebuild27
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/rfc3987/Manifest b/dev-python/rfc3987/Manifest
new file mode 100644
index 000000000000..ece20de5a831
--- /dev/null
+++ b/dev-python/rfc3987/Manifest
@@ -0,0 +1,3 @@
+DIST rfc3987-1.3.7.tar.gz 20701 BLAKE2B 234f3dc60d83e5615ae9fbbc14d063f9a993a532f5e7042144a8f5e995d44a27d88c284f7e12ff1f3f92d2440333438b3e1a0804ab43ca229305ce20ec4cb4f2 SHA512 c5fa8eb36358f7f42d12adc305031bfff7bd77e83316ad4458ed07acc6094c7d9109b95848b9296dcbc6677ce34aa59b1be8fd57dfcdc6be47eb92aeda51c518
+EBUILD rfc3987-1.3.7.ebuild 791 BLAKE2B 5a3405705ad526281842a83974146c7edd9f41c3bca4d4b8bc7528ddd0b280d4e700142aa97e49127a2d6e4506221653da2cde081870f661150b6fa5bc48f9d2 SHA512 b5faae4e208053829208f4530246f23f5df83d596758da42e9c31ddf9d3c763c1b11b5f97e2247157012bf216e50011cde41d6b5317dad120690ebe54482652f
+MISC metadata.xml 571 BLAKE2B c366d3c4f3cb52d43bf469e77610cb6cfdd57b82ef0f46e8f1dbc739637bae6805edf5086deb4779738be7d29c4c73f7d658050112e9f5be62debc22a735f61c SHA512 2ced33f8245fc320ca1795072d9e63b5cc910b90f368306112316dcb444ee24f292e39ff76dfb027edcaf2c7a6dbfa636414ab8f9cfe777b0a2aeed17143e8c0
diff --git a/dev-python/rfc3987/metadata.xml b/dev-python/rfc3987/metadata.xml
new file mode 100644
index 000000000000..ed37dd5132a7
--- /dev/null
+++ b/dev-python/rfc3987/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>aballier@gentoo.org</email>
+ <name>Alexis Ballier</name>
+ <description>Python team can take the package if they wish.</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">rfc3987</remote-id>
+ <remote-id type="github">dgerber/rfc3987</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/rfc3987/rfc3987-1.3.7.ebuild b/dev-python/rfc3987/rfc3987-1.3.7.ebuild
new file mode 100644
index 000000000000..1a78ecb2298b
--- /dev/null
+++ b/dev-python/rfc3987/rfc3987-1.3.7.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Parsing and validation of URIs (RFC 3986) and IRIs (RFC 3987)"
+HOMEPAGE="https://github.com/dgerber/rfc3987 https://pypi.org/project/rfc3987/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="$(python_gen_cond_dep \
+ 'dev-python/regex[${PYTHON_USEDEP}]' python2_7 'python3*' pypy)"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ ${EPYTHON} -m doctest -v "${S}/${PN}.py" || die
+}