summaryrefslogtreecommitdiff
path: root/dev-python/rfc8785
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-28 01:25:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-28 01:25:58 +0100
commit6405cba4bf18141460bc9fcb8f5580532d4b46f8 (patch)
tree377baa366741990f54b18ea82f5566c48295f4e0 /dev-python/rfc8785
parentabc3bfc07d931f667a0f50cf607f1c8a49af879f (diff)
gentoo auto-resync : 28:09:2024 - 01:25:57
Diffstat (limited to 'dev-python/rfc8785')
-rw-r--r--dev-python/rfc8785/Manifest3
-rw-r--r--dev-python/rfc8785/metadata.xml12
-rw-r--r--dev-python/rfc8785/rfc8785-0.1.3.ebuild27
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/rfc8785/Manifest b/dev-python/rfc8785/Manifest
new file mode 100644
index 000000000000..accba445d313
--- /dev/null
+++ b/dev-python/rfc8785/Manifest
@@ -0,0 +1,3 @@
+DIST rfc8785.py-0.1.3.gh.tar.gz 14754 BLAKE2B c0fab30a49cf3d1e405bf0aa32d2ec9300841bf7517b7c633ceac8dea340d3bfc7b562fbeb77c6392660f3009ca3b36e2882b7d60ca66cadfdab1661809a218c SHA512 a7318f5c19b9d49522d66c601da2006b1978bd3ccdce9e56e6ff0c8a0efbd3b13f0014b0f69a27c1f78a17c5a4c338301606c82fa70b3d09efda9efa1f23e4e9
+EBUILD rfc8785-0.1.3.ebuild 588 BLAKE2B 919f1a2e3d316e3e9b98168c5d31703a6d0ad8e1c4b94d805d05602f8ad6cd95e6800df01c9d42924f2247a06757e683f1b97f37fadc5441849ad23ae30c3e88 SHA512 d573b396283014b21e6ff600f59da377ff94bfcf598eafcaf472ad688951adb84cee29e82866070beaa776ca9233c117a4a2463009b98047652c44a9c3664172
+MISC metadata.xml 375 BLAKE2B 8ea127ad02d391f042cf16678abee358d0c9647cfcbf4a66aea86be8892ff3544f150c9e311bc358521fb9b737f5ece7b5e181c2622d837c253dee268121c78e SHA512 98143faf1800899ced91194cb0b5adf1f7b5380c7467943b1bd0c76aeb31ba3cb0e405335c0607cad3cf3a4506d663143e5ee30b4381d7ce83ba75ab95d774e9
diff --git a/dev-python/rfc8785/metadata.xml b/dev-python/rfc8785/metadata.xml
new file mode 100644
index 000000000000..8cc2dc5c7200
--- /dev/null
+++ b/dev-python/rfc8785/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">trailofbits/rfc8785.py</remote-id>
+ <remote-id type="pypi">rfc8785</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/rfc8785/rfc8785-0.1.3.ebuild b/dev-python/rfc8785/rfc8785-0.1.3.ebuild
new file mode 100644
index 000000000000..aac5c89b298d
--- /dev/null
+++ b/dev-python/rfc8785/rfc8785-0.1.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1
+
+MY_P=rfc8785.py-${PV}
+DESCRIPTION="Pure-Python impl. of RFC 8785 (JSON Canonicalization Scheme)"
+HOMEPAGE="
+ https://github.com/trailofbits/rfc8785.py/
+ https://pypi.org/project/rfc8785/
+"
+SRC_URI="
+ https://github.com/trailofbits/rfc8785.py/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest