summaryrefslogtreecommitdiff
path: root/dev-python/rich
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-17 00:13:57 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-17 00:13:57 +0000
commit27b3683509c5229cce540418778a8b64afbc0009 (patch)
treeb7164898142b8b093b91c8254c4387b6eec679ee /dev-python/rich
parentf2bdc27fe0f79f8f9a3945eb2b1163ce75c56439 (diff)
gentoo auto-resync : 17:02:2025 - 00:13:57
Diffstat (limited to 'dev-python/rich')
-rw-r--r--dev-python/rich/Manifest2
-rw-r--r--dev-python/rich/rich-13.9.4.ebuild15
2 files changed, 7 insertions, 10 deletions
diff --git a/dev-python/rich/Manifest b/dev-python/rich/Manifest
index 03dd3409b604..a4cf262100a7 100644
--- a/dev-python/rich/Manifest
+++ b/dev-python/rich/Manifest
@@ -1,3 +1,3 @@
DIST rich-13.9.4.gh.tar.gz 15064359 BLAKE2B bf0bd53f3993fbfa309012b646d293799699040827c160a627fb4dbf292146e43b4a823606a6d9855d835f9739c1d75f539328aa093471db54adff44ef7d4e77 SHA512 36d9f0442759784453a75c9a80cd3dde113db5544d62da1eb85bc0572c16b6247da9b5254246fa571007ce0e70a234aea2ab1ed5dc20c1ec23084070733d39a1
-EBUILD rich-13.9.4.ebuild 2098 BLAKE2B 70f396aca5f5286e4a0a7cd4f6a7e1d4da74a0f5e994d6aa15f5437d6dedda388fbc2d91bef598d1c8dc4e49c1eef639dd30ef67ba4ee1d31a3064541cd98ccf SHA512 33ee42f905e141639f3925f61443af0259507b1228d7e453c1c30f5867498e75aecdda140c00bfe979be3d3a06497a953a5a0afd52dbe4d5b61fcf1ab24ac8dc
+EBUILD rich-13.9.4.ebuild 1856 BLAKE2B ebe506381913a99ca1f51a9ea2c7b54d4b05f509f96006a0efb13012b3bda4e96d3355af89a916895793b4a0b48a6e18878e713b8decc635b33b79ee9567fc57 SHA512 12188863ce9f137e8f466c19b12e59df3d94b1e08976cbfdae8c575fe152b3d397b093d61c8632e54c78458ec77970139f7f971810932d4c3ca431561c3d8c9c
MISC metadata.xml 387 BLAKE2B 049491e034ba233f33c76dc5e3f1b887ba5d2da9d65b09bda51a7cf4eb30a9c66f3ddf714f52407a73e51da78523084064bccd4fc687e0bc0fc2b32dbb4c513b SHA512 448ce879331748e3166f670981a27ee5c3ef20b51af442ccc684cb6514c0d6a0d4e433a8bc1ddb3bdf68c734bac013c1ba04d38adf90644b062231ab1c1d2c0b
diff --git a/dev-python/rich/rich-13.9.4.ebuild b/dev-python/rich/rich-13.9.4.ebuild
index 80df0e3fb36f..3fb0c38348f8 100644
--- a/dev-python/rich/rich-13.9.4.ebuild
+++ b/dev-python/rich/rich-13.9.4.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{10..13} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} pypy3 pypy3_11 )
inherit distutils-r1 optfeature
@@ -44,6 +44,10 @@ python_test() {
tests/test_console.py::test_size_can_fall_back_to_std_descriptors
# TODO: segfault in recursion (PyQt6 interfering?)
tests/test_traceback.py::test_recursive
+ # TODO: some random dep changes?
+ tests/test_markdown.py::test_inline_code
+ tests/test_syntax.py::test_blank_lines
+ tests/test_syntax.py::test_python_render_simple_indent_guides
)
# version-specific output -- the usual deal
case ${EPYTHON} in
@@ -53,16 +57,9 @@ python_test() {
tests/test_inspect.py::test_inspect_integer_with_methods_python310only
)
;;
- python3.13)
+ pypy3.11)
EPYTEST_DESELECT+=(
- tests/test_inspect.py::test_inspect_builtin_function_except_python311
- tests/test_inspect.py::test_inspect_integer_with_methods_python38_and_python39
- tests/test_inspect.py::test_inspect_integer_with_methods_python310only
tests/test_inspect.py::test_inspect_integer_with_methods_python311
- tests/test_pretty.py::test_pretty_dataclass
- tests/test_pretty.py::test_reference_cycle_dataclass
- tests/test_pretty.py::test_max_depth_dataclass
- tests/test_pretty.py::test_attrs_broken
)
;;
esac