summaryrefslogtreecommitdiff
path: root/dev-python/rich
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
commite9d044d4b9b71200a96adfa280848858c0f468c9 (patch)
tree1bd8ef816043a8cd340f1d774e79553a1a7d31d8 /dev-python/rich
parentfc2f1018fc323ef2c6572734a9b130427cba76a6 (diff)
gentoo resync : 13.11.2021
Diffstat (limited to 'dev-python/rich')
-rw-r--r--dev-python/rich/Manifest2
-rw-r--r--dev-python/rich/rich-10.13.0.ebuild27
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/rich/Manifest b/dev-python/rich/Manifest
index 6b846f573e3d..b9960f2cc25b 100644
--- a/dev-python/rich/Manifest
+++ b/dev-python/rich/Manifest
@@ -1,3 +1,5 @@
DIST rich-10.12.0.tar.gz 16265099 BLAKE2B c2249be5a5008e3e9fd5c301b10d7bc544e4805d4762e87481aa31716e38eb3cb2b81ce80f201fc0d3961574136f47b7b374d6bc7d18e4f55f1f757a7e17e5a2 SHA512 bb42ff24c9eeeae548a6e222ecc03f8b46d763c4b022964bd8fb11517f1a23a7aaa82a2155d5cd3d29cdd1af5fab6cc4f26840a84ce5e26dd740f8706961ce1f
+DIST rich-10.13.0.tar.gz 16277448 BLAKE2B e33bca376e1a5b82d0648c7bdda9ce30930b7c095cd8272b573f52dcb056a21be35fb0ef83c939e7feeb458eb4efb7767bf98706a4c58fc134627a0b0f3aa68d SHA512 23ea811fbaa8002416530975fe79c62b42d3c79806d312c172351f632864356be77063d5dc0fe0243d78479fb31a87433a432b115f5cf570f7c6e44c6f773ff0
EBUILD rich-10.12.0.ebuild 743 BLAKE2B 3f9b348de8da37dae056fdb7ac0284fda112d940a3b8e8a91cef075567f9d3243be1869d17eaeb570b64b113a5e3dbd523423c852971f464de55ff948a1b3687 SHA512 c9a18a846ec538dc6cf9f8763084d17e1c560b2ec9e62845c29ed85156362e497e79b447850e7a2b04a5ab67f732534aa037aca441d6be6b43a3b0bbf7f3004e
+EBUILD rich-10.13.0.ebuild 743 BLAKE2B 3f9b348de8da37dae056fdb7ac0284fda112d940a3b8e8a91cef075567f9d3243be1869d17eaeb570b64b113a5e3dbd523423c852971f464de55ff948a1b3687 SHA512 c9a18a846ec538dc6cf9f8763084d17e1c560b2ec9e62845c29ed85156362e497e79b447850e7a2b04a5ab67f732534aa037aca441d6be6b43a3b0bbf7f3004e
MISC metadata.xml 388 BLAKE2B 9d57523a8babbcd81afad320ed91201aa1235a19bcd305b3102888f17d24666fbf94df2eae06af746a62e167c139258088d7116d52064ec022294c7ad4a9cb48 SHA512 a2a11fa0ab987f8b661176e88980dcf7335298d80a3cbe7c910accb9ecd9ee33e3add0389b23224fee88467092298db9176adde09935fd466ebbf97bdc58b8db
diff --git a/dev-python/rich/rich-10.13.0.ebuild b/dev-python/rich/rich-10.13.0.ebuild
new file mode 100644
index 000000000000..05ddc3dab2e6
--- /dev/null
+++ b/dev-python/rich/rich-10.13.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for renrering rich text, tables, etc. to the terminal"
+HOMEPAGE="https://github.com/willmcgugan/rich"
+SRC_URI="https://github.com/willmcgugan/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/commonmark[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "integration with HTML widgets for Jupyter" dev-python/ipywidgets
+}