summaryrefslogtreecommitdiff
path: root/dev-python/roman-numerals-py
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-18 00:14:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-18 00:14:44 +0000
commit5264c18a325553759d67fb4e059db03cf3fc5c81 (patch)
tree588a7d54829b20df6c11016213dad5808b5c706a /dev-python/roman-numerals-py
parent27b3683509c5229cce540418778a8b64afbc0009 (diff)
gentoo auto-resync : 18:02:2025 - 00:14:44
Diffstat (limited to 'dev-python/roman-numerals-py')
-rw-r--r--dev-python/roman-numerals-py/Manifest3
-rw-r--r--dev-python/roman-numerals-py/metadata.xml12
-rw-r--r--dev-python/roman-numerals-py/roman-numerals-py-2.0.0.ebuild21
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/roman-numerals-py/Manifest b/dev-python/roman-numerals-py/Manifest
new file mode 100644
index 000000000000..8d7ae96a1173
--- /dev/null
+++ b/dev-python/roman-numerals-py/Manifest
@@ -0,0 +1,3 @@
+DIST roman_numerals_py-2.0.0.tar.gz 8747 BLAKE2B 55998af1542f61aa0ac8a6bdf11aa6c4ef99f91a8d72df0194659f7b679a07b69f2a67ed71beca373d6c3c8843fd9c7149918755cb97ceaea3d6d9153321e5fd SHA512 c67d0f0c8244449694693c081a5291da7742ad19ede1447da06526bc8edb0f7f20b4778040f052ad104d6c5079c63fd052197fb2f0414d855c9531faa20b2041
+EBUILD roman-numerals-py-2.0.0.ebuild 457 BLAKE2B 169ff12f3e0e9a86e905196345b252b7003451891fea56f70b994476cd03ae1f5bb00eb87782e599cba3e8257e080360019b6474195135d3be2bdde0c4bc7cb8 SHA512 f67d59c940ed881e9876b10ccbf82ed8be35b0d3fcea6592371edcf46b6828de56dad472f0f8ff187db171ea15171285f85930cda03209768f82babdcf0ac21f
+MISC metadata.xml 387 BLAKE2B 785d894a66c3b4a1d14fdb4510b8573c7d3eabb25ea22f61f6b66b4cf2d60ade26ba397d0b0a59899a06e870bc299b9f97b11982ebb7eef26e471a5a25f8ff23 SHA512 dc0901ddf30c3c719ec84bac2cdae8db65abb317ce308daa869956f3c0d4bac791e1a5dff69cb077c2fde04bdd4fdf77c23936f6f6918299beb1157cc74d1681
diff --git a/dev-python/roman-numerals-py/metadata.xml b/dev-python/roman-numerals-py/metadata.xml
new file mode 100644
index 000000000000..5510aeea4eda
--- /dev/null
+++ b/dev-python/roman-numerals-py/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">AA-Turner/roman-numerals</remote-id>
+ <remote-id type="pypi">roman-numerals-py</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/roman-numerals-py/roman-numerals-py-2.0.0.ebuild b/dev-python/roman-numerals-py/roman-numerals-py-2.0.0.ebuild
new file mode 100644
index 000000000000..b4e159b8f1df
--- /dev/null
+++ b/dev-python/roman-numerals-py/roman-numerals-py-2.0.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 pypy3_11 python3_{10..13} python3_13t )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Manipulate roman numerals"
+HOMEPAGE="
+ https://github.com/AA-Turner/roman-numerals/
+ https://pypi.org/project/roman-numerals-py/
+"
+
+LICENSE="|| ( 0BSD CC0-1.0 )"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest