summaryrefslogtreecommitdiff
path: root/dev-python/rootpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/rootpy
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/rootpy')
-rw-r--r--dev-python/rootpy/Manifest5
-rw-r--r--dev-python/rootpy/metadata.xml16
-rw-r--r--dev-python/rootpy/rootpy-0.8.3.ebuild46
-rw-r--r--dev-python/rootpy/rootpy-1.0.1.ebuild46
4 files changed, 113 insertions, 0 deletions
diff --git a/dev-python/rootpy/Manifest b/dev-python/rootpy/Manifest
new file mode 100644
index 000000000000..84777dad4812
--- /dev/null
+++ b/dev-python/rootpy/Manifest
@@ -0,0 +1,5 @@
+DIST rootpy-0.8.3.tar.gz 417400 BLAKE2B a8120d7005082be96901820d602abfc43bbac5d797d41a8bc215fef36ed37e3bc7b797e0d4ca084ba45b840dcf8eb4afcdfb454f8c801bdf1edec146f3f9ac38 SHA512 b1d3c17fb0a6dfe36bdf3d9a345fc55af8a102d33433c951581f9a61babf377fabb1ae486c78b2d4654cbc7320de122fb3075f27a1565655a3dc17c2b4f56df6
+DIST rootpy-1.0.1.tar.gz 418618 BLAKE2B ce321e69d7e202877697d133ad2ba90df71cd261b206211718cb6a9ec8ee3ec085cac49526b9bb75166fafeb43f83b3f53bf231d9353f3d63fa7e4be381ce454 SHA512 db1c7edc02d1cd5a4a1940237c1e1c63d892bb92e612bdad028d14f9723a4bdc5f9b6711a135b0e099ce1895b2564b29aeb21ef0d2c3681354bf4edc9c6a325f
+EBUILD rootpy-0.8.3.ebuild 1062 BLAKE2B 85317c47af89837c58cc560db31d2f6c3266b52065a92536326e995527c45eaffaf16d03108530fd147a790e2b4196b512fa9c860e3f202c19897ca47fa61b50 SHA512 16c48103cdb703323a87757396e731abef22238dd40103ea4e389a5c07e8dc27e20527b5cf58bd5eba1d7bdc1e85249fe76c92eb01774f11f8f08fb99679822e
+EBUILD rootpy-1.0.1.ebuild 1070 BLAKE2B c1726eb00f1370fdb555e74a3c4b65b8447d8643f4729b9324d68f50e5732aacfa61d66087700322a492384ef25c4d40e4d5041546cc4f71c6a5038eca1258b8 SHA512 c16fb4e31cf7731b138e4733915831bc929c4eb820944552b4538371b9eb5b4926ccdc67af327b3a9d388b952e19df751ef89f434d18dd979450d689b2615e99
+MISC metadata.xml 525 BLAKE2B add8ec7423df97b01b5b9cad45c04339bd8aa2fcd62be3bbae15b66d9520603d7ad9c31232a7215fe68cf706f28348be54b38ca8bd05923a677b6c26ecafa7fa SHA512 6987f42215b8a3160a7e292499f63e26c05c8ffef69f7ade03fb4b539fb0116f14d7204602264e237d5c4e75436794770061c4d0d508072c06e24c1eec500094
diff --git a/dev-python/rootpy/metadata.xml b/dev-python/rootpy/metadata.xml
new file mode 100644
index 000000000000..3728d7ab174f
--- /dev/null
+++ b/dev-python/rootpy/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>sci-physics@gentoo.org</email>
+ <name>Gentoo Physics Project</name>
+</maintainer>
+<longdescription lang="en">
+ The rootpy project is a community-driven initiative aiming to provide
+ a more pythonic interface with ROOT on top of the existing PyROOT
+ bindings.
+</longdescription>
+<upstream>
+ <remote-id type="pypi">rootpy</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/dev-python/rootpy/rootpy-0.8.3.ebuild b/dev-python/rootpy/rootpy-0.8.3.ebuild
new file mode 100644
index 000000000000..9823bde1b34e
--- /dev/null
+++ b/dev-python/rootpy/rootpy-0.8.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="readline"
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="Pythonic layer on top of the ROOT framework's PyROOT bindings"
+HOMEPAGE="http://rootpy.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples test"
+
+RDEPEND="
+ sci-physics/root[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pytables[${PYTHON_USEDEP}]
+ dev-python/root_numpy[${PYTHON_USEDEP}]
+ dev-python/termcolor[${PYTHON_USEDEP}]"
+
+DEPEND="
+ sci-physics/root[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+# TOFIX: tests go in an infinite loop error
+RESTRICT=test
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+ nosetests -v || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/dev-python/rootpy/rootpy-1.0.1.ebuild b/dev-python/rootpy/rootpy-1.0.1.ebuild
new file mode 100644
index 000000000000..b4efcde380e3
--- /dev/null
+++ b/dev-python/rootpy/rootpy-1.0.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_6} )
+PYTHON_REQ_USE="readline"
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="Pythonic layer on top of the ROOT framework's PyROOT bindings"
+HOMEPAGE="http://rootpy.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples test"
+
+RDEPEND="
+ sci-physics/root:=[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pytables[${PYTHON_USEDEP}]
+ dev-python/root_numpy[${PYTHON_USEDEP}]
+ dev-python/termcolor[${PYTHON_USEDEP}]"
+
+DEPEND="
+ sci-physics/root[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+# TOFIX: tests go in an infinite loop error
+RESTRICT=test
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+ nosetests -v || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}