summaryrefslogtreecommitdiff
path: root/dev-python/rope
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-03 06:31:16 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-03 06:31:16 +0000
commit5087ee3bf0055aae666159351774f2fb3610e571 (patch)
tree203f4d869518e7391a255055ca9a4b874e7b2d19 /dev-python/rope
parentff733bfb4d0bd82175e03255004faef8721b53ea (diff)
gentoo auto-resync : 03:01:2025 - 06:31:16
Diffstat (limited to 'dev-python/rope')
-rw-r--r--dev-python/rope/Manifest2
-rw-r--r--dev-python/rope/files/rope-1.13.0-python3.13.patch55
-rw-r--r--dev-python/rope/rope-1.13.0-r1.ebuild48
3 files changed, 105 insertions, 0 deletions
diff --git a/dev-python/rope/Manifest b/dev-python/rope/Manifest
index 36a05f030931..dacfe336b284 100644
--- a/dev-python/rope/Manifest
+++ b/dev-python/rope/Manifest
@@ -1,3 +1,5 @@
+AUX rope-1.13.0-python3.13.patch 1815 BLAKE2B 5c03762d2066acea76a02bc9be8272216964576bf8967316180ec4d28bc7970cbb3fe0cfa14d61e721d32c62dff3f221f0559685522ec425eb71a55ef3f153ea SHA512 f9a501580d21a44aacaeaf577064e14970d6fe781d955408224430143242e22d4239be4cf97adcb88318116efc3a590c3f4954dc8c4b5f9e48a6b5cdacefb080
DIST rope-1.13.0.tar.gz 294457 BLAKE2B 6d859f9a5d09734ef90398671a3ef3c8564f2a8b1d03a064d22161ac7deeceefb38849cd6940a53f61f20199c27edc5ef5e88d59336cfd69f4da22685c705356 SHA512 2f150d8b56165dd3cffc3f41d94394b5f44d7d6274859d7b460c6e61b99cb9d9630f3540940fa97bcd1238fa8a799cf9c80f2d9b5b7fd6a690cebabadf775db4
+EBUILD rope-1.13.0-r1.ebuild 1257 BLAKE2B 0b9b009435d7fbcad1a0f1e7a3eba32420001c4892d4c8fc6b8d73053bab469d7c263914e1ffa5ef15a82b168cc7f2ee4f79177de6b6aac2dc2c11ddddbe9ed4 SHA512 33614e4b18de24d641b9790c5962f54f0385dd7770f6e0f1b6caf644533e28d6c75b386dc3c35efffaaf0436eb3ced0f613f976f2ed1601099e39cd10836c673
EBUILD rope-1.13.0.ebuild 1148 BLAKE2B b8a9b4e5e4e869c75adb0055410e67faca0b773ee85afe6a32e0717e523aba6873c91bde4a4382312e6110d9dfdcd6a81371ddd0af82d193c97a9e392821dd69 SHA512 0cba1eac4ddb2a5b57096622f514219d9a882b44686d310c6c9081e63ad4d5a7f493f95c41355dbec03d39373502643dc04ec30afd112cbacc9a5ecfcdf724ba
MISC metadata.xml 452 BLAKE2B 6bee424d801bad8728f10ec3a1618e3a48776a7b0af2a04efafd07e6ae5ac8e0b88253ebc35e457c791e820f8c3b1dabde73aabbfd3636cac5e169e8aca75aa7 SHA512 4f88e1157e4838f321b6f208ba6b89fbf2b7a72ea6e038cdd6cf3e9e211c2788dda137e3adf76072c1d52026c554750193d9938054670dd995a91db24ea8da76
diff --git a/dev-python/rope/files/rope-1.13.0-python3.13.patch b/dev-python/rope/files/rope-1.13.0-python3.13.patch
new file mode 100644
index 000000000000..6c1e6deb47a4
--- /dev/null
+++ b/dev-python/rope/files/rope-1.13.0-python3.13.patch
@@ -0,0 +1,55 @@
+diff --git a/rope/base/oi/type_hinting/utils.py b/rope/base/oi/type_hinting/utils.py
+index b0a7aff97..2381c8472 100644
+--- a/rope/base/oi/type_hinting/utils.py
++++ b/rope/base/oi/type_hinting/utils.py
+@@ -1,6 +1,7 @@
+ from __future__ import annotations
+
+ import logging
++import sys
+ from typing import TYPE_CHECKING, Optional, Union
+
+ import rope.base.utils as base_utils
+@@ -81,7 +82,10 @@ def resolve_type(
+ """
+ Find proper type object from its name.
+ """
+- deprecated_aliases = {"collections": "collections.abc"}
++ if sys.version_info < (3, 13):
++ deprecated_aliases = {"collections": "collections.abc"}
++ else:
++ deprecated_aliases = {"collections": "_collections_abc"}
+ ret_type = None
+ logging.debug("Looking for %s", type_name)
+ if "." not in type_name:
+
+diff --git a/rope/contrib/autoimport/sqlite.py b/rope/contrib/autoimport/sqlite.py
+index 54a6d03cf..f06fdaca3 100644
+--- a/rope/contrib/autoimport/sqlite.py
++++ b/rope/contrib/autoimport/sqlite.py
+@@ -569,14 +569,17 @@ def filter_folders(folder: Path) -> bool:
+ return list(OrderedDict.fromkeys(folder_paths))
+
+ def _safe_iterdir(self, folder: Path):
+- dirs = folder.iterdir()
+- while True:
+- try:
+- yield next(dirs)
+- except PermissionError:
+- pass
+- except StopIteration:
+- break
++ try:
++ dirs = folder.iterdir()
++ while True:
++ try:
++ yield next(dirs)
++ except PermissionError:
++ pass
++ except StopIteration:
++ break
++ except PermissionError:
++ pass
+
+ def _get_available_packages(self) -> List[Package]:
+ packages: List[Package] = [
diff --git a/dev-python/rope/rope-1.13.0-r1.ebuild b/dev-python/rope/rope-1.13.0-r1.ebuild
new file mode 100644
index 000000000000..33e3ad7738ee
--- /dev/null
+++ b/dev-python/rope/rope-1.13.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python refactoring library"
+HOMEPAGE="
+ https://pypi.org/project/rope/
+ https://github.com/python-rope/rope/
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-python/pytoolconfig-1.2.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/build[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ # https://github.com/python-rope/rope/pull/809
+ "${FILESDIR}/${PN}-1.13.0-python3.13.patch"
+)
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # our venv style confuses this comparison
+ ropetest/contrib/autoimport/utilstest.py::test_get_package_source_typing
+ ropetest/contrib/autoimport/utilstest.py::test_get_package_tuple_typing
+ ropetest/contrib/autoimport/utilstest.py::test_get_package_tuple_compiled
+ # TODO
+ ropetest/contrib/autoimport/autoimporttest.py::TestQueryUsesIndexes::test_search_by_name_like_uses_index
+ ropetest/contrib/autoimport/autoimporttest.py::TestQueryUsesIndexes::test_search_module_like_uses_index
+)