summaryrefslogtreecommitdiff
path: root/dev-python/rope
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-30 07:42:23 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-30 07:42:23 +0100
commit560c9b9748b885a005f22dac90f6e2622fe9ead5 (patch)
tree9eb65efc966093e8a40428f27a93ca0807af1d29 /dev-python/rope
parent38c20fb51b0482ec1b2c2a34ed16227718eac4b2 (diff)
gentoo auto-resync : 30:06:2023 - 07:42:22
Diffstat (limited to 'dev-python/rope')
-rw-r--r--dev-python/rope/Manifest2
-rw-r--r--dev-python/rope/rope-1.9.0.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/rope/Manifest b/dev-python/rope/Manifest
index ac7e6534a867..26f489420eae 100644
--- a/dev-python/rope/Manifest
+++ b/dev-python/rope/Manifest
@@ -1,3 +1,5 @@
DIST rope-1.8.0.tar.gz 297235 BLAKE2B e9849b75b3ec640201b30318863066b969b5ebde98522c3c09f70bcc344bce5f604601bd155ed0ce6fb3eebb392ea3669f77fb2da21c11078e1041ae13464fd8 SHA512 2fa8e56d6d7fd0a15acb16a1fe27db89d9c2dd6f93fabd448509a112a6ef7f3dfdd4d3d544cf1218149c7a7fa1db9908b107b6eae6e89299f32c0d1586ceaf4e
+DIST rope-1.9.0.tar.gz 298227 BLAKE2B c136678bdd9d580d0f0ada93e5c61b963bfe5b9867b39f8c9ba35578f4c8b2ebca1031d00bea4bf2f10ebdf300bc4920827a3325a5c26498efb3e6a4af5b016a SHA512 fd8cc75c70814afc427fbccbe8a1389773737ee664a42a43bb2fb7e7ff667fac4680d233c751ee15b03e41b60ba270b3cf48b1a766420468e4a7c974e4c0158c
EBUILD rope-1.8.0.ebuild 895 BLAKE2B cadb2ef59fafc5ad7f0d0167b0f13e05e1455cf4113332df3e4296145ee552c5972d1042ab186477c57e082c9f34cbd9bff36886980d3b295a74a217df795c8e SHA512 7b5a442a81b96b1155ffc14c3f3f9e972c8e6099900746d47a914a328391c9be1308a682edb8ecac9ec2a46a2d0b4130e11a986da7a9c253b44bdbcf183821ba
+EBUILD rope-1.9.0.ebuild 897 BLAKE2B 7006f8aa45fa1578cbb0c88b94801a274981a4de2330140facd36ca6825e3c19e9132aab0e28378e95caea9b623ee6a44fb9cd940d37da0415b7da762d99779f SHA512 97a69715f1e35fc57467b69cd037f5e96ff4e4e1d44ed3faaecfc9d8c0bd1fc17174705180f662edbc00d8354c35f77f6a2f5c9c87cd232ebba73273a218fc75
MISC metadata.xml 452 BLAKE2B 6bee424d801bad8728f10ec3a1618e3a48776a7b0af2a04efafd07e6ae5ac8e0b88253ebc35e457c791e820f8c3b1dabde73aabbfd3636cac5e169e8aca75aa7 SHA512 4f88e1157e4838f321b6f208ba6b89fbf2b7a72ea6e038cdd6cf3e9e211c2788dda137e3adf76072c1d52026c554750193d9938054670dd995a91db24ea8da76
diff --git a/dev-python/rope/rope-1.9.0.ebuild b/dev-python/rope/rope-1.9.0.ebuild
new file mode 100644
index 000000000000..d3ca80b1d3ec
--- /dev/null
+++ b/dev-python/rope/rope-1.9.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python refactoring library"
+HOMEPAGE="
+ https://pypi.org/project/rope/
+ https://github.com/python-rope/rope/
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-python/pytoolconfig-1.2.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/build[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # our venv style confuses this comparison
+ ropetest/contrib/autoimport/utilstest.py::test_get_package_source_typing
+ ropetest/contrib/autoimport/utilstest.py::test_get_package_tuple_typing
+ ropetest/contrib/autoimport/utilstest.py::test_get_package_tuple_compiled
+)