summaryrefslogtreecommitdiff
path: root/dev-python/ropemacs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/ropemacs
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/ropemacs')
-rw-r--r--dev-python/ropemacs/Manifest5
-rw-r--r--dev-python/ropemacs/metadata.xml16
-rw-r--r--dev-python/ropemacs/ropemacs-0.8.ebuild31
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/ropemacs/Manifest b/dev-python/ropemacs/Manifest
new file mode 100644
index 000000000000..764ab18670eb
--- /dev/null
+++ b/dev-python/ropemacs/Manifest
@@ -0,0 +1,5 @@
+DIST ropemacs-0.8.tar.gz 22161 SHA256 e1ae9691d402eaa525f56d37f5fefff8b8fe9892188e49600d01063a5acb535f SHA512 3e42ce03758c13d8f6e66b69a4b9ab7620956ed0272ecf770c0cea204ffae8c85f41103b29e507db7d68d6dc006b14e6ca5ce31d8ca17b6a66bf743f1110a9b3 WHIRLPOOL 5632799ace9e3c0a40342b3d7be5da3f5763a290931a84fa464bed214cd18c2968b58ee209868e2977524b3cf9bce48fb32f0aeab0897ad9df1cac80e81f838b
+EBUILD ropemacs-0.8.ebuild 834 SHA256 aef47585e452b4a5786597e50f599116f4dfad75a6da56b160118fa45ce5f64e SHA512 6669d5bf07c2bea7f37a482f6de3d09b31326930b8fb032f4594a4fe7e48b14a93f733e78f2c57c08437e3959af2b09813f6130695d18ea5637670f8dfe45fb7 WHIRLPOOL de0ca86d4e2c928e555d03bdd5173a083160e5e5572c52dae46a3d9884887c8ed4cbade8f0b4c15347a02039941f52d8fe5321659dc8395cb1bd1a12ddacc54d
+MISC ChangeLog 3317 SHA256 bd0a0cb8675d53dfebf546e48514402a700fe0ebbe2d3f36fa7fe2f0b3831004 SHA512 e02fc1352fa688ea8b8731bb86dae518e8cc6a745e435ff49e21bbc89350d6f3849863c7fea1990650083cea37a19fbe57d1ba19c503c8c655e244b2ab5fdd09 WHIRLPOOL 69971d2f36dcf6a74c286bd607acdc3321d367501d2f63b8f5ad65d36affa456ffb46e9aa19a63a7220aa84428509b6762a5e0fa223a7d077c9849bcdf224e06
+MISC ChangeLog-2015 1030 SHA256 4680c577d70714db3d14d379fbc6274577282f5d894e73a061677130ae0db26f SHA512 891fbb660bb8afdb46be9e94155dbed6b83efdee8b084e5f74baefa3f5b3bde31baf95d9b70623a808bb0db12a012eafc6f2ffd4126ad0aa9f1354513a40b57c WHIRLPOOL da4cbb213c7aa0fff2a8338f78213e37e4e29b7eb1248fcd0565fa0f04d69aab4d4a914cb6df7048ae1cb5d83e0bfa88b9bc94b0c520f4e6390755602542715e
+MISC metadata.xml 476 SHA256 406ea91e0e09fc5f4c9adb91ad1ed5f462af9f92e44e345d5a80c855ecec72ed SHA512 2f7eb5e71660ad51be770eee8352df5995e4599d50a43f394cb1f532444fc52be98cf6cd9e6d4ccbc1f1067ac36a66e430d1eec12de68f03e3a9d96eda7e6782 WHIRLPOOL 98867dc4c308e311f14f2c8c1b80cd1212fae747faf74582b75ce54b81b4d4ba3ed3c445d66178bae9d11524fefdee01818347a8bddbcd533d16979ff616f202
diff --git a/dev-python/ropemacs/metadata.xml b/dev-python/ropemacs/metadata.xml
new file mode 100644
index 000000000000..f3a018c56488
--- /dev/null
+++ b/dev-python/ropemacs/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+</maintainer>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<upstream>
+ <remote-id type="pypi">ropemacs</remote-id>
+ <remote-id type="sourceforge">rope</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/dev-python/ropemacs/ropemacs-0.8.ebuild b/dev-python/ropemacs/ropemacs-0.8.ebuild
new file mode 100644
index 000000000000..4413ac115e15
--- /dev/null
+++ b/dev-python/ropemacs/ropemacs-0.8.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils readme.gentoo
+
+DESCRIPTION="Rope in Emacs"
+HOMEPAGE="https://github.com/python-rope/ropemacs
+ https://pypi.python.org/pypi/ropemacs"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-1+" # GPL without version
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/rope[${PYTHON_USEDEP}]
+ dev-python/ropemode[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ local DOCS="${DOCS} README.rst docs/*.rst"
+ distutils-r1_src_install
+
+ DOC_CONTENTS="In order to enable ropemacs support in Emacs, install
+ app-emacs/pymacs and add the following line to your ~/.emacs file:
+ \\n\\t(pymacs-load \"ropemacs\" \"rope-\")"
+ readme.gentoo_create_doc
+}