summaryrefslogtreecommitdiff
path: root/dev-python/rosdistro/rosdistro-0.8.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
commitc719fdcee603a5a706a45d10cb598762d56a727d (patch)
tree620cbf137661399a3fb1eff92914204f9a970713 /dev-python/rosdistro/rosdistro-0.8.3.ebuild
parentcc4618c9ba3d974948ebf340b542d8cb01db2f55 (diff)
gentoo resync : 25.09.2021
Diffstat (limited to 'dev-python/rosdistro/rosdistro-0.8.3.ebuild')
-rw-r--r--dev-python/rosdistro/rosdistro-0.8.3.ebuild18
1 files changed, 5 insertions, 13 deletions
diff --git a/dev-python/rosdistro/rosdistro-0.8.3.ebuild b/dev-python/rosdistro/rosdistro-0.8.3.ebuild
index 8bd21ec57713..87bc969239f4 100644
--- a/dev-python/rosdistro/rosdistro-0.8.3.ebuild
+++ b/dev-python/rosdistro/rosdistro-0.8.3.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{3_7,3_8,3_9} )
+
+PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_USE_SETUPTOOLS=rdepend
SCM=""
@@ -24,31 +25,22 @@ fi
LICENSE="BSD"
SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="
dev-python/catkin_pkg[${PYTHON_USEDEP}]
dev-python/rospkg[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
+ dev-python/pyyaml[${PYTHON_USEDEP}]"
BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
-"
-DEPEND="${RDEPEND}
test? (
dev-python/mock[${PYTHON_USEDEP}]
)
"
PATCHES=( "${FILESDIR}/yaml.patch" )
+distutils_enable_tests nose
+
src_prepare() {
# Requires network access
rm -f test/test_manifest_providers.py
default
}
-
-python_test() {
- nosetests --with-xunit test || die
-}