summaryrefslogtreecommitdiff
path: root/dev-python/rosdistro
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/rosdistro
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/rosdistro')
-rw-r--r--dev-python/rosdistro/Manifest6
-rw-r--r--dev-python/rosdistro/metadata.xml11
-rw-r--r--dev-python/rosdistro/rosdistro-0.6.6.ebuild43
-rw-r--r--dev-python/rosdistro/rosdistro-0.6.8.ebuild43
-rw-r--r--dev-python/rosdistro/rosdistro-9999.ebuild43
5 files changed, 146 insertions, 0 deletions
diff --git a/dev-python/rosdistro/Manifest b/dev-python/rosdistro/Manifest
new file mode 100644
index 000000000000..0b6f7af7aa46
--- /dev/null
+++ b/dev-python/rosdistro/Manifest
@@ -0,0 +1,6 @@
+DIST rosdistro-0.6.6.tar.gz 58881 BLAKE2B 9daa5c08b97509606d5077f55e8a85d2cd278f69aebff22feefd9661d455f38cff549ee26f894b040cad7192f044828a20cf749d83a257a8b5604f07d382f081 SHA512 2a4b0dfcaa43a8e4d4a0fff5ed204ad81317156128d9050e0c67dfe2cd9efda2bfc84f454e424ebd457e7c62c7c6add113ceb31e99310c34a9fc9f206e510922
+DIST rosdistro-0.6.8.tar.gz 59771 BLAKE2B 5610ef992824104570abc8c5cc0224838ee1442d942f8f317b20b300831f7536649b47360e7f542e484d75eac29af71ce9e82fadf91b540f4671478039776921 SHA512 57db65b7cba29e41c14ea4e45f951a410e6152ce4247afd1b15df51cd79e50bdbc95151eac02acc666f8bc3c2658695600ad1b4fc0f4152d71901685c9e8f558
+EBUILD rosdistro-0.6.6.ebuild 979 BLAKE2B fa07155748189f0377c4ee69288f0d876d77bd8b8ed4f942abd309fcce01db3e890da5012c5c85110fc3e00724bfafc1bf32f53d5581557887102bd1407990c6 SHA512 ead56ec46c5e25727911212be51bffd567e5b84507984ab74221b5fb4107b95e17c2f1a8f51110fc70c361cd41f3e2d881dc7d9c9f42b4f911011e4443ba5bac
+EBUILD rosdistro-0.6.8.ebuild 979 BLAKE2B fa07155748189f0377c4ee69288f0d876d77bd8b8ed4f942abd309fcce01db3e890da5012c5c85110fc3e00724bfafc1bf32f53d5581557887102bd1407990c6 SHA512 ead56ec46c5e25727911212be51bffd567e5b84507984ab74221b5fb4107b95e17c2f1a8f51110fc70c361cd41f3e2d881dc7d9c9f42b4f911011e4443ba5bac
+EBUILD rosdistro-9999.ebuild 979 BLAKE2B fa07155748189f0377c4ee69288f0d876d77bd8b8ed4f942abd309fcce01db3e890da5012c5c85110fc3e00724bfafc1bf32f53d5581557887102bd1407990c6 SHA512 ead56ec46c5e25727911212be51bffd567e5b84507984ab74221b5fb4107b95e17c2f1a8f51110fc70c361cd41f3e2d881dc7d9c9f42b4f911011e4443ba5bac
+MISC metadata.xml 342 BLAKE2B 1975e171b6e686c5fa1cf51909101b1785f2610f619de6465329c935023adcbe5d0373512bf7e7fb5a2451e31664faeb2aed67eb9af58d40005f10ee1582e4f9 SHA512 5f55e6edbfd3be1214791b1897ce625f6cc52989ac007d7de9c9eb0bff57c1ca805ee18b911fcc2c29a86a5fb9f68e1b9647f69a38dc6b1d1d74334b35ac106d
diff --git a/dev-python/rosdistro/metadata.xml b/dev-python/rosdistro/metadata.xml
new file mode 100644
index 000000000000..552fe0204755
--- /dev/null
+++ b/dev-python/rosdistro/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros-infrastructure/rosdistro</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/rosdistro/rosdistro-0.6.6.ebuild b/dev-python/rosdistro/rosdistro-0.6.6.ebuild
new file mode 100644
index 000000000000..8780e241c60c
--- /dev/null
+++ b/dev-python/rosdistro/rosdistro-0.6.6.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ros-infrastructure/rosdistro"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Tools to work with catkinized rosdistro files"
+HOMEPAGE="http://wiki.ros.org/rosdistro"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/ros-infrastructure/rosdistro/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/catkin_pkg[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ nosetests --with-xunit test || die
+}
diff --git a/dev-python/rosdistro/rosdistro-0.6.8.ebuild b/dev-python/rosdistro/rosdistro-0.6.8.ebuild
new file mode 100644
index 000000000000..8780e241c60c
--- /dev/null
+++ b/dev-python/rosdistro/rosdistro-0.6.8.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ros-infrastructure/rosdistro"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Tools to work with catkinized rosdistro files"
+HOMEPAGE="http://wiki.ros.org/rosdistro"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/ros-infrastructure/rosdistro/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/catkin_pkg[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ nosetests --with-xunit test || die
+}
diff --git a/dev-python/rosdistro/rosdistro-9999.ebuild b/dev-python/rosdistro/rosdistro-9999.ebuild
new file mode 100644
index 000000000000..8780e241c60c
--- /dev/null
+++ b/dev-python/rosdistro/rosdistro-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ros-infrastructure/rosdistro"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Tools to work with catkinized rosdistro files"
+HOMEPAGE="http://wiki.ros.org/rosdistro"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/ros-infrastructure/rosdistro/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/catkin_pkg[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ nosetests --with-xunit test || die
+}