summaryrefslogtreecommitdiff
path: root/dev-python/rq
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-14 04:04:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-14 04:04:03 +0100
commit2916cf6049cf9d3092021e247d56c580df6029a7 (patch)
treec796a6fc8b6fd0e4fd5ac06b009000b438fed7d9 /dev-python/rq
parent7b5306e0d287565138e8b051e32f57e6af6ae0ed (diff)
gentoo auto-resync : 14:10:2024 - 04:04:03
Diffstat (limited to 'dev-python/rq')
-rw-r--r--dev-python/rq/Manifest2
-rw-r--r--dev-python/rq/rq-1.16.2.ebuild13
2 files changed, 12 insertions, 3 deletions
diff --git a/dev-python/rq/Manifest b/dev-python/rq/Manifest
index fa373d140550..6e56ca4beadb 100644
--- a/dev-python/rq/Manifest
+++ b/dev-python/rq/Manifest
@@ -1,3 +1,3 @@
DIST rq-1.16.2.tar.gz 629881 BLAKE2B 69ac4ba43ea79ddf998bc9f7cf0fc5fa42acb0315dff663b1c924498ccfabdd37ac6d9613e128b838b9e1f45988632a337fb2fa50f5adcd1b69aa520b5ad33e2 SHA512 1c3162b1acffc9d11292fcbff7177267272a02e752b5839a4004b875bb5bb25af7e61f31041df438ef4e0e47152296c3a2711856c6a36d787848dcb766387d1a
-EBUILD rq-1.16.2.ebuild 1332 BLAKE2B 25c91449e4e3731b5c54933b123953d0cd61de460a2537fa1607fdbfd71c351a555f7e61ece09f3ff9808c9057cffef038338f86710df471e2c607c9c328d682 SHA512 805c437c27a3235ef41213ce482da8616ebcd6d2750029f9f5b52bba2289e78a3ef9af85db3c940f13b3be08c8242a7544bb3877253ff7065b211bfa120c8887
+EBUILD rq-1.16.2.ebuild 1472 BLAKE2B 5069ef150732873a25c3d4f73e8c699e267dc28d2cc304afcb6f9aeda696fb08503fa3b3e1a12ef6cbe3da0d0fda9b597f15487c3b0b7f7eb6cc51bff0953fc4 SHA512 33dc640b0aced4501582d728d3ad977bf7f406c6f09b06d22e3ef00b121a6ea84f2b5e678c72c561fa67737fa12579725bda49c4b6144c391d0c02ff723ae4d2
MISC metadata.xml 453 BLAKE2B 6a46d43b524fded1ad4749fb9669ea07f8b3e23940d0bf2a4db5d92564316b01fdfbe220771e30b1a110ef72c613ad683cdcb7940682ea32198a5b6f027e4db3 SHA512 104ef96c34b55a9fda377c1304ff85781219fdbccef1a83d1bef30cb2fbd0ef816cfe82715af8937f452499135f7ed65c65a29c34919a09b6144ada367c26af5
diff --git a/dev-python/rq/rq-1.16.2.ebuild b/dev-python/rq/rq-1.16.2.ebuild
index 936514338ab0..b4c12356976c 100644
--- a/dev-python/rq/rq-1.16.2.ebuild
+++ b/dev-python/rq/rq-1.16.2.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{11..12} )
+PYTHON_COMPAT=( python3_{11..13} )
inherit distutils-r1 pypi
@@ -27,7 +27,6 @@ BDEPEND="
test? (
dev-db/redis
dev-python/psutil[${PYTHON_USEDEP}]
- <dev-python/sentry-sdk-2[${PYTHON_USEDEP}]
)
"
@@ -55,3 +54,13 @@ src_test() {
# Clean up afterwards
kill "$(<"${redis_pid}")" || die
}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires <sentry-sdk-2
+ tests/test_sentry.py::TestSentry::test_failure_capture
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}