summaryrefslogtreecommitdiff
path: root/dev-python/rst-linker
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-python/rst-linker
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-python/rst-linker')
-rw-r--r--dev-python/rst-linker/Manifest2
-rw-r--r--dev-python/rst-linker/rst-linker-2.3.0.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/rst-linker/Manifest b/dev-python/rst-linker/Manifest
index f136d62fdd4e..0e155446068b 100644
--- a/dev-python/rst-linker/Manifest
+++ b/dev-python/rst-linker/Manifest
@@ -1,3 +1,5 @@
DIST rst.linker-2.2.0.tar.gz 14339 BLAKE2B fedeb8deea3ba3dc1f084a08476d2117787dd33c3ff2cd4c7881283e3c3e6813ffc143373812adfb4e578d21034d2c287a5af2b1e3dc9ae2f087cae9364d2ce3 SHA512 3e51103eb5111e1dd6e4e6f8c546a366eeb669d27b050de41a0580ac992117c530c322ed7cf31fd26a2f4a872ce8a7a41e801630e9291a6a644befd7272351a1
+DIST rst.linker-2.3.0.tar.gz 10146 BLAKE2B a2c1a97a8e734644f5124f89878d770d186c16a44d1eaa98281592754e0a8db4be1e019001448890e712b4e4fea3f4a0f0675009d5285ae94483ef8e8d34ae6f SHA512 a4190c3349c85ee52d17498c99c7879be3f0a98cfc0b5966cc2f6161f9b374d52a64be7035691256d96d4c2ebb2272d5d10802e5e716efedf78859e418e561e0
EBUILD rst-linker-2.2.0-r1.ebuild 796 BLAKE2B 5f58b99b749d02902289e6ecb3e0deca2f46e3d266a09c3f054f1c60ab085c79d12912dc7988d07f2315e47cc748a2f54a4d13508023f9e43a7511caedf1e651 SHA512 8810804adb79d7fec6ff25582c41fa2635a2183be5be4c0c2a6cd2a29f8b0ba58a3139a58854d4048de26af6b2aabc061e17e674017ef004d4174588755d5551
+EBUILD rst-linker-2.3.0.ebuild 770 BLAKE2B 18c38e3a95978639fccfb43c8ecc5b7949ee795aa72c9154db06a9a12039ac6a60ce5e067624b4af0f6b95223e39e63831b7f17aa601734dd9afa3ebf5782f6a SHA512 57547176fc3cb0a29a9dedd3d7877568468448cd41cc8d6645a267c7859cd9e0a4c4a1cff63f39042e1bdbfb7a75a625dc7bd3779e8da95e56c308c127aff346
MISC metadata.xml 465 BLAKE2B b8b71e857bae63cd24248002a557047895ac4f19937b5854920738c3c3b67a424d7d705cb42f203061d6eae63acdd9d0a3c564fedc6f0f7a22567498c9963dc2 SHA512 bbaef22ff0b07cc50559a1c718e240832ff3640053aff3483f3d5615a864c5a176bf77f6077a7f691390c794949448517ab017c75026fdbc8ffe7f9cebeeaefd
diff --git a/dev-python/rst-linker/rst-linker-2.3.0.ebuild b/dev-python/rst-linker/rst-linker-2.3.0.ebuild
new file mode 100644
index 000000000000..dfa0d9406050
--- /dev/null
+++ b/dev-python/rst-linker/rst-linker-2.3.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Sphinx plugin to add links and timestamps to the changelog"
+HOMEPAGE="https://github.com/jaraco/rst.linker"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-3.4.1[${PYTHON_USEDEP}]
+ test? (
+ dev-python/path-py[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest