summaryrefslogtreecommitdiff
path: root/dev-python/ryu
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/ryu
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/ryu')
-rw-r--r--dev-python/ryu/Manifest5
-rw-r--r--dev-python/ryu/metadata.xml11
-rw-r--r--dev-python/ryu/ryu-4.14.ebuild20
-rw-r--r--dev-python/ryu/ryu-4.21.ebuild20
4 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/ryu/Manifest b/dev-python/ryu/Manifest
new file mode 100644
index 000000000000..45d7a6473a5c
--- /dev/null
+++ b/dev-python/ryu/Manifest
@@ -0,0 +1,5 @@
+DIST ryu-4.14.tar.gz 1492205 BLAKE2B 2a4135ebb68fdde9346fa1e6431a0581138bdc7ac62394b7143326e001bed2039daefd79eb7a6f27b32ee23c7eb10b995ad2441b6a67fcc13637512dc17f2f6a SHA512 e3fd7dc340c4b5cd191b8013bfcd8c0d6dd81489032dbb842fd1bd9f1adddddb715d8c8b92e59bf83fc4adeb7d36b9ee81bdb79caab1f4f10559e54f4da37c76
+DIST ryu-4.21.tar.gz 1513472 BLAKE2B 814db9cf5aff130c1b1cebb4eb2e3bcf2a868cb20a004fde9cf11c82869ac710834c8ea10d27c5bb542cce34145e5932148a10dbc69f20ec521dd1799bf21100 SHA512 03001eb2cf03e3b2051cb05a3be16b9c9c5f9c15e549bb7490f67216e62ecf21c229016c97546477298c4475866cf295bd706746ba7b5a47599ead2564dbcc5b
+EBUILD ryu-4.14.ebuild 506 BLAKE2B f977a93749295151302fe1a276429b5f3a2bdfb442e11e10e960e001b8391b9db6e04026e5ca1d6bb901c06f3a2056815426e3afffb9ee23303fb59dbf693b85 SHA512 0f79562cd1872255efa837a090e6f9f259e60c2d386f514fac34173abf7d82bdac57e8caf4d7e668c3616f16f210e47a85b4ba19638f5c7d9910af630d973563
+EBUILD ryu-4.21.ebuild 502 BLAKE2B eb5e0bde121fba468623d0ad45432d702e5a9680df66a94c001dd67609ec8797c64eb4da84a72a86f4104dd6b3ac9f96875da4ef3534141e94984168e67552ad SHA512 769ed322eab01b87567c38f6d2b38f3281a7b68cafcb89fa139f9f6dfc1f030c7b6497190895584a573f2805bf53684320bd406f79be539c999ea1144e531a73
+MISC metadata.xml 320 BLAKE2B 53cf3eb4dc8485edcfb30a28d51e9191a4c24a3770fe376e3df73534e0ebf7481b5eac783a3bf8d8ffcb6f963c5ec22ca49a568f66c983a6d619b8505d2289c2 SHA512 44ad18c381ba7c542ed25119d53ebc3ef8e6a2cc46cdd4bfdec51fa07d6250e9a59212e8ce3176f0f6b219726fd869b706f487ac86f5d3b8645ecb485ff68028
diff --git a/dev-python/ryu/metadata.xml b/dev-python/ryu/metadata.xml
new file mode 100644
index 000000000000..e491d9a1ccd8
--- /dev/null
+++ b/dev-python/ryu/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">ryu</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/ryu/ryu-4.14.ebuild b/dev-python/ryu/ryu-4.14.ebuild
new file mode 100644
index 000000000000..53e4a313ee99
--- /dev/null
+++ b/dev-python/ryu/ryu-4.14.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Component-based Software-defined Networking Framework"
+HOMEPAGE="http://osrg.github.io/ryu/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]"
+RDEPEND=""
diff --git a/dev-python/ryu/ryu-4.21.ebuild b/dev-python/ryu/ryu-4.21.ebuild
new file mode 100644
index 000000000000..416825abdab4
--- /dev/null
+++ b/dev-python/ryu/ryu-4.21.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Component-based Software-defined Networking Framework"
+HOMEPAGE="http://osrg.github.io/ryu/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]"
+RDEPEND=""