summaryrefslogtreecommitdiff
path: root/dev-python/scimath
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/scimath
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/scimath')
-rw-r--r--dev-python/scimath/Manifest5
-rw-r--r--dev-python/scimath/metadata.xml20
-rw-r--r--dev-python/scimath/scimath-4.1.2-r1.ebuild45
3 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/scimath/Manifest b/dev-python/scimath/Manifest
new file mode 100644
index 000000000000..4f58833b97b6
--- /dev/null
+++ b/dev-python/scimath/Manifest
@@ -0,0 +1,5 @@
+DIST scimath-4.1.2.tar.gz 119399 SHA256 f175ba482dbd4fa8154c6cb44ce8a582b0724c174b401642319f2316af70147e SHA512 2ceeeca5402da2b8745e0af5dac6a470c47b80529ec56aeb758cea815785be8a38b4ee3a052780c532b474acc4bf36474dd67c802a94971f3010148987c24257 WHIRLPOOL 3e5ef8135086a323429994d1831124d3912b1e765ef65610bd6bdd94ee18a170fd90bc4a3f6f8fa9cc026c635ce368a6c8eb79a3a47bb58db03df6507cc58c5b
+EBUILD scimath-4.1.2-r1.ebuild 1161 SHA256 9dd2459aed30b4492f910d75708b2c81f3773aba8347c3b4cbfe234d5106e5ed SHA512 8024407c212da0fef5b2b2f3f3bbb032e7339f8f93a8e1478d3745b2f5f26914ea3781af9c74090e6a95a7f46cf948d5799f19743cc106aec6bf9a64fc15cad9 WHIRLPOOL 8253921ea10a2d734d4884ac92d11281dda3aea23ea7bfb317955a1dbe9820cd02fe170d529f9f52963b3a95e8b85bbc9ffb4f3b7eb172197b21968bba4edeea
+MISC ChangeLog 2581 SHA256 639c6492fad8273bbf921ab596591dd8c3810782910d6ea325a94b66f6806f5e SHA512 a5472c0bc724dcf5fb9c458ddc1265bcc67f3ca2c2706c10485658d3ff7897ab938e796ff593f11d8414bdec72e3a1aa8d1d80ee859c6439b49969275bbbd023 WHIRLPOOL 89d96a2dfef59f72c283695bfcefca7eebb98a46e43252b052bc8e7c0989fafc9d75fbc1d5aa6408f11f7d8f52bd57b017087a488845a0df6cb1c0e302f015fa
+MISC ChangeLog-2015 2738 SHA256 778e66b4c564f33052171e31970d093ad0b796088096cbb27d849ceaeeb265d7 SHA512 151dbd1c1fe86cea30e7ec250d57cde73dd56d424cb5f7718964aa5e8a02e4e5f9f6bca324af79764f83830c440c98c4614a277c542de8f6d7dc1114b12ef833 WHIRLPOOL 19e582eb6d6ba33da71ee1727fdd367767e1b3af298acadfd3e1b71d97c0379e2965914dd7fed0c3ab2746c4856f871f2f825bfc889078973a3be8d237a16de4
+MISC metadata.xml 670 SHA256 06ee5b85bc081d25bb0d1aff1521c346a2b61d81bf7642cbba1ee0f7d8022d8b SHA512 eccd352c38d4967cd43718b0dc9daabcf2431d2b273056efad81a18a5bd93e9b4478cca105a4e4e68996ca13d3aa1bb4f1c70bba2fd395e43813fdab1578441c WHIRLPOOL 11c63bf358ef5e3c6529dde64cec39bcfa48ed9aa0f68663b4ca6b115714f64454c6a9f074a68880a82debfe7ed3a5c9e0d37a606a04fc58f7c45f584fc9706a
diff --git a/dev-python/scimath/metadata.xml b/dev-python/scimath/metadata.xml
new file mode 100644
index 000000000000..318fee4f61fb
--- /dev/null
+++ b/dev-python/scimath/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ The SciMath project from the Enthought Tool Suite includes
+ packages to support scientific and mathematical calculations,
+ beyond the capabilities offered by SciPy:
+ * enthought.interpolate
+ * enthought.mathematics
+ * enthought.units
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/scimath/scimath-4.1.2-r1.ebuild b/dev-python/scimath/scimath-4.1.2-r1.ebuild
new file mode 100644
index 000000000000..dce19f877634
--- /dev/null
+++ b/dev-python/scimath/scimath-4.1.2-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Enthought Tool Suite: Scientific and mathematical tools"
+HOMEPAGE="http://code.enthought.com/projects/sci_math/ https://pypi.python.org/pypi/scimath"
+SRC_URI="http://www.enthought.com/repo/ets/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+RDEPEND=">=dev-python/traits-4.1[${PYTHON_USEDEP}]
+ >=dev-python/traitsui-4.1[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ ${RDEPEND}
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ x11-apps/xhost
+ )"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ # ONE test assumes PYTHONPATH in its own dir!!!
+ PYTHONPATH=build/lib/:build/lib/scimath/interpolate/
+ VIRTUALX_COMMAND="nosetests" virtualmake
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}