summaryrefslogtreecommitdiff
path: root/dev-python/scimath
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/scimath
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/scimath')
-rw-r--r--dev-python/scimath/Manifest3
-rw-r--r--dev-python/scimath/metadata.xml16
-rw-r--r--dev-python/scimath/scimath-4.1.2-r1.ebuild47
3 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/scimath/Manifest b/dev-python/scimath/Manifest
new file mode 100644
index 000000000000..b5eba103e477
--- /dev/null
+++ b/dev-python/scimath/Manifest
@@ -0,0 +1,3 @@
+DIST scimath-4.1.2.tar.gz 119399 BLAKE2B 8f316ac90ec167d9563dafcdb0acbe2dae8ecea92a5c9c2dd126a0278bf3820c7bb87d7e9e597ed5a0c9ed8d154b7883cf31a6360adbb41c3654c8b3c10d5be8 SHA512 2ceeeca5402da2b8745e0af5dac6a470c47b80529ec56aeb758cea815785be8a38b4ee3a052780c532b474acc4bf36474dd67c802a94971f3010148987c24257
+EBUILD scimath-4.1.2-r1.ebuild 1187 BLAKE2B a34c2d1cad9dbe1fee0b17f15cb7290d0db0ba1ef47deaa6fd1d9f564ad865b1923313bac2c48726205025b7e78c3088f070bfc8cf22bf022b3a3e7016665ee3 SHA512 a311da56a37c6fbac8b3046381e95d4c5e9c36b8a55a595e315ba07288ba8e485dd0481e80eec2997afdf3c3848c6deb99a8b5970c56c6d0b1fa6af5c0ff57a5
+MISC metadata.xml 563 BLAKE2B 663c07122bdcb83b975997e3cf0d98469fb60014329fd275d4915d9d8dfcf80cb47309538a3a9560cab3a0ccd3aaa25d5ebc8276c698e18b958d3aeaedc15dce SHA512 0137c8cd9a6ee41f481fad81d30a8bfc2a190879d348b34814f58ed2282d83ea20736ba3e9f4b84e777524360f263d1996cac943c1243d8a01b34f3e010db166
diff --git a/dev-python/scimath/metadata.xml b/dev-python/scimath/metadata.xml
new file mode 100644
index 000000000000..80c1e798f10e
--- /dev/null
+++ b/dev-python/scimath/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ The SciMath project from the Enthought Tool Suite includes
+ packages to support scientific and mathematical calculations,
+ beyond the capabilities offered by SciPy:
+ * enthought.interpolate
+ * enthought.mathematics
+ * enthought.units
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/scimath/scimath-4.1.2-r1.ebuild b/dev-python/scimath/scimath-4.1.2-r1.ebuild
new file mode 100644
index 000000000000..c67376ac54e2
--- /dev/null
+++ b/dev-python/scimath/scimath-4.1.2-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Enthought Tool Suite: Scientific and mathematical tools"
+HOMEPAGE="http://docs.enthought.com/scimath/
+ https://github.com/enthought/scimath
+ https://pypi.org/project/scimath/"
+SRC_URI="http://www.enthought.com/repo/ets/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+RDEPEND=">=dev-python/traits-4.1[${PYTHON_USEDEP}]
+ >=dev-python/traitsui-4.1[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ ${RDEPEND}
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ x11-apps/xhost
+ )"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ # ONE test assumes PYTHONPATH in its own dir!!!
+ PYTHONPATH=build/lib/:build/lib/scimath/interpolate/
+ VIRTUALX_COMMAND="nosetests" virtualmake
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}