summaryrefslogtreecommitdiff
path: root/dev-python/scipy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-25 02:45:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-25 02:45:51 +0100
commit237ad05f4a374a9f1707c3413a5094a6ce93e7ab (patch)
tree4e147c642dea57b55f5219109ecce4757a022f4b /dev-python/scipy
parent342922f04a58a969ff23806acc427c7ff79119ce (diff)
gentoo auto-resync : 25:10:2023 - 02:45:51
Diffstat (limited to 'dev-python/scipy')
-rw-r--r--dev-python/scipy/Manifest1
-rw-r--r--dev-python/scipy/scipy-1.11.3-r1.ebuild129
2 files changed, 130 insertions, 0 deletions
diff --git a/dev-python/scipy/Manifest b/dev-python/scipy/Manifest
index 2bdce0d45565..314e52f76e52 100644
--- a/dev-python/scipy/Manifest
+++ b/dev-python/scipy/Manifest
@@ -11,5 +11,6 @@ EBUILD scipy-1.10.1.ebuild 2662 BLAKE2B dec183f49fdfc327173ad0a5ae329cf9621662f0
EBUILD scipy-1.11.0-r1.ebuild 2850 BLAKE2B eb201e9c497d0262cd1416b9f9f90fc9c84195595e348ffc1341457922add3482b16577d7bbb48017d3bce1883c69ee4545fc30e6fabe8410d3e5113e56286ff SHA512 d703ab7e30a83a720cb4a3568a841e5348e021b5542b708483731894b4f7bb16e0b9cce1a93fad84f558b2b3fb812528fb72a6812b9dc888f89d853898aefb06
EBUILD scipy-1.11.1.ebuild 2938 BLAKE2B 591c432fb4060eb9a5eff0c7f5b0cfaec1340b6938074eb44aac124b2314b5aeebc8e83c28ad85a3df3a2142829d43729a6fd34b079405a544332cbd00a1c06d SHA512 1b21eb7a9307dc650d7ae86221c8b9ca81b212c9a31a19ece5c2170fe9a6518c1df4fe57b25acfe97f3a59a27a18ec3bfe2b5d9b9fb922237b6d71cfe9193e8a
EBUILD scipy-1.11.2.ebuild 2844 BLAKE2B 2f895f59475840c3e1e9a6d01e11688147f43ecd010ffdf67788db9b4baf0cdb8174b353e8e39b729251e13ec698aff6a893bd4119e0b4dcf7648947960f1556 SHA512 ee69a5c20a0e056db32e4ee3060f1d058068e4261401931d871c9799d64c04c7a5893bbef7aa13cb7c007f4d4f29bc03c71eccd9eddd5b9268b41a96d12483a4
+EBUILD scipy-1.11.3-r1.ebuild 2964 BLAKE2B 2a8b9b266fdef5c915866fc025b9bd53b7e31717712e05ce32ea779b13e42d1dc7bc132d95b3a07d2bd8023d71d22d3d2e25f85489c27bac58ec0fe5f6b08f4c SHA512 f2f76bd3332d135a3f525b9332d27c02c538c4a8cd317a69016fd6e48c2830ac7de4660f69c9a8baec031ad235c018c3f9fbc3bcf7e7d8c14e03238da363e638
EBUILD scipy-1.11.3.ebuild 3025 BLAKE2B 1c8afbbd88b427ee822f03bd87345c53ceedf264bcf34d9d16ef100f50b82b8a945f798606da0736d2d9b291f250f237e88ec63395403c91d139229bdc1e7296 SHA512 68b832b7cf683dcb4096c37529da1ca4e1a5b7efe89b4e205619b53a94af6a9baaa0e0e78882707d9745bf2f7ed71191aa8eb26bb2d11abd2394bfd234e1e85f
MISC metadata.xml 953 BLAKE2B a09ea1325a175e349fbc3ca77c5e7b373538ea01147e8544f44b7d4e0c55fbbc2012431fcfe9a3457e82d295e4b5630df1ed69c48ef3462ed9b157af30a1e09a SHA512 74a21c6e1a9bef95b3d74a9513c59d302f473725c04fa32a9991b6108113c0f4b78179ce4a628140e7aa870c24ca60bddf7a00063b6b73dd45110112311371d8
diff --git a/dev-python/scipy/scipy-1.11.3-r1.ebuild b/dev-python/scipy/scipy-1.11.3-r1.ebuild
new file mode 100644
index 000000000000..ec1b7d97a795
--- /dev/null
+++ b/dev-python/scipy/scipy-1.11.3-r1.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+FORTRAN_NEEDED=fortran
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=meson-python
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit fortran-2 distutils-r1 multiprocessing
+
+DESCRIPTION="Scientific algorithms library for Python"
+HOMEPAGE="
+ https://scipy.org/
+ https://github.com/scipy/scipy/
+ https://pypi.org/project/scipy/
+"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+
+ # Need submodules, so git for now.
+ EGIT_REPO_URI="https://github.com/scipy/scipy"
+ EGIT_BRANCH="maintenance/$(ver_cut 1-2).x"
+ EGIT_SUBMODULES=( '*' )
+else
+ inherit pypi
+
+ # Upstream is often behind with doc updates
+ #DOC_PV=${PV}
+ DOC_PV=1.11.0
+
+ SRC_URI+="
+ doc? (
+ https://docs.scipy.org/doc/${PN}-${DOC_PV}/${PN}-html-${DOC_PV}.zip
+ )"
+
+ if [[ ${PV} != *rc* ]] ; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+ fi
+fi
+
+LICENSE="BSD LGPL-2"
+SLOT="0"
+IUSE="doc +fortran test-rust"
+
+# umfpack is technically optional but it's preferred to have it available.
+DEPEND="
+ >=dev-python/numpy-1.21.6[lapack,${PYTHON_USEDEP}]
+ sci-libs/arpack:=
+ sci-libs/umfpack
+ virtual/cblas
+ >=virtual/lapack-3.8
+"
+RDEPEND="
+ ${DEPEND}
+ dev-python/pillow[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-lang/swig
+ >=dev-python/cython-0.29.35[${PYTHON_USEDEP}]
+ >=dev-python/meson-python-0.12.1[${PYTHON_USEDEP}]
+ >=dev-python/pybind11-2.10.4[${PYTHON_USEDEP}]
+ >=dev-util/meson-1.1.0
+ !kernel_Darwin? ( dev-util/patchelf )
+ virtual/pkgconfig
+ doc? ( app-arch/unzip )
+ fortran? ( dev-python/pythran[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+ test-rust? (
+ dev-python/pooch[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_unpack() {
+ default
+
+ if use doc; then
+ unzip -qo "${DISTDIR}"/${PN}-html-${DOC_PV}.zip -d html || die
+ fi
+}
+
+python_configure_all() {
+ DISTUTILS_ARGS=(
+ -Dblas=blas
+ -Dlapack=lapack
+ -Duse-pythran=$(usex fortran true false)
+ )
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+
+ local EPYTEST_DESELECT=(
+ # Network
+ scipy/datasets/tests/test_data.py::TestDatasets::test_existence_all
+ scipy/datasets/tests/test_data.py::TestDatasets::test_ascent
+ scipy/datasets/tests/test_data.py::TestDatasets::test_face
+ scipy/datasets/tests/test_data.py::TestDatasets::test_electrocardiogram
+
+ # Precision issue with diff. blas?
+ scipy/optimize/tests/test__basinhopping.py::Test_Metropolis::test_gh7799
+
+ # Crashes with assertion, not a regression
+ # https://github.com/scipy/scipy/issues/19321
+ scipy/signal/tests/test_signaltools.py::test_lfilter_bad_object
+ )
+ local EPYTEST_IGNORE=()
+
+ if ! has_version -b "dev-python/pooch[${PYTHON_USEDEP}]" ; then
+ EPYTEST_IGNORE+=(
+ scipy/datasets/tests/test_data.py
+ )
+ fi
+
+ epytest -n "$(makeopts_jobs)" --dist=worksteal scipy
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( "${WORKDIR}"/html/. )
+
+ distutils-r1_python_install_all
+}