summaryrefslogtreecommitdiff
path: root/dev-python/scipy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-28 07:59:59 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-28 07:59:59 +0100
commitb8325835c82367d22428eb41afa0f2d375338d3c (patch)
treec416b8853bd14fc346da5d0129843cc4a68a30a0 /dev-python/scipy
parentd2ed973482fdd800013658e83a61709b29e0a80f (diff)
gentoo auto-resync : 28:06:2024 - 07:59:59
Diffstat (limited to 'dev-python/scipy')
-rw-r--r--dev-python/scipy/Manifest2
-rw-r--r--dev-python/scipy/scipy-1.14.0.ebuild13
2 files changed, 12 insertions, 3 deletions
diff --git a/dev-python/scipy/Manifest b/dev-python/scipy/Manifest
index 4466be9276a6..8f3561fccda1 100644
--- a/dev-python/scipy/Manifest
+++ b/dev-python/scipy/Manifest
@@ -14,5 +14,5 @@ EBUILD scipy-1.11.4-r1.ebuild 3660 BLAKE2B e5e7918bf5f1abfaa9d2fdec01b5c52d4e020
EBUILD scipy-1.12.0-r1.ebuild 3620 BLAKE2B c5c8dfd752b81e16f61a25beabb20a20b3d9087b1a6c514fd7f8d3710435d68b49ad55ba2f082e468a9066f4ad1bff664036c073cfb48cf16d09fcb0b1fafb13 SHA512 e2ebf0e8d464306b0d12b4e831cd7c253b2431fa922d4276c516238d93c4b1f0b0275a3354b31428e9bc43e05eafaf67f92a6b481d9be941421693687bdb513f
EBUILD scipy-1.13.0.ebuild 4168 BLAKE2B 69ff580f5b92bdcc72fce07810d00c4b1689f66c758ac519b2368c9e05e516e794f124632f7b598899f676e866f1aca6e98708dfd8fea94bfef04b8d69ad7aa7 SHA512 4d92a3499809ee17e06df6ccb89871c299cf1ba7878e68df10de280af52e610cef206f7f1c1ef80d3b349f2ec256d9211a44e20c35d3db349dd035a83c486e95
EBUILD scipy-1.13.1.ebuild 4169 BLAKE2B a7c8562615453a25c777b32041aa5808bbbb936bd7e1d85f00bdddf3377bd0a6343bd71b2b02c05d3105d15bcc799ef4230fb4446aa6e4807cca357e3268b0d4 SHA512 23890d6a413417b5fb46cb0e29e5fd3a226f67f94674d746ce9813c711508690b527b72fad90e6771695d9f191125e1012c7d2413bf3946cc10e00519f669a01
-EBUILD scipy-1.14.0.ebuild 4323 BLAKE2B d23b00b414e5a1e74c1ba5715ee8c1ae0bdae9ba50237bf919e4362c6fa913744cf9d90f72e045ea4b875730b3e698b30c126a4eaa57fd3bba30a90cbba397f2 SHA512 deb228b83485badc72b47237e8ba25f3fc0c72e6f5c9ef7cb5c586305981ad4dbf0f7769bb27bb04c0c93c4b7653ea13c31186ae21c9f4cf59d71ec73841be4c
+EBUILD scipy-1.14.0.ebuild 4552 BLAKE2B 1a83ff14bed8a8f949d0629d016bc4b407102fc4577247ade6746f984cf9a7508cc0aa0cc1e90f0ad803532ec8ab0a419298dde36fa7818ba9d62df3ab3f2d8f SHA512 708f2f4fae74c20041278df688afa0daa94b1ca823725f8510fb9b35b61d85352fdaa2fcf12f47d50c56da8abed61bf0fe2f229dc7155cdd359a9acd8196c876
MISC metadata.xml 953 BLAKE2B a09ea1325a175e349fbc3ca77c5e7b373538ea01147e8544f44b7d4e0c55fbbc2012431fcfe9a3457e82d295e4b5630df1ed69c48ef3462ed9b157af30a1e09a SHA512 74a21c6e1a9bef95b3d74a9513c59d302f473725c04fa32a9991b6108113c0f4b78179ce4a628140e7aa870c24ca60bddf7a00063b6b73dd45110112311371d8
diff --git a/dev-python/scipy/scipy-1.14.0.ebuild b/dev-python/scipy/scipy-1.14.0.ebuild
index a37f5c5245cb..8e3a14e3952c 100644
--- a/dev-python/scipy/scipy-1.14.0.ebuild
+++ b/dev-python/scipy/scipy-1.14.0.ebuild
@@ -6,10 +6,10 @@ EAPI=8
FORTRAN_NEEDED=fortran
DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=meson-python
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
PYTHON_REQ_USE="threads(+)"
-inherit fortran-2 distutils-r1
+inherit flag-o-matic fortran-2 distutils-r1
DESCRIPTION="Scientific algorithms library for Python"
HOMEPAGE="
@@ -95,6 +95,9 @@ python_configure_all() {
-Duse-pythran=$(usex fortran true false)
)
+ # https://bugs.gentoo.org/932721
+ has_version '>=dev-python/numpy-2.0.0' && filter-lto
+
# hide real scipy, to prevent pythran crashing when scipy is being
# rebuilt for new numpy ABI
# https://github.com/serge-sans-paille/pythran/issues/2194
@@ -157,6 +160,12 @@ python_test() {
scipy/optimize/tests/test_hessian_update_strategy.py::TestHessianUpdateStrategy::test_initialize_catch_illegal
)
;;
+ python3.13)
+ EPYTEST_DESELECT+=(
+ # docstring formatting
+ scipy/misc/tests/test_doccer.py::test_decorator
+ )
+ ;;
esac
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1