summaryrefslogtreecommitdiff
path: root/dev-python/scipy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
commitb8c7370a682e4e29cda623222d17a790c01c3642 (patch)
treef6caa14689bd00a5760eadaa381ff41e50ef3c1b /dev-python/scipy
parent8a4997a7e2d1e36c089d4d76935b5a902d98d3d0 (diff)
gentoo auto-resync : 07:08:2024 - 12:37:20
Diffstat (limited to 'dev-python/scipy')
-rw-r--r--dev-python/scipy/Manifest2
-rw-r--r--dev-python/scipy/scipy-1.14.0.ebuild14
2 files changed, 2 insertions, 14 deletions
diff --git a/dev-python/scipy/Manifest b/dev-python/scipy/Manifest
index b3599581a3ed..d9b6d263dbfb 100644
--- a/dev-python/scipy/Manifest
+++ b/dev-python/scipy/Manifest
@@ -1,4 +1,4 @@
DIST scipy-1.14.0.tar.gz 58618870 BLAKE2B bf9ed05628b02dc058555402995caae722cf6802bde80387d4e4477ec533589a66ca70b5dd44a32ddac652c7c69300406434b80e7cbc9aee2a78ae6b26ee4c2b SHA512 6579d988a2093602f5fc82203bbb5dc5690a95032484b5d5bd843d1e7995b3b89d802c7b38ec0345c1f3d8e22c98fb92b3982a1eadfcdf63607f929a52b56abf
DIST scipy-html-1.14.0.zip 65723829 BLAKE2B ba47dbf00a5d2a53a9addc5ea68ab18b42f211a018b89aa4b0b57ff0dee02e410a3effc59ddf8fbbc5aa33075d45d86880aed3a14068da5bd7b62ee526199967 SHA512 93be0bafcc64cea1ba130bbcc77c0741acc4f819c84a5030391a22657a1bc63abe8434a2723f66b7ad04c0809dc6d02e3a97ffb8d94bd3d4a4bb759ee796b475
-EBUILD scipy-1.14.0.ebuild 4547 BLAKE2B f194df24edb371dc53abca65d483e80dca52a402a5f6e9b7cdea4419431243e97c1e77de93664a22a068006d09babfaa120befdedc6568a123f77552dcd51856 SHA512 9d22b43d4676b3f35c75be0e023c652acd1ca5741b9c8c3a05ece1f939f9576a5f9b2bca47f051fe4882ed0b36a15ed0a612fd394461f0d71cc73ce6642deaed
+EBUILD scipy-1.14.0.ebuild 4200 BLAKE2B e09240f54150aa756aa33388670a242835fafc7bfc1f4373156e72eee64176e44f49681fd2e88e87ffe8b6d9702b592870dc16f1ea61018f4915a82039f76143 SHA512 aa078bb6fbf623ba13095b1a2a0768f07945c888cb49310ec90ca460f33c9496a410095487e0891b8e93d2807cbb38484cf9ca71cac6629370bf7ea2e6fe004f
MISC metadata.xml 953 BLAKE2B a09ea1325a175e349fbc3ca77c5e7b373538ea01147e8544f44b7d4e0c55fbbc2012431fcfe9a3457e82d295e4b5630df1ed69c48ef3462ed9b157af30a1e09a SHA512 74a21c6e1a9bef95b3d74a9513c59d302f473725c04fa32a9991b6108113c0f4b78179ce4a628140e7aa870c24ca60bddf7a00063b6b73dd45110112311371d8
diff --git a/dev-python/scipy/scipy-1.14.0.ebuild b/dev-python/scipy/scipy-1.14.0.ebuild
index cd7be229a991..d92a8af88f7a 100644
--- a/dev-python/scipy/scipy-1.14.0.ebuild
+++ b/dev-python/scipy/scipy-1.14.0.ebuild
@@ -67,7 +67,7 @@ BDEPEND="
virtual/pkgconfig
doc? ( app-arch/unzip )
fortran? (
- >=dev-python/pythran-0.14.0[${PYTHON_USEDEP}]
+ >=dev-python/pythran-0.16.0[${PYTHON_USEDEP}]
)
test? (
>=dev-python/hypothesis-6.30[${PYTHON_USEDEP}]
@@ -97,18 +97,6 @@ python_configure_all() {
# https://bugs.gentoo.org/932721
has_version '>=dev-python/numpy-2.0.0' && filter-lto
-
- # hide real scipy, to prevent pythran crashing when scipy is being
- # rebuilt for new numpy ABI
- # https://github.com/serge-sans-paille/pythran/issues/2194
- cat >> "${T}/scipy.py" <<-EOF || die
- raise ImportError("hide real scipy")
- EOF
-}
-
-python_compile() {
- local -x PYTHONPATH="${T}${PYTHONPATH+:${PYTHONPATH}}"
- distutils-r1_python_compile
}
python_test() {