summaryrefslogtreecommitdiff
path: root/dev-python/sdnotify
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/sdnotify
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/sdnotify')
-rw-r--r--dev-python/sdnotify/Manifest3
-rw-r--r--dev-python/sdnotify/metadata.xml24
-rw-r--r--dev-python/sdnotify/sdnotify-0.3.1.ebuild22
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/sdnotify/Manifest b/dev-python/sdnotify/Manifest
new file mode 100644
index 000000000000..49123373a2c7
--- /dev/null
+++ b/dev-python/sdnotify/Manifest
@@ -0,0 +1,3 @@
+DIST sdnotify-0.3.1.tar.gz 2513 SHA256 e69220d4f6cbb02130f43f929350a80cf51033fde47dcb056fbda71e2dff2d5a SHA512 765e75e727ad5128269bfffd4d3f64666df654adc50965a54f3cd622933aca583faee5453f7fec3a23b6f754f4475522dd96a86ba643984cd72a575ec082709c WHIRLPOOL b43831604022cdd5f605138324cda4e43ee7021993e66afaa73b82eff98c11dc087d5f8f5d1b62073d750cfb84ac9168eca12640dc6149df68506826fcbfc0c4
+EBUILD sdnotify-0.3.1.ebuild 494 SHA256 0a253c778ca1d87859b646e755befc78c08f8492d4cedbfd166fa67617b37b81 SHA512 84b03e6a9a4a2c0d6bac5ace9dbb999b7d1c422bd94968140ba239949d2d1c939661d047b522439ecdcb93f0af2dbcb80bbc59c7067f739580e37932b1840e23 WHIRLPOOL 3c5b664e55189aca5e751333a3830648f40605d18ac1382b870b79aa27d5da40299166c60db722e35ff224332f7037680c722b7c5696ec122a9c0341811982cb
+MISC metadata.xml 898 SHA256 59c34273b0f1764d7bfa20e025dbb4b9535cb08ebe57b4ce93afa8bc0b8c2b3c SHA512 3bec05dec5e31a37d823081ff5b30fef06ab6a793801e1163d296d8c6b637dcc964379d53e77fdaaa6c55ccd5095018cb5f14c3252f575ba90eeeb93736ee986 WHIRLPOOL 0d4d270004d3aa2d9d7465075fbab82e146b190d16d7bd1413abe57f3bacd62416e730c058a326f65cdd9b2865fad22c3c09fb531caab34622099238e274fa0f
diff --git a/dev-python/sdnotify/metadata.xml b/dev-python/sdnotify/metadata.xml
new file mode 100644
index 000000000000..24bc40f11d18
--- /dev/null
+++ b/dev-python/sdnotify/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dolsen@gentoo.org</email>
+ <description>Primary maintainer</description>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>bbethke@gmail.com</email>
+ <name>Brett Bethke</name>
+ </maintainer>
+ <remote-id type="pypi">sdnotify</remote-id>
+ <remote-id type="github">bb4242/sdnotify</remote-id>
+ </upstream>
+ <longdescription>
+ This is a pure Python implementation of the systemd sd_notify
+ protocol. This protocol can be used to inform systemd about
+ service start-up completion, watchdog events, and other service
+ status changes. Thus, this package can be used to write system
+ services in Python that play nicely with systemd. sdnotify is
+ compatible with both Python 2 and Python 3.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/sdnotify/sdnotify-0.3.1.ebuild b/dev-python/sdnotify/sdnotify-0.3.1.ebuild
new file mode 100644
index 000000000000..fe6f98641f01
--- /dev/null
+++ b/dev-python/sdnotify/sdnotify-0.3.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of systemd's service notification protocol (sd_notify)"
+HOMEPAGE="
+ https://github.com/bb4242/sdnotify
+ https://pypi.python.org/pypi/sdnotify"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"