summaryrefslogtreecommitdiff
path: root/dev-python/seaborn
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/seaborn
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/seaborn')
-rw-r--r--dev-python/seaborn/Manifest3
-rw-r--r--dev-python/seaborn/metadata.xml36
-rw-r--r--dev-python/seaborn/seaborn-0.7.1.ebuild38
3 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/seaborn/Manifest b/dev-python/seaborn/Manifest
new file mode 100644
index 000000000000..c2df6d459870
--- /dev/null
+++ b/dev-python/seaborn/Manifest
@@ -0,0 +1,3 @@
+DIST seaborn-0.7.1.tar.gz 158146 BLAKE2B f547e41306634f41091ca5641319abcdb1d22359d67591f115009cd95cdf50463e3683fb1ac911ff9dee3d7628320a76fbcbaa9c91510937907a40a0daa259c4 SHA512 6c730d87a97f0df3b38b78ee9255d47b900aece1308127e2772dc982b19691efe6afe192752c89cba9e9532b567dc1c3c103675e580e6f1151355ea89d1019b3
+EBUILD seaborn-0.7.1.ebuild 861 BLAKE2B 877d9f1245db09269e2421c7d467c93cf80d5eb4afca016e943edf806e8daca4b71bde2871ec99f54bf847e402fd2d2f9b1337de726b6dd06b7460811423fd3a SHA512 80ee544c6334384276a2f66fe0e4c141cf735cc279ad476558daf321d189aafd25743c317a7e9f338f557209e135dea5829af8d7e305d1d25a7aecf7cba4af5d
+MISC metadata.xml 1741 BLAKE2B c1c19f61b7964ce77784415d3d964425a53e7a15d5e3148b7ee8474603f771eb07fe7e44fd0fc0a155687831fcf11425e963ed884c982541da707bf46e393658 SHA512 ddea613b7d13e3fce33bca903896fcbc0cf8f383f423cf6362190c9159675925cb297f57307ee223b43d2b15d41634e39d8ad2535071db0771a4ac9e891265d1
diff --git a/dev-python/seaborn/metadata.xml b/dev-python/seaborn/metadata.xml
new file mode 100644
index 000000000000..fefd180716d0
--- /dev/null
+++ b/dev-python/seaborn/metadata.xml
@@ -0,0 +1,36 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>horea.christ@gmail.com</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ Seaborn is a library for making attractive and informative statistical graphics
+ in Python. It is built on top of matplotlib and tightly integrated with the
+ PyData stack, including support for numpy and pandas data structures and
+ statistical routines from scipy and statsmodels.
+
+ Some of the features that seaborn offers are
+
+ * Several built-in themes that improve on the default matplotlib aesthetics
+ * Tools for choosing color palettes to make beautiful plots that reveal patterns in your data
+ * Functions for visualizing univariate and bivariate distributions or for comparing them between subsets of data
+ * Tools that fit and visualize linear regression models for different kinds of independent and dependent variables
+ * Functions that visualize matrices of data and use clustering algorithms to discover structure in those matrices
+ * A function to plot statistical timeseries data with flexible estimation and representation of uncertainty around the estimate
+ * High-level abstractions for structuring grids of plots that let you easily build complex visualizations
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">seaborne</remote-id>
+ <remote-id type="github">mwaskom/seaborn</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/seaborn/seaborn-0.7.1.ebuild b/dev-python/seaborn/seaborn-0.7.1.ebuild
new file mode 100644
index 000000000000..f7f36034b4f1
--- /dev/null
+++ b/dev-python/seaborn/seaborn-0.7.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Statistical data visualization"
+HOMEPAGE="https://seaborn.pydata.org https://github.com/mwaskom/seaborn"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/patsy[${PYTHON_USEDEP}]
+ dev-python/statsmodels[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ cat > matplotlibrc <<- EOF || die
+ backend : Agg
+ EOF
+ virtx nosetests --verbosity=3 || die
+}