summaryrefslogtreecommitdiff
path: root/dev-python/securesystemslib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-28 01:25:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-28 01:25:58 +0100
commit6405cba4bf18141460bc9fcb8f5580532d4b46f8 (patch)
tree377baa366741990f54b18ea82f5566c48295f4e0 /dev-python/securesystemslib
parentabc3bfc07d931f667a0f50cf607f1c8a49af879f (diff)
gentoo auto-resync : 28:09:2024 - 01:25:57
Diffstat (limited to 'dev-python/securesystemslib')
-rw-r--r--dev-python/securesystemslib/Manifest3
-rw-r--r--dev-python/securesystemslib/metadata.xml12
-rw-r--r--dev-python/securesystemslib/securesystemslib-1.1.0.ebuild45
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/securesystemslib/Manifest b/dev-python/securesystemslib/Manifest
new file mode 100644
index 000000000000..33cf53c21e83
--- /dev/null
+++ b/dev-python/securesystemslib/Manifest
@@ -0,0 +1,3 @@
+DIST securesystemslib-1.1.0.tar.gz 934688 BLAKE2B f9e997306e0f17d5f75b8a85c732950460ff7443fd301e845c721a6e49f74dc48f6d2b5b7e0def63b262a09e6901affe8b293124bd4f82e69157e8cd26cb134c SHA512 65ec41c08ad679884c327c291e27a8529e6a559f52eb154a4c1c13a558df7845cabc21e466e908029afcd57b6581b2f429c4ea87e34b664e52369ca6b0f63ba1
+EBUILD securesystemslib-1.1.0.ebuild 885 BLAKE2B a1a74d4eeadbbbb3192e944c6db75ba1d9056a1d750c59295616357d840e74761352cbd9e0d2a39666616f7d8ee6c0cd76aad2555f9d894b21da41d1f5e460a3 SHA512 a3d1a6ac172213afe0bc0d38b230274ccbc1684091ff7b8050f71a118b86ce1281bf2bd33c0a247d671023b9d00ceff35b8c3e15dbe10cca5cf96021490c2073
+MISC metadata.xml 397 BLAKE2B 54aea8ac6c4200962e3cacf83933b1ced69ef9980348b58c92668c53b62ae6f918b13ca7320e08528272957a7b507b358b545e7a9f691c7f520ce829e21d9d9d SHA512 9dea6a3d95b8da1cceff9a5f3f8dc6f722fe0c29e9896deab11998c6849912e593021e9cd706a412d828bdc1bf83da2ec57d39a422dc86eb8ce738394525b683
diff --git a/dev-python/securesystemslib/metadata.xml b/dev-python/securesystemslib/metadata.xml
new file mode 100644
index 000000000000..0681ed430fa2
--- /dev/null
+++ b/dev-python/securesystemslib/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">secure-systems-lab/securesystemslib</remote-id>
+ <remote-id type="pypi">securesystemslib</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/securesystemslib/securesystemslib-1.1.0.ebuild b/dev-python/securesystemslib/securesystemslib-1.1.0.ebuild
new file mode 100644
index 000000000000..acad89793005
--- /dev/null
+++ b/dev-python/securesystemslib/securesystemslib-1.1.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Cryptographic routines for Secure Systems Lab projects at NYU"
+HOMEPAGE="
+ https://github.com/secure-systems-lab/securesystemslib/
+ https://pypi.org/project/securesystemslib/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/cryptography-40.0.0[${PYTHON_USEDEP}]
+"
+#BDEPEND="
+# test? (
+# )
+#"
+
+distutils_enable_tests pytest
+
+# TODO: unbundle https://github.com/pyca/ed25519 (wtf? not on PyPI?)
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires pyspx
+ tests/test_signer.py::TestSphincs::test_sphincs
+ )
+ local EPYTEST_IGNORE=(
+ # requires PyKCS11
+ tests/test_hsm_signer.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests
+}