summaryrefslogtreecommitdiff
path: root/dev-python/semantic-version
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-24 09:01:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-24 09:01:51 +0100
commitbd2c7873be3178619accade4259ba907b6baca46 (patch)
treea2dd247d39fd3cd02086ae2248b0cd590397320c /dev-python/semantic-version
parenta5d03e5440b3955446fba6d02de9f53ea4f6efc4 (diff)
gentoo auto-resync : 24:05:2023 - 09:01:50
Diffstat (limited to 'dev-python/semantic-version')
-rw-r--r--dev-python/semantic-version/Manifest3
-rw-r--r--dev-python/semantic-version/metadata.xml21
-rw-r--r--dev-python/semantic-version/semantic-version-2.10.0.ebuild27
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/semantic-version/Manifest b/dev-python/semantic-version/Manifest
new file mode 100644
index 000000000000..d11d47579efb
--- /dev/null
+++ b/dev-python/semantic-version/Manifest
@@ -0,0 +1,3 @@
+DIST semantic_version-2.10.0.tar.gz 52289 BLAKE2B bb26ac31e71974376b40893cf000fe0d85e1e3e4c7c93372f2bfca841a5d760a99ca49d67f80c6e8707e60e313162b786300109f6f8cd1cfaa0001c343bc4702 SHA512 869a3901d4fc12acb285c94175011ed03dc00b35ab687c67dda458cffab5666cea21bc1b4bf75ef4edeb83b8080452a1c1470248eee54bbd269614a8cab132dc
+EBUILD semantic-version-2.10.0.ebuild 616 BLAKE2B 62d01f3201ca275c670bff34b681d208883191b1b4261fb33d27e7efe590a59f338bf9e77cda0007f69ae378eaedfb8fc5e6d13969d2fe8068a9454fba5a5a41 SHA512 ec23e8d661f592bfd2c67d5fdb268849789bae26ba616c37da99c88cacb71498e3b2fdd08808f89fa83b810e2d012297ade8cbd8f920f50fdab436b8a0a81364
+MISC metadata.xml 820 BLAKE2B 83a7b2e1fb38295f0c33ae8167795a047dee861961557ffdf7ef464c37a03229b639e5fb30b1bbc9d85b30192d87a2894a29ba3b10f8ca8d59c9aff20c4e6f32 SHA512 98505d13a269954057c74ce70d2229c57ed5b6d912d566075a871b465ce4b511f2b04761f21627b91118866b23fd8e4b332d4d2506b476fb3695ea88585088fb
diff --git a/dev-python/semantic-version/metadata.xml b/dev-python/semantic-version/metadata.xml
new file mode 100644
index 000000000000..920bd3fa3a30
--- /dev/null
+++ b/dev-python/semantic-version/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ This small python library provides a few tools to handle SemVer in Python. It follows strictly the 2.0.0 version of the SemVer scheme.
+ </longdescription>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">semantic-version</remote-id>
+ <remote-id type="github">rbarrois/python-semanticversion</remote-id>
+ <bugs-to>https://github.com/rbarrois/python-semanticversion/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/semantic-version/semantic-version-2.10.0.ebuild b/dev-python/semantic-version/semantic-version-2.10.0.ebuild
new file mode 100644
index 000000000000..f25427331685
--- /dev/null
+++ b/dev-python/semantic-version/semantic-version-2.10.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python library providing a few tools handling SemVer in Python"
+HOMEPAGE="
+ https://github.com/rbarrois/python-semanticversion/
+ https://pypi.org/project/semantic-version/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv ~s390 sparc x86"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -p no:django
+}