summaryrefslogtreecommitdiff
path: root/dev-python/sentry-sdk
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
commit185fa19bbf68a4d4dca534d2b46729207a177f16 (patch)
treea8a537b82fda83a0799c2ca9887f212558363aa7 /dev-python/sentry-sdk
parentc8fd0d84af0bfd1949542adc2cbb735b1d28f9ed (diff)
gentoo resync : 11.05.2021
Diffstat (limited to 'dev-python/sentry-sdk')
-rw-r--r--dev-python/sentry-sdk/Manifest2
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-1.1.0.ebuild69
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/sentry-sdk/Manifest b/dev-python/sentry-sdk/Manifest
index f885fc3616f3..c7d80c552497 100644
--- a/dev-python/sentry-sdk/Manifest
+++ b/dev-python/sentry-sdk/Manifest
@@ -1,3 +1,5 @@
DIST sentry-sdk-1.0.0.tar.gz 213707 BLAKE2B 9fa3dfac7d82c9e2c81be6f4edafbc27ab19a2a96876885dabe72d2dbd6cf392b80e453c640affb94d84f35b227b12d56927bec88e01a0ebfdcf8a466470a909 SHA512 e91ede3e5e31c2acba7094bd5c6a95280aa8367b1fcd524fc9b100d2a3a253efec1ed3d9c72465f5b2ef5276c834906d622b84e1650b65d2032f4acaf2fd1ab8
+DIST sentry-sdk-1.1.0.tar.gz 215946 BLAKE2B 486f32430a03d42c73814195ef16ec4efc71512faca197d8020fad7b3d1e7350ec619ef453075bc4fc4e0e454f3aa6eda41ec29b88af19d75b5f6a10273db325 SHA512 500d0d3add4bf8e74f2e34d6c00491f4bbd45a2226cc0ee93ca0f63f5ae5aea61be6730f845d50e10909c9ede6918ec6cfb90e5ebe80b753dd634ac9a9238061
EBUILD sentry-sdk-1.0.0.ebuild 2276 BLAKE2B 728371e10316b4f3e894274fd7167401b87715a317e5d826ea63cd293b8204d1f5a427f1a7ba1071e80d477e71a5710b02e9eb12da7f7633ffaf4507a1648318 SHA512 882c5b8a27083f3a576c7b2dd1c15a8fbf962ba20dd411191374294719778c15cbfa93132807923c4a320eb8ab1d6b390e996b5584d78b9a6c55a67286a70538
+EBUILD sentry-sdk-1.1.0.ebuild 2239 BLAKE2B d4068a69e301ab5e1bbd524de310a3882fc0e7fb1ed44c37b7c7818e6074f97005e8b0fde6934bfeabfeb7e7abbb15fb18c3a9bdae80c3ee013f7f1c20670082 SHA512 51453b1f68c2a18e5216b39da235e8ab4de77ede61c2019fa766e9d334dab88c8d622471dfa0097352bfa567400c14de2c4925c7cb42349931157d61eedfee7e
MISC metadata.xml 509 BLAKE2B 5b68b368764625061ea2eadc0161570e46760904015f6e1e3e97a7a4dacd3604a18b2cbfb665e816981a40f95ec9c4f0c4a0447ecc968cbdf1fd21dcd4149193 SHA512 c42a1f7972313d3369ba392347b0efa700ee9c9b01d3275b3973b8137cf00fca693288a1af57c355b2d87525d9fcb7a320ad571fe8be5531472a8710f9b287d1
diff --git a/dev-python/sentry-sdk/sentry-sdk-1.1.0.ebuild b/dev-python/sentry-sdk/sentry-sdk-1.1.0.ebuild
new file mode 100644
index 000000000000..1a90236e8d17
--- /dev/null
+++ b/dev-python/sentry-sdk/sentry-sdk-1.1.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for Sentry"
+HOMEPAGE="https://sentry.io/ https://pypi.org/project/sentry-sdk/"
+SRC_URI="https://github.com/getsentry/sentry-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/sentry-python-${PV}"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/asttokens[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/executing[${PYTHON_USEDEP}]
+ dev-python/eventlet[${PYTHON_USEDEP}]
+ dev-python/fakeredis[${PYTHON_USEDEP}]
+ dev-python/flask-login[${PYTHON_USEDEP}]
+ dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pyrsistent[${PYTHON_USEDEP}]
+ dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # tests require Internet access
+ tests/integrations/stdlib/test_httplib.py
+ tests/integrations/requests/test_requests.py
+ # wtf is it supposed to do?!
+ tests/integrations/gcp/test_gcp.py
+ # hangs
+ 'tests/test_transport.py::test_transport_works[eventlet'
+ # TODO
+ 'tests/test_basics.py::test_auto_enabling_integrations_catches_import_error'
+ tests/test_client.py::test_databag_depth_stripping
+ tests/test_client.py::test_databag_string_stripping
+ tests/test_client.py::test_databag_breadth_stripping
+ # test_circular_references: apparently fragile
+ 'tests/integrations/threading/test_threading.py::test_circular_references'
+ # test for new feature, fails with IndexError
+ tests/integrations/wsgi/test_wsgi.py::test_session_mode_defaults_to_request_mode_in_wsgi_handler
+ )
+
+ # Prevent tests/integrations/modules/test_modules.py:test_basic failure
+ # Needs to detect sentry-sdk in the installed modules
+ distutils_install_for_testing
+
+ epytest ${deselect[@]/#/--deselect }
+}