summaryrefslogtreecommitdiff
path: root/dev-python/sentry-sdk
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-13 11:48:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-13 11:48:35 +0000
commite45f0df9d7f9f5260e69235b8c7c6e00153747f0 (patch)
tree1999e441fd73f9d62d9ab632067bb978b9b34f29 /dev-python/sentry-sdk
parent4bc834b03b9438dcfd45780f31a02994c24608ba (diff)
gentoo auto-resync : 13:01:2023 - 11:48:35
Diffstat (limited to 'dev-python/sentry-sdk')
-rw-r--r--dev-python/sentry-sdk/Manifest2
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-1.13.0.ebuild100
2 files changed, 102 insertions, 0 deletions
diff --git a/dev-python/sentry-sdk/Manifest b/dev-python/sentry-sdk/Manifest
index 29271d6d4276..b245c05d3218 100644
--- a/dev-python/sentry-sdk/Manifest
+++ b/dev-python/sentry-sdk/Manifest
@@ -1,5 +1,7 @@
DIST sentry-sdk-1.11.1.gh.tar.gz 296633 BLAKE2B 8325b75d58bb4c587c5d27698b775a76aaf840fc69a910567243fcac2d6fbb7fe00fbfe008c70fc5b67d999167cc3474e5a18817832dfe2c768ffc750c7af128 SHA512 9fd3e1aa9a7287ae21d1a7274f12b9d309d95615e5611ee098c8e2d0577f7c3928a6d5c7256b18d4f0de0ac48d44eb9e38f94709e8982a0c09a5b1cfb5dba114
DIST sentry-sdk-1.12.1.gh.tar.gz 306457 BLAKE2B e0c4e92fcf8f0213f27ccf6f03cfbdc66999469357cfdf82e4b923f34d79c44e0824a50caf437dded4404e77cd1cbdede240b1e98bd8408d467b754b3586d598 SHA512 c4fb0d13c1e40e0220ef56c29c2c5235aba0c7be598a545e08af783da0732266455d6b9aa73f2aaa068bf63105369517a12e8abbc7a31410ef3c4bea1a0b3018
+DIST sentry-sdk-1.13.0.gh.tar.gz 309851 BLAKE2B e1827bf8aa09a7d28a75f46afbbf3d59d92569e870fec3ad5c960fd566398bacdbd22e3f1c1bdd16f9905d430ddd4c348fb44b8fd2d20b8601bea4b61af1b57e SHA512 6e18fafafe37150958c3a474a7b9e783403fb0dff3747647e438bcfb490f1ba6a9584c9f5a35889c1c8f4e2502d83a2f851d037d11dfc58dd22f04479d3f6ce7
EBUILD sentry-sdk-1.11.1.ebuild 3402 BLAKE2B 31fba694c7e06d3f567a5a78e4758784d2369aa477cf198ff383a28679f50648404f47df8614ba8e7aed752380b40a7360caa8db058615855cc36515d3996942 SHA512 25bfc33e63adb74e4ecb00b5de71503cc2be90b97959f45cd9868bee5254601a20d8d11cc906e9cff2d954742e755848320d5c291188b74a62406902a3375c32
EBUILD sentry-sdk-1.12.1.ebuild 3406 BLAKE2B 8a72ea60a5252e2786def87bbb5438bc1e121fdd6d80c9780d937eb9bad41cccdf6e3ed72494e72a80b54244ad4eb12af4a1fae608e0486508e0a3ec86e6c0f1 SHA512 2db8be49c8996b1080429ff7de25a0eb7607757cfb658203995131ed28f636131eca723e323706fe579ce10d055e3bddac3c41895f7238e6477cb1c9345ba0bc
+EBUILD sentry-sdk-1.13.0.ebuild 3406 BLAKE2B ee768d372b20b57503479bc2f99cfaaaec0a65228ef2e7511a8a3eef204d0eb18074cc431d8293b5d885b177bb40192a2ca278eeebc1026e62a143a44736a7d3 SHA512 d51110b0344c5b7866ee044730158b3c3b819246a921bf7f4eecffb8dace42ba872ac20f42e314b6434e843df19d69f5d014b22ee325cf6b5cb6f4c60ed85fc5
MISC metadata.xml 510 BLAKE2B e00011699ac2cc83f1923e1f6fa813ede7eab8c57f9ce9d9fca04e721b089db1c5f2bdffaa7b9856f56b433abd9189125e07ffd3f329e4fa8d098e28a4f2d7bd SHA512 bafb77a102d94fe050cb526b298fb8cfd56775cb4d07eda280f6356fbec6fbe5df5c9ebd459d9d4457cd027c2e0d7c349e053fa6070b52f0d2989f6ec600b87d
diff --git a/dev-python/sentry-sdk/sentry-sdk-1.13.0.ebuild b/dev-python/sentry-sdk/sentry-sdk-1.13.0.ebuild
new file mode 100644
index 000000000000..6e9f9359154e
--- /dev/null
+++ b/dev-python/sentry-sdk/sentry-sdk-1.13.0.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for Sentry"
+HOMEPAGE="
+ https://sentry.io/
+ https://github.com/getsentry/sentry-python/
+ https://pypi.org/project/sentry-sdk/
+"
+SRC_URI="
+ https://github.com/getsentry/sentry-python/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/sentry-python-${PV}"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/asttokens[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/executing[${PYTHON_USEDEP}]
+ dev-python/fakeredis[${PYTHON_USEDEP}]
+ dev-python/flask-login[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pyrsistent[${PYTHON_USEDEP}]
+ dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zope-event[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # tests require Internet access
+ tests/integrations/httpx/test_httpx.py
+ tests/integrations/requests/test_requests.py
+ tests/integrations/stdlib/test_httplib.py
+ tests/integrations/flask/test_flask.py
+ tests/integrations/django/test_basic.py
+ # wtf is it supposed to do?!
+ tests/integrations/gcp/test_gcp.py
+ # broken by rq-1.10.1 (optional dep)
+ tests/integrations/rq/test_rq.py
+ # fastapi is not packaged
+ tests/integrations/asgi/test_fastapi.py
+ # TODO
+ tests/integrations/bottle
+ # TODO: causes breakage in other tests
+ tests/integrations/starlette
+ # TODO
+ tests/integrations/tornado
+ # requires mockupdb
+ tests/integrations/pymongo
+)
+
+EPYTEST_DESELECT=(
+ # hangs
+ 'tests/test_transport.py::test_transport_works'
+ # TODO
+ 'tests/test_basics.py::test_auto_enabling_integrations_catches_import_error'
+ tests/test_client.py::test_databag_depth_stripping
+ tests/test_client.py::test_databag_string_stripping
+ tests/test_client.py::test_databag_breadth_stripping
+ tests/integrations/asgi/test_asgi.py::test_auto_session_tracking_with_aggregates
+ tests/integrations/asgi/test_asgi.py::test_websocket
+ tests/integrations/aiohttp/test_aiohttp.py::test_transaction_style
+ tests/integrations/aiohttp/test_aiohttp.py::test_traces_sampler_gets_request_object_in_sampling_context
+ # incompatible version?
+ tests/integrations/falcon/test_falcon.py
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_too_large_event_truncated
+ # test_circular_references: apparently fragile
+ 'tests/integrations/threading/test_threading.py::test_circular_references'
+ # test for new feature, fails with IndexError
+ tests/integrations/wsgi/test_wsgi.py::test_session_mode_defaults_to_request_mode_in_wsgi_handler
+ # TODO
+ tests/integrations/wsgi/test_wsgi.py::test_auto_session_tracking_with_aggregates
+ tests/integrations/wsgi/test_wsgi.py::test_profile_sent_when_profiling_enabled
+ tests/test_profiler.py::test_sample_buffer
+ tests/test_profiler.py::test_thread_scheduler_takes_first_samples
+ tests/test_profiler.py::test_thread_scheduler_takes_more_samples
+ tests/test_profiler.py::test_thread_scheduler_single_background_thread
+)