summaryrefslogtreecommitdiff
path: root/dev-python/sgmllib3k
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
commitc719fdcee603a5a706a45d10cb598762d56a727d (patch)
tree620cbf137661399a3fb1eff92914204f9a970713 /dev-python/sgmllib3k
parentcc4618c9ba3d974948ebf340b542d8cb01db2f55 (diff)
gentoo resync : 25.09.2021
Diffstat (limited to 'dev-python/sgmllib3k')
-rw-r--r--dev-python/sgmllib3k/Manifest3
-rw-r--r--dev-python/sgmllib3k/sgmllib3k-1.0.0.ebuild11
2 files changed, 11 insertions, 3 deletions
diff --git a/dev-python/sgmllib3k/Manifest b/dev-python/sgmllib3k/Manifest
index bedc3059415e..e0e4327f5162 100644
--- a/dev-python/sgmllib3k/Manifest
+++ b/dev-python/sgmllib3k/Manifest
@@ -1,3 +1,4 @@
DIST sgmllib3k-1.0.0.tar.gz 5750 BLAKE2B 188ac3c55245ff431e1ad7981f706f1a8fce3e9f3aaf844252c02da1189e5b9c7d29b76d803cbbcfc157fbb1ec7f36245186693472b95ed1634a2989185308ae SHA512 f9238afb831356f66b1c3e55975e0ea88007ffe1469b8b4e325e704d1915eb0ab120f5f9e98f36eeb4bf6204a1938d8a4d5a424f0cc054b141ac94adc8ef8ca9
-EBUILD sgmllib3k-1.0.0.ebuild 442 BLAKE2B 666bf095c2fa912e49526dcdf8198d8c346f1141b65dd019739644cd4fa6bcf0016a1b294e27a5bae302c071a8d0c43b26f31a0ae7db2118b2e478cc415a766b SHA512 f15fa4ff86741105264fdbe6133995d49338aab8b651cee1323e999740669e4b67937a212f132807af4854ee772708c9a692c7e6056e66275b448a034d54c7c8
+DIST test_sgmllib.py.gz 3769 BLAKE2B 026a843eaeb698d87e0137453b7f82763dee9a1ca446fc2c2fa9af8324297176749b041dfc2fc4c1954d743d9cfb7e773a189d99f22f7dc55ea1de486da80dd4 SHA512 722b79aa8b38626540bc331f9edb36919a8fb2561c5526be19509a58901aa1e2582e312fc2ace09cae54cb62577f266fcb10a1d98ab10685e2c79a17fea2f124
+EBUILD sgmllib3k-1.0.0.ebuild 676 BLAKE2B d9663478d9009398edc59d08d690376f026855ea0eaed918f865e0e776d7b5d6bfd1f5acf8106707a54f35280b7735045b154083cdebf9231ad6cd0c4183280c SHA512 4726dd7698a68b9e1d69bb9f51c6bbccd47ddd3fd19a2449a10cdd6df317cdf4405699ce767cb3e329de875913449e465d90780ad0d996a826a761b5ae5675c1
MISC metadata.xml 337 BLAKE2B c95ed9109d2ab27ccbe5311e23f4617d19c2b7489b805500d8bd2c8dff99d8a74054d3e2b0a455f12cd616673071d308ca404e6734fe1bf4b16893d1a2bee577 SHA512 05cbda57d5634c30f963382afc29ce0f7e761bb7e9f48d11457c5d10fea14d9df3bca07bcea75d02430b421fc5d87b6c083c2feddd7f46d9d841f6e403d1d0f9
diff --git a/dev-python/sgmllib3k/sgmllib3k-1.0.0.ebuild b/dev-python/sgmllib3k/sgmllib3k-1.0.0.ebuild
index 7d34b5788ff5..d61a1417da37 100644
--- a/dev-python/sgmllib3k/sgmllib3k-1.0.0.ebuild
+++ b/dev-python/sgmllib3k/sgmllib3k-1.0.0.ebuild
@@ -3,13 +3,20 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit distutils-r1
DESCRIPTION="Py3k port of sgmllib"
HOMEPAGE="https://pypi.org/project/sgmllib3k/"
-SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz
+ test? ( https://dev.gentoo.org/~arthurzam/distfiles/dev-python/${PN}/test_sgmllib.py.gz )"
LICENSE="PSF-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+python_test() {
+ "${EPYTHON}" "${WORKDIR}/test_sgmllib.py" -v || die "Tests failed with ${EPYTHON}"
+}