summaryrefslogtreecommitdiff
path: root/dev-python/shapely
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-04 10:56:18 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-04 10:56:18 +0000
commit4ead5818a5d230bcc875202c487761a9b786e945 (patch)
tree63238d1977f2788cb5b7074037f15810af25bb88 /dev-python/shapely
parentd074d0ba59e3121dba0c27c4a18f1e481f67b62a (diff)
gentoo auto-resync : 04:12:2023 - 10:56:18
Diffstat (limited to 'dev-python/shapely')
-rw-r--r--dev-python/shapely/Manifest2
-rw-r--r--dev-python/shapely/files/shapely-2.0.2-c99.patch19
-rw-r--r--dev-python/shapely/shapely-2.0.2-r1.ebuild50
3 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/shapely/Manifest b/dev-python/shapely/Manifest
index 72f0775cc12a..75b79a457551 100644
--- a/dev-python/shapely/Manifest
+++ b/dev-python/shapely/Manifest
@@ -1,3 +1,5 @@
+AUX shapely-2.0.2-c99.patch 654 BLAKE2B 98ac763b8c6170708a3399f4f863d17ebdce9d9979832073c36539ba1d35cfb4388ba6442ea5fe954853c5c0149e80b03024fb915c6b7290eddd1270d078fdbc SHA512 9111c77d76f40c8d2595793091448b4e0d6d0696ce40dcc57d34285e06339e6537f7285aaaa88628302ab03dd591bd8bc1abb0091c5582cc17cf20a59a99986f
DIST shapely-2.0.2.gh.tar.gz 330120 BLAKE2B 01630239075c767897635fb25573bc37469ecb7b03d62cef2d82b95a8bd7216864087b9bbcaa46c75850f2048efac2b171f2a78090bf4cd846e882fd8b549942 SHA512 7d19984a1fae9a4ec6abaa2f88712ff442272019976427a915ccd3493e3dc8fe169c5ab3aacf71f3104fc325f93b1877bfcbe9c44968b661feccc38eeeb16f9a
+EBUILD shapely-2.0.2-r1.ebuild 910 BLAKE2B a940f01ae4cf6ab65f612276434d870c0a2884c5bef633412aac2cea5c71bec8e1cda0bfbb04f0f6b1cc65d646672b93908dd4b2576521843cc45261df24bb78 SHA512 b62fc41c55092af45768f24f68623c2029b292c9caa17e3a553614a974361f24681ade4b372d348d6b3f22cb8f17d2e9f066023f5b61f89a98a35cfb19b7d1fe
EBUILD shapely-2.0.2.ebuild 858 BLAKE2B 1aa394852469b0bcd9544266c49905074dbc55c5c3d5784fe478739208724c48c99f51745306a57e791085420c3abec97b1588689eb03e04d9d14b85d5fe0158 SHA512 cf24c0612e427daa1b195cbc4d58bffce046aaaf4665dee7f2ac1a8a464f0bf00302b295d8d34da083e290e1a057dd649c6934ea03f4d3a907d0ecef8deaf7e4
MISC metadata.xml 1000 BLAKE2B 9be4c31c417a5660338f479aee97ec224a420cbd1ebd665ff4269a9920e16a5d78b494790bd1450ceb8be0d1228666cb5f7559b76abc669b8a15e61fb683a38a SHA512 044961ebb0caebfdacfd130fa5ed132b3ce59d0f3343c76d394e2e1cd5544bc23d3013e5b206597960f514da0203d59759a115daeab1291b6ce40ca5bdce6c8a
diff --git a/dev-python/shapely/files/shapely-2.0.2-c99.patch b/dev-python/shapely/files/shapely-2.0.2-c99.patch
new file mode 100644
index 000000000000..a51fc8883103
--- /dev/null
+++ b/dev-python/shapely/files/shapely-2.0.2-c99.patch
@@ -0,0 +1,19 @@
+https://github.com/shapely/shapely/pull/1945
+
+From 9795506bba84e96418466ae84573c0cf8654bbeb Mon Sep 17 00:00:00 2001
+From: "Benjamin A. Beasley" <code@musicinmybrain.net>
+Date: Sun, 3 Dec 2023 11:36:36 -0500
+Subject: [PATCH] Fix incompatible pointer type passed to GEOSPolygonize_r
+
+--- a/src/ufuncs.c
++++ b/src/ufuncs.c
+@@ -2160,7 +2160,7 @@ static void polygonize_func(char** args, const npy_intp* dimensions, const npy_i
+
+ GEOS_INIT;
+
+- GEOSGeometry** geoms = malloc(sizeof(void*) * dimensions[1]);
++ const GEOSGeometry** geoms = malloc(sizeof(void*) * dimensions[1]);
+ if (geoms == NULL) {
+ errstate = PGERR_NO_MALLOC;
+ goto finish;
+
diff --git a/dev-python/shapely/shapely-2.0.2-r1.ebuild b/dev-python/shapely/shapely-2.0.2-r1.ebuild
new file mode 100644
index 000000000000..794dd6b9b43e
--- /dev/null
+++ b/dev-python/shapely/shapely-2.0.2-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=${P/_p/.post}
+DESCRIPTION="Geometric objects, predicates, and operations"
+HOMEPAGE="
+ https://pypi.org/project/shapely/
+ https://github.com/shapely/shapely/
+"
+SRC_URI="
+ https://github.com/shapely/shapely/archive/${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="
+ >=sci-libs/geos-3.9
+"
+RDEPEND="
+ ${DEPEND}
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${DEPEND}
+ >=dev-python/cython-0.29.32[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0.2-c99.patch
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ rm -rf shapely || die
+ epytest --pyargs shapely
+}