summaryrefslogtreecommitdiff
path: root/dev-python/shiboken6
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-06 11:57:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-06 11:57:11 +0100
commit2b03b0d9c5ca3890c219ebd24721133e766e9bb9 (patch)
tree5d30f335ce7ca22011789e938f980ff88db62a2c /dev-python/shiboken6
parentee3e7766db93c66376cf52eaac72b16fa156d223 (diff)
gentoo auto-resync : 06:10:2023 - 11:57:10
Diffstat (limited to 'dev-python/shiboken6')
-rw-r--r--dev-python/shiboken6/Manifest2
-rw-r--r--dev-python/shiboken6/shiboken6-6.5.2-r2.ebuild (renamed from dev-python/shiboken6/shiboken6-6.5.2-r1.ebuild)15
2 files changed, 12 insertions, 5 deletions
diff --git a/dev-python/shiboken6/Manifest b/dev-python/shiboken6/Manifest
index dd1817a0fbfa..6cdaf3dfb598 100644
--- a/dev-python/shiboken6/Manifest
+++ b/dev-python/shiboken6/Manifest
@@ -1,4 +1,4 @@
AUX shiboken6-6.3.1-no-strip.patch 1001 BLAKE2B c486f9423d4934c2305e8f3109f017dbebd568573469a2fced8da895fbc61ef07a80e0d1c846e7a57988801d6ec4be05b86b46a8039e6702d667129a899fc137 SHA512 1f3e5b082a978e3ab8d8f4d9a5a0a661b8c063e2ece0221440abe342fbd45d566a384d588dbf00a1e469687f82da3728cd53e35d02077ce6a748d3747de3cec2
DIST pyside-setup-everywhere-src-6.5.2.tar.xz 13576204 BLAKE2B 3e1d62e6d877140137896552184c8fe56fd62056a1ea506ab474256ee0e2f16d3e10ddb84965602650bb466f3563555c3c344698b6877a45f9130d1e919aba21 SHA512 ca677645579fc6b82285dd6c294909ca5e91a8c8efbc53bd103aff64e3ef89eff67820bfc9100cf50f043015d41c49d4ff86b3008f02505941a09bd54621f403
-EBUILD shiboken6-6.5.2-r1.ebuild 6472 BLAKE2B 941e5fbbe728e590719d65618586650fe201a7b02ebda541b7fea81112507a49949af580211055d6b72be368ff927c3fc5de0cd861b9091a62be5e1199ac4942 SHA512 c96c683e68499bc1795589fdc816fbef0feeaa9ec05b12861edf4dfb010420ab101ee6c64f1ba63be6a1eda8b4d25e1ffcd56a46c76bc6b25db989518f2e5cbf
+EBUILD shiboken6-6.5.2-r2.ebuild 6656 BLAKE2B 39c4dfb74d1dd5bc30f0aa0505bbfced3a828d0a41a42e10f08e472d5496447a9e7d9abcd19fa6d61f14bd79c671511d473f1495cad6409b63ab25b07ada157a SHA512 7876f161a7ac5f8982dafc554e03b3e62e1c6a5feb439900b68e7f9254e33cc64cbd6ef00b31e9e1f8ceedb8ab7e9d8959c16bf3628e7eca9468f10d5f7f3bcb
MISC metadata.xml 730 BLAKE2B 33e7e589d02ec0517e134aa50407ecb97c6800be3ab7b69174d65776f62c1f25c2b2209d51299d9e0110b5f5e9322ee2c0b43dc89e6b12c40ea322ca9bc8eb3f SHA512 cc4ecdd9bc86ce59c2027c6f87307d32bd76d5d2cd8c07edb6c60cc5317ea52a96136c7597a179d75f1632db2999300d8b8f0567679ba3fc562804774fcdcc98
diff --git a/dev-python/shiboken6/shiboken6-6.5.2-r1.ebuild b/dev-python/shiboken6/shiboken6-6.5.2-r2.ebuild
index 365771516fcd..359316a52fac 100644
--- a/dev-python/shiboken6/shiboken6-6.5.2-r1.ebuild
+++ b/dev-python/shiboken6/shiboken6-6.5.2-r2.ebuild
@@ -40,11 +40,11 @@ RESTRICT="test"
QT_PV="$(ver_cut 1-3)*:6"
# Since Clang is required at both build- and runtime, BDEPEND is omitted here.
-LLVM_MAX_SLOT=15
+LLVM_MAX_SLOT=16
RDEPEND="${PYTHON_DEPS}
=dev-qt/qtbase-${QT_PV}
- <sys-devel/clang-16:=
- <sys-devel/clang-runtime-16:=
+ <sys-devel/clang-17:=
+ <sys-devel/clang-runtime-17:=
docstrings? (
>=dev-libs/libxml2-2.6.32
>=dev-libs/libxslt-1.1.19
@@ -82,6 +82,13 @@ src_prepare() {
ApiExtractor/clangparser/compilersupport.cpp || die
fi
+ local clangver="$(CPP=clang clang-major-version)"
+
+ # Clang 15 and older used the full version as a directory name.
+ if [[ ${clangver} -lt 16 ]]; then
+ clangver="$(CPP=clang clang-fullversion)"
+ fi
+
# Shiboken6 assumes the "/usr/lib/clang/${CLANG_NEWEST_VERSION}/include/"
# subdirectory provides Clang builtin includes (e.g., "stddef.h") for the
# currently installed version of Clang, where ${CLANG_NEWEST_VERSION} is
@@ -97,7 +104,7 @@ src_prepare() {
# PySide6 does *NOT* care whether the end user has done so or not, as
# PySide6 unconditionally requires Clang in either case. See also:
# https://bugs.gentoo.org/619490
- sed -i -e 's~(findClangBuiltInIncludesDir())~(QStringLiteral("'"${EPREFIX}"'/usr/lib/clang/'$(CPP=clang clang-fullversion)'/include"))~' \
+ sed -i -e 's~(findClangBuiltInIncludesDir())~(QStringLiteral("'"${EPREFIX}"'/usr/lib/clang/'"${clangver}"'/include"))~' \
ApiExtractor/clangparser/compilersupport.cpp || die
cmake_src_prepare