summaryrefslogtreecommitdiff
path: root/dev-python/shtab/shtab-1.7.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-28 11:40:46 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-28 11:40:46 +0000
commit73c06e01ebc820f47f0140310b8a096e9d20877b (patch)
treee42588135c33dc1c950c2ac5de5dd32897af342b /dev-python/shtab/shtab-1.7.0.ebuild
parent88f366f99d8e731ae1a13d9eca9a5284484d2c6f (diff)
gentoo auto-resync : 28:02:2024 - 11:40:46
Diffstat (limited to 'dev-python/shtab/shtab-1.7.0.ebuild')
-rw-r--r--dev-python/shtab/shtab-1.7.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/shtab/shtab-1.7.0.ebuild b/dev-python/shtab/shtab-1.7.0.ebuild
new file mode 100644
index 000000000000..a2c1c32cd280
--- /dev/null
+++ b/dev-python/shtab/shtab-1.7.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Automagic shell tab completion for Python CLI applications"
+HOMEPAGE="
+ https://github.com/iterative/shtab
+ https://pypi.org/project/shtab/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="dev-python/setuptools-scm[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # Disable pytest-cov
+ epytest -o addopts=
+}