summaryrefslogtreecommitdiff
path: root/dev-python/simplejson
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-12 08:41:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-12 08:41:54 +0100
commit4df3bf9762850b34cd1ead5c80374d1a0fc3362e (patch)
tree3080c5cb7ad17abcb63776a9f21c4947845546a6 /dev-python/simplejson
parent814f4cf860e299a046b649eaee5463427984c09c (diff)
gentoo resync : 12.07.2021
Diffstat (limited to 'dev-python/simplejson')
-rw-r--r--dev-python/simplejson/Manifest2
-rw-r--r--dev-python/simplejson/simplejson-3.17.3.ebuild19
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/simplejson/Manifest b/dev-python/simplejson/Manifest
index 30c8a75b294a..beab903d4ff4 100644
--- a/dev-python/simplejson/Manifest
+++ b/dev-python/simplejson/Manifest
@@ -1,3 +1,5 @@
DIST simplejson-3.17.2.tar.gz 83210 BLAKE2B 1b9f97a43bfe84f1ad506713d81483ebcd4006d1174558b7a27373f99d014e23ed72a9ec2b2006e64760c61e1e500a4f1ea4547104e7f4c71ba51003df0a5052 SHA512 003b2fbcb3f8e0849bdbd958c78f8b470081d97527bef82306db77940c6734a1cbf3b5dcb0984d2f9c9d14aa525e7865a08e70a10971f8841e138f7ad6476e4a
+DIST simplejson-3.17.3.tar.gz 82434 BLAKE2B ae6f303a204f0c5a6bc7a10aa8da3dadbd4fc3a257abb15e330d13299dcbd5bc6be97506f6d5b48f3a3fe24570ac28b331644870d03aa30f80d40e69f4d2ec15 SHA512 b4ccdff3df2c87ed6f5119e93560ea7ddf60fcc64f996efeef1f6077f3a559c8f9ea77fd217348c1cba2de50e40523714899de110614953baf8385bb78d10af6
EBUILD simplejson-3.17.2-r1.ebuild 759 BLAKE2B 239ae01dda0770fdc8878c2c2e24e920967536299dfaca60c9dd5a03459469e3f222330eef5073d8311f56ef5f2aacd36b6472cd0e925d1feb40899da9128ac4 SHA512 b39b26240bd8f4e5e759471b2be04c3dd21f45e5aef016893496b32655326e2497141a16c05fcaaca7aadc6eda74a6fed281430882e4d15848c7c5cebb0774e4
+EBUILD simplejson-3.17.3.ebuild 630 BLAKE2B 79f94d0e77e3b2f3a0e96602adfedaa74be0f3e701acfcdee8a4aa81f1a10d0002b9e306de82539a8f1f2f639f173d4feaa379187aef4eef449c0eb0fde5b47b SHA512 2ea2e35033578aec72b5bf69f73664d14c4b599d3795b3acb4008a19a49a634cd97d782c7365a1db72452fbf9ed9bc1fb232e1b90eb3a67820ab642409686f8f
MISC metadata.xml 374 BLAKE2B 9bc3d7ea8f41525aa5306e4d8db6373ea172453d9b62f8712c7ce6e4982cd2d09b2b7581f42f6728442085eb0ec120333dad9a1ae6fb8f2752a5d690f640a5df SHA512 f1091ba57b32514620ff6265354681c7ee168a12c384c66d1302b3c4a2fca897d08802156b69136a0ed9bbc026a14ffdbf705419c43da66d0b659592b05b68ae
diff --git a/dev-python/simplejson/simplejson-3.17.3.ebuild b/dev-python/simplejson/simplejson-3.17.3.ebuild
new file mode 100644
index 000000000000..4eeb70ccbda3
--- /dev/null
+++ b/dev-python/simplejson/simplejson-3.17.3.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
+HOMEPAGE="https://github.com/simplejson/simplejson https://pypi.org/project/simplejson/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( MIT AFL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+DOCS=( README.rst CHANGES.txt )
+
+distutils_enable_tests unittest