summaryrefslogtreecommitdiff
path: root/dev-python/simplejson
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/simplejson
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/simplejson')
-rw-r--r--dev-python/simplejson/Manifest3
-rw-r--r--dev-python/simplejson/simplejson-3.17.5-r1.ebuild24
-rw-r--r--dev-python/simplejson/simplejson-3.17.5.ebuild2
3 files changed, 27 insertions, 2 deletions
diff --git a/dev-python/simplejson/Manifest b/dev-python/simplejson/Manifest
index 288c67ea413f..dee30c4c1bac 100644
--- a/dev-python/simplejson/Manifest
+++ b/dev-python/simplejson/Manifest
@@ -1,3 +1,4 @@
DIST simplejson-3.17.5.tar.gz 83182 BLAKE2B 8fbaa83c81a7478b3c62c6625e717874f6dd3bef236b85504788a66d2b820dbf601e65edbcc7056528e67a66b806b3847b8efcc522464604bd4987dce9870643 SHA512 f5af32e4f9b4575323f9c0eb8163e794270a8607710d08a72cece953f57861e3619038798369ea049d82b9b53f293b9d9eefdeb4dd94ab4f043506bc3f1ddfad
-EBUILD simplejson-3.17.5.ebuild 628 BLAKE2B d7f31c54026481b3a97289da19abc5905fc15ca1469fa55be849c6b5c13e6e6096dd2a583f09c46ed6b1eb0180b0b399e5abde2a9d01b05a4eefe6cbbceeed3d SHA512 fb9f86e9cd5c50253da4435d8962f8f76aee348286511a165463b0fe882cf4a8b3975228870bd881fcd92166bdffeda8592679ea04f19369865a1bad6157c1ab
+EBUILD simplejson-3.17.5-r1.ebuild 681 BLAKE2B 404388de6ac84f52a17a4d7d450c4f128e86aceda17b764894a260c84e9b1b58012f1659d95852dd75a35ac8ad9d669b05837d962c42ab80297bfe1f8838717e SHA512 73cd38632b70dfcd52e2f78733e58e3a1b63d140a3b8a7d94d5c839d16cab3527aa1225b1b7bd9ab16d46954e70d0200a55a97052d12d822bafa093d9cf8ad76
+EBUILD simplejson-3.17.5.ebuild 635 BLAKE2B 5e35845393c3bdf0e3220c86ac68bd3177286cab6f8a4afcef4ea132252bd4bb9b7664daab3d2615f815212d3248551d5a34818033c8d83fed596f0d06ff515e SHA512 b53626aca1805d05ffa5ef8140c878950b1dcd4039628fb96abe7d7e6b6e09e774c84356d5229e2506df6cb2b633b22c628c5b2c1bacae290376d1ee7562e049
MISC metadata.xml 375 BLAKE2B 2c3a0f98ee3f6c9ba41edf3e8e4d6536ac518a59234e6c602d46cbfcb8a5c760c71997b3c169dd2c0b3f9c5dcbea1cb36967e4d050933bd5e31d6f609a835e83 SHA512 6ad418641e64295566aa5418b9bead66e7ea84e0ca7aa454bfedf613cde7ed4d1cd17dff962963c3dda62ad9050e6348f9f53da21ba25b53cdeba2d91b8c551d
diff --git a/dev-python/simplejson/simplejson-3.17.5-r1.ebuild b/dev-python/simplejson/simplejson-3.17.5-r1.ebuild
new file mode 100644
index 000000000000..84d4dee1f814
--- /dev/null
+++ b/dev-python/simplejson/simplejson-3.17.5-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
+HOMEPAGE="
+ https://github.com/simplejson/simplejson/
+ https://pypi.org/project/simplejson/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( MIT AFL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+DOCS=( README.rst CHANGES.txt )
+
+distutils_enable_tests unittest
diff --git a/dev-python/simplejson/simplejson-3.17.5.ebuild b/dev-python/simplejson/simplejson-3.17.5.ebuild
index d7d4e2b5d186..5390d37cace5 100644
--- a/dev-python/simplejson/simplejson-3.17.5.ebuild
+++ b/dev-python/simplejson/simplejson-3.17.5.ebuild
@@ -12,7 +12,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="|| ( MIT AFL-2.1 )"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
DOCS=( README.rst CHANGES.txt )