summaryrefslogtreecommitdiff
path: root/dev-python/simpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-19 13:58:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-19 13:58:24 +0100
commit12652841746da7ae2f03b8b0c571a9bd5033e15c (patch)
tree17ba3a2b3f142284453d0e9109be1765200f643b /dev-python/simpy
parent27f7ac2204449d9fc2137f442522b4fb10327d90 (diff)
gentoo auto-resync : 19:10:2022 - 13:58:24
Diffstat (limited to 'dev-python/simpy')
-rw-r--r--dev-python/simpy/Manifest1
-rw-r--r--dev-python/simpy/simpy-4.0.1-r1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/simpy/Manifest b/dev-python/simpy/Manifest
index 7a287a03a106..3e821f42d2d5 100644
--- a/dev-python/simpy/Manifest
+++ b/dev-python/simpy/Manifest
@@ -1,3 +1,4 @@
DIST simpy-4.0.1.tar.gz 410082 BLAKE2B 09c6f29d2792ac15bb4a3b42a1cdbd4d342aca0ef528aadbe37e01342534645939c9663977230ec7f6f1542a4354925e25f0c5b3bf6e20b29b6da2e69f3d5a90 SHA512 5cc4baada79503e3c2f2425b9f7f00d68f263283ff0cae048fba86665c4dcf70590683f6b7df50d1c1a914ac7cb471ed4b6850676030bea4a3a70fb40eb2cdb4
+EBUILD simpy-4.0.1-r1.ebuild 917 BLAKE2B 3a1e03704932c8f6909deb7113885642bdf0df31f9793845a9c6291e8230f4cce1a5d8ee254b5070248a65b28ea7df84676a6e90ddad00ff574ad91105e901a2 SHA512 05679115b5e81b212864e2387de2c9fef55343a400987767fd8bc909331c1c6b325c682a676d16865c1a7f8b2eea52916cab6ed2134347928db904a83f281801
EBUILD simpy-4.0.1.ebuild 894 BLAKE2B 5c435abdd2d49374a29c53e27e19c75921405773acd69499696e56150c2451eb2543744bb349895edb111794b43946ba5040a4464e586007c265969d9d43b5a3 SHA512 89bff8e1e5566415afce1fbcf51ff3fd444f15c98480e4631bd3a90e59a5454dcce1e2d625e85613a68f909cf72696998f2c79676072285011be6d8be2519c4a
MISC metadata.xml 384 BLAKE2B 8f679e95c624b40c8c89f95b3d1e2607bbc0955c5a98b2ad1e92cd49a762a43d937426e7d369b900cc9002418e28e44e280dbd6f5a08b0bedbdd3052563606bc SHA512 24e7b4072a8653aa4c62be190c6c03701f46d8418577e8deafea3eb4da77a293d433e24e264a778f865e3daf8a7ee166af88831bdfe9fd52d5bd157e44b25274
diff --git a/dev-python/simpy/simpy-4.0.1-r1.ebuild b/dev-python/simpy/simpy-4.0.1-r1.ebuild
new file mode 100644
index 000000000000..fac65d7b2095
--- /dev/null
+++ b/dev-python/simpy/simpy-4.0.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="tk"
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+MY_P="${P/simpy/SimPy}"
+
+DESCRIPTION="Object-oriented, process-based discrete-event simulation language"
+HOMEPAGE="https://simpy.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+# Could not import extension sphinx.builders.epub3 (exception: cannot import
+# name 'StandaloneHTMLBuilder' from partially initialized module
+# 'sphinx.builders.html' (most likely due to a circular import)
+# (/usr/lib/python3.10/site-packages/sphinx/builders/html/__init__.py))
+#distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest