summaryrefslogtreecommitdiff
path: root/dev-python/simpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-06 10:15:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-06 10:15:54 +0000
commiteb7aa327b218d640c8bda63ba0fd1ace2bd2d17b (patch)
treebbe526e2a2c1fd2fd7ee20d62b99c7ac30476aff /dev-python/simpy
parent6471b382a951b256ffa1b8ea3e6e7d7f5b189281 (diff)
gentoo auto-resync : 06:11:2023 - 10:15:54
Diffstat (limited to 'dev-python/simpy')
-rw-r--r--dev-python/simpy/Manifest2
-rw-r--r--dev-python/simpy/simpy-4.1.0.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/simpy/Manifest b/dev-python/simpy/Manifest
index 968c05d296ba..5b53ef9d2de0 100644
--- a/dev-python/simpy/Manifest
+++ b/dev-python/simpy/Manifest
@@ -1,3 +1,5 @@
DIST simpy-4.0.2.tar.gz 410706 BLAKE2B 787da43fe29135ef3f70f286074e5b6dba50c26f50910674a290a4e9e95fe68dffca5e5308e629f8359181f9e7200938b980bdbd9d7b2c09beb30dd49069fdce SHA512 a1f9e10928930817a07ee851f3190c4aefb9c4f0538557b7cc5b0f8950ed2234878f29d1790cbf6991b78bbd73e989d7df0ed1997847eedf129fc9d1c4d1fc23
+DIST simpy-4.1.0.tar.gz 407835 BLAKE2B 840815663c65e22cd8fbdf74d70fba6c5badb38e33c8506a52e163cfea2fa4f72370c4c3d53c106017c74a10a83ac15fd204f35dcffd70b29a4eb9bb4647049d SHA512 8d54e332ffd6c3ae32904a75c599b0bc33f2ac5f294c89f76632b3b2867de561169504870c89cf6f091a6674d9b9c6168f88887c628bba59e4ef2985176c8586
EBUILD simpy-4.0.2.ebuild 993 BLAKE2B e503390e3b8bc37e5f5b187291062cc8ff65c626df00eab638929ec5fb07d4306a88e332a1d0e1634a244da0a0d1bcba59fa622dfc7879bf02038cc014b759f1 SHA512 0c2159aa6bbd90c2053b30f609daaedd071fc185a8d96e4f1e6b1802e110f15b83bc4663f763fa00f93aec68237784f441e4e5a70bc7dc02cd3c600faceef535
+EBUILD simpy-4.1.0.ebuild 995 BLAKE2B 8994f1ee7211e178726cd24fc700300f25b29960245fd248e6470a1f838dc34193b9572321e76e5c078a58efd56e25260e7efe7a878e2ffc0f4ae2ca783d2083 SHA512 91c2795fdec50403f550cea4e68a9cbba6e122883c4fe3eee1433382db8a6435231f5122c8bc5ec623df453e7a068c0eb86bbd7e8af926d0bd8d544222c31bcc
MISC metadata.xml 390 BLAKE2B 69ebc7a2e53d6b632403d5cb184e351b33fbca28b380332c961d940c6ef852b830363ced8768f752ba29b9fe2d533bc17d5af6eca2428b491efeb407d8259e31 SHA512 7f7c6e1efe74ff01be746ecdbc68845dad65697e72e3b160683c4587cec353cd314294df5c3b46ea8d5e72bb8f38a5c3f68097c3cb93d020daa5d9601a4131a7
diff --git a/dev-python/simpy/simpy-4.1.0.ebuild b/dev-python/simpy/simpy-4.1.0.ebuild
new file mode 100644
index 000000000000..e7d76b0c98c1
--- /dev/null
+++ b/dev-python/simpy/simpy-4.1.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="tk"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Object-oriented, process-based discrete-event simulation language"
+HOMEPAGE="
+ https://simpy.readthedocs.io/
+ https://gitlab.com/team-simpy/simpy/
+ https://pypi.org/project/simpy/
+"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+# Could not import extension sphinx.builders.epub3 (exception: cannot import
+# name 'StandaloneHTMLBuilder' from partially initialized module
+# 'sphinx.builders.html' (most likely due to a circular import)
+# (/usr/lib/python3.10/site-packages/sphinx/builders/html/__init__.py))
+#distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}