summaryrefslogtreecommitdiff
path: root/dev-python/sip
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-13 02:01:50 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-13 02:01:50 +0000
commit2a3e0d61b3d88306b6fae46756f9ba7d230222ae (patch)
treea0d3259dd259861a49a2d3e6e9220beaa8ec39c2 /dev-python/sip
parent39c32f4d5dca9f6293fccb69e9d50baf494c8de4 (diff)
gentoo auto-resync : 13:12:2024 - 02:01:50
Diffstat (limited to 'dev-python/sip')
-rw-r--r--dev-python/sip/Manifest2
-rw-r--r--dev-python/sip/sip-6.9.1.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/sip/Manifest b/dev-python/sip/Manifest
index 8f56ae4724e5..57efd3bbc03a 100644
--- a/dev-python/sip/Manifest
+++ b/dev-python/sip/Manifest
@@ -1,5 +1,7 @@
DIST sip-6.8.6.gh.tar.gz 515751 BLAKE2B 769a1270351473f1c498e0d3cd463df3aa0992782b5501bd06455b71be05cae5a9754611bad4f966cc5b204170fec7fccbb065d9ed4c800daaa1bd6448a96352 SHA512 bfbeace21ef0bfd072548bcdb9af1f4917a33e15bcd9c5f6575aea0dc0eeaeec4aa322b2408f586c0e2713ada65c1657f81a4e0eb25cb9a3472fada234beca33
DIST sip-6.9.0.gh.tar.gz 517388 BLAKE2B 453b4f124dad36b3bd2f8e86c41249bc77d2c6841eefe4a922c08306339c939c2894402ee149275a6bffab468a9b2ab05c7beeb8c214ebd0b7842ef0dbaa6f5b SHA512 ffa4035ff04a5c1ed7848322d052ed96419bddd96e20fda86307db4d96776cc00544df021423c0fd358989d4ba982648499eb7f6ddf18f04a38deab9184bfacb
+DIST sip-6.9.1.gh.tar.gz 517896 BLAKE2B 1ed8eb2e3cdf4eca76aed82bafbfb6ed60163cc58aff7a709cff29c2b370c68d5dcfce8db04768b9133fba58a24734bbc32b7c5a004ab84a73661db690976228 SHA512 670b1afcf7c6337f48d53cea86c535f24932393d68ee1654c754bfa3481f2f736f1dc935f39f501650e210112034b0fdb8c8ec46627066d9af3be0c599e8a093
EBUILD sip-6.8.6-r1.ebuild 849 BLAKE2B 985e254c4f7e7810541b7d792f378c855ce4433418e4f874eaabce3116f865cff5dcd6f2c2a40b58753aa11c8723004391a39dc85ded39f70e70bd7abf42429d SHA512 b6b2d4dc861857525a41029841fe15ef43c6097e5710ea5cfe411ead400d286a34af3053f1758b0790542f8d88a494ba304f3c716086dfe0552d182b978b4f1e
EBUILD sip-6.9.0.ebuild 855 BLAKE2B 504980e69a83baa210e8cd9c6f88227594394500222b0c84a9be643d5d48d1fc54c95a5ee987429b89d1114574cc780b870a0275049d306fc9980f591fbfb0c9 SHA512 6f76e0a5e4a2ec2f69e5fd2da4dcc48b31d8707dade249b3389c10022277f06a2b76de906e736895a6c201a2ffbbb57191d6d9afc2209dd2fe3ac6862299ae18
+EBUILD sip-6.9.1.ebuild 855 BLAKE2B 504980e69a83baa210e8cd9c6f88227594394500222b0c84a9be643d5d48d1fc54c95a5ee987429b89d1114574cc780b870a0275049d306fc9980f591fbfb0c9 SHA512 6f76e0a5e4a2ec2f69e5fd2da4dcc48b31d8707dade249b3389c10022277f06a2b76de906e736895a6c201a2ffbbb57191d6d9afc2209dd2fe3ac6862299ae18
MISC metadata.xml 524 BLAKE2B 57657d01dc5be425f66f1136356fa028a32ad6a2ca79cadf4b9ed6a940b414b0e3efa161895d1858ab3d4977241883f9dfefbe37a8cbaad10589d57f598856a1 SHA512 82208b61b297d8c2110ea47a82c046118afd9332c52fa6590f7ed11b4e70af8b75f087b006fa5ed9058dbd2f98f02104559e085f781f2fc887396b7ff9d1b859
diff --git a/dev-python/sip/sip-6.9.1.ebuild b/dev-python/sip/sip-6.9.1.ebuild
new file mode 100644
index 000000000000..a67928c5bda2
--- /dev/null
+++ b/dev-python/sip/sip-6.9.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings generator for C/C++ libraries"
+HOMEPAGE="https://github.com/Python-SIP/sip/"
+SRC_URI="
+ https://github.com/Python-SIP/sip/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD-2 BSD"
+SLOT="5"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/tomli[${PYTHON_USEDEP}]' 3.10)
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-8[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ dev-python/myst-parser \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest