summaryrefslogtreecommitdiff
path: root/dev-python/six
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/six
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/six')
-rw-r--r--dev-python/six/Manifest3
-rw-r--r--dev-python/six/six-1.16.0-r1.ebuild32
-rw-r--r--dev-python/six/six-1.16.0.ebuild4
3 files changed, 36 insertions, 3 deletions
diff --git a/dev-python/six/Manifest b/dev-python/six/Manifest
index f9793156f534..18b2b5862216 100644
--- a/dev-python/six/Manifest
+++ b/dev-python/six/Manifest
@@ -1,3 +1,4 @@
DIST six-1.16.0.tar.gz 34041 BLAKE2B 764f8da9a0d89e95af002c79c2b19e852fdec9a6819655c57be019b48bd65a5f7909473e71887e6080073f381f983c077487591d4e44297542cf6b9a29ba42b8 SHA512 076fe31c8f03b0b52ff44346759c7dc8317da0972403b84dfe5898179f55acdba6c78827e0f8a53ff20afe8b76432c6fe0d655a75c24259d9acbaa4d9e8015c0
-EBUILD six-1.16.0.ebuild 830 BLAKE2B 1796d67b0193d7e8be88113297ea741a9719db600a8df6f2e1e047074dba7dc09cc003bff171173d33f2c2c9672062f1eeb8a488a64cf3f76b36e40da5c6057f SHA512 85f3222d2cd6c384f2abfcb86912df7ab3ba394b38e0ac2092e83b0980232f694db8feee48a05770590140a5b0f48fde51b0764343c863405fcd09032f91f5cd
+EBUILD six-1.16.0-r1.ebuild 869 BLAKE2B feaef1b49f5654b67cd7eb965e3d4bb4f491c25ddd793394244ee7c1467b2999a21e094f8a807daeef26ede53970f145c148fc49397859ac2cd97557aefb787f SHA512 28e7e63b2c2a015b6bca02cf272afa36e651057d23632f01e85a11a2c6e7a9484bdfb0e5a5b74a5635d8ccb8d21e28ca45c79172cd3f28260b4c68f188271d02
+EBUILD six-1.16.0.ebuild 837 BLAKE2B da3b3723743fd72a6cc736f1a51d13c6c7ff7202798c5dc631188b62e668975d2cdfa8a818250329eb2d7413b8135393ad2862f95bf67edb8a362e7db7262918 SHA512 28007f4ee4ec13b6d50b7efed1a548c554a8b62cf5f1a2bc08195ec6fb6956326c97e5ddfa123b5423f5fa0aa5842099358fb19847ed3d70fe2e3acd4c4c9b06
MISC metadata.xml 397 BLAKE2B ec6bbdf426ea83004d6c5eae83e650c6d601d639a51a08e58e9bc7d187877bbec9cb89f05f7b44ad521a2cc4f82269503cbd5f882c8e67d96a9018500803f931 SHA512 13d061df717192e9de816f03d7386218d8a760665d2d6ff2187da9152d0a7d7085df96cecbf47d76f9099b0eea8640506fce924d52e1f16300a6bcb06a2406b8
diff --git a/dev-python/six/six-1.16.0-r1.ebuild b/dev-python/six/six-1.16.0-r1.ebuild
new file mode 100644
index 000000000000..5a7dc9923d19
--- /dev/null
+++ b/dev-python/six/six-1.16.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python 2 and 3 compatibility library"
+HOMEPAGE="
+ https://github.com/benjaminp/six/
+ https://pypi.org/project/six/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+distutils_enable_sphinx documentation --no-autodoc
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
+ 'test_six.py::test_move_items[dbm_ndbm]'
+ )
+
+ epytest
+}
diff --git a/dev-python/six/six-1.16.0.ebuild b/dev-python/six/six-1.16.0.ebuild
index 830bec098c8c..601cf02a7860 100644
--- a/dev-python/six/six-1.16.0.ebuild
+++ b/dev-python/six/six-1.16.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -13,7 +13,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
distutils_enable_sphinx documentation --no-autodoc
distutils_enable_tests pytest