summaryrefslogtreecommitdiff
path: root/dev-python/six
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /dev-python/six
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'dev-python/six')
-rw-r--r--dev-python/six/Manifest4
-rw-r--r--dev-python/six/six-1.14.0.ebuild2
-rw-r--r--dev-python/six/six-1.15.0.ebuild20
3 files changed, 24 insertions, 2 deletions
diff --git a/dev-python/six/Manifest b/dev-python/six/Manifest
index 22f8332e3772..77b6484bcc50 100644
--- a/dev-python/six/Manifest
+++ b/dev-python/six/Manifest
@@ -1,3 +1,5 @@
DIST six-1.14.0.tar.gz 33857 BLAKE2B 711ef5b79118c1280c9868688869cc475668c248e6b0c2061145818842d5b4c28809d86b1388709af24f6e92fe5926ea6261f1b85c62db749f79664cbad93e4d SHA512 4dea0f4e7961e8b582d665501c65852dc3b73516a0b6f78b0888c8670f1450df58bd3eea418777f41080b842ab6c3d8633be1034bcf920192e5590d5316e2c9e
-EBUILD six-1.14.0.ebuild 676 BLAKE2B 816b596fcaa18032f1042586bda6416458f532a9f8a613533024e059b21645c5ed61b1f82a66eba72e87fe0bf798d96fc79c3384ce1a9c47e4f2053bf255d557 SHA512 f84d9095be0e2d5ffd508b03a877e5760a5eafdeeb75248cb4cfefff7c71fccadd77ed1daad3ec005b81d321a3e56c8c87a2aa8136fd2e115258c25af89a1e0d
+DIST six-1.15.0.tar.gz 33917 BLAKE2B 57e852b6c35dd19e256814c0371cfbc26141b0f25a31f79a1cbd1b0cdd7d3cacf1236b96f5452f968cc426e6dff4d1ad70a9f2432bc361ba3c8c17fd40fe7582 SHA512 eb840ac17f433f1fc4af56de75cfbfe0b54e6a737bb23c453bf09a4a13d768d153e46064880dc763f4c5cc2785b78ea6d3d3b4a41fed181cb9064837e3f699a9
+EBUILD six-1.14.0.ebuild 689 BLAKE2B ff4f54f7fb3e48bbea4fd2dc414668e95cd55cb78ed55f91934e304de9b9ec95b3c70e60e144aaaa36d39ac8351f324293803deecd35e8b13bf096435e39a499 SHA512 3b89249aff7ee4847e88a3343096ec4cbf5930b16c1dba3d9dce77a8359157e7c2c45d2aef508d6a34d3349a1ef5973b496db898478339bc16fdbd7f574e8159
+EBUILD six-1.15.0.ebuild 700 BLAKE2B a3d6710773c64fb242887345ceaea95ad8c88de4d43cdeb2d73a7f31e76dfd6fe87e24c40877a5e5ca1d2ef5fc5793d5b8b9254b82dcdb79f2dd8a6b66d3b443 SHA512 ea9962f66ae2732c681f30d1141d8a49ee30d44ae26371fbf6ac5cb2808784b5d264476e936daca2b1089daccc9adde3dd8e70c431f619904c634b595c56bbd0
MISC metadata.xml 396 BLAKE2B 4b08f7faa6e73dee9d4f39caebc0eef9901f408c1cdfe5d883b350af406de2731e654c2a1c266daf07299451f57b8a717214ca1716463f7f43b376a51b4f6c2c SHA512 03881122a5eae7539c27d078eaf69f34e121f3a8a43c7e0ca9470c0ec6863ea268b5facc64e0ab100cc6b8c00473f784042047f077ceaa7f13d70d71dce03391
diff --git a/dev-python/six/six-1.14.0.ebuild b/dev-python/six/six-1.14.0.ebuild
index de9905e4010a..2b7b9e966813 100644
--- a/dev-python/six/six-1.14.0.ebuild
+++ b/dev-python/six/six-1.14.0.ebuild
@@ -16,5 +16,5 @@ SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="doc"
-distutils_enable_sphinx documentation
+distutils_enable_sphinx documentation --no-autodoc
distutils_enable_tests pytest
diff --git a/dev-python/six/six-1.15.0.ebuild b/dev-python/six/six-1.15.0.ebuild
new file mode 100644
index 000000000000..cd8f4891597e
--- /dev/null
+++ b/dev-python/six/six-1.15.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python 2 and 3 compatibility library"
+HOMEPAGE="https://github.com/benjaminp/six https://pypi.org/project/six/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc"
+
+distutils_enable_sphinx documentation --no-autodoc
+distutils_enable_tests pytest