summaryrefslogtreecommitdiff
path: root/dev-python/slixmpp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-29 06:30:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-29 06:30:44 +0000
commit0e12f8e53cdddba84b0eb27dca59153e2cf52309 (patch)
tree8dec970370295a71970b82457ae1db36dbbbd07c /dev-python/slixmpp
parent72fd2b48b7154274a1d2009cdaab54e7f49fb3aa (diff)
gentoo auto-resync : 29:12:2024 - 06:30:44
Diffstat (limited to 'dev-python/slixmpp')
-rw-r--r--dev-python/slixmpp/Manifest2
-rw-r--r--dev-python/slixmpp/slixmpp-1.8.6.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/slixmpp/Manifest b/dev-python/slixmpp/Manifest
index 24375a3ceb12..e4e9aec97ad1 100644
--- a/dev-python/slixmpp/Manifest
+++ b/dev-python/slixmpp/Manifest
@@ -1,4 +1,6 @@
DIST slixmpp-1.8.5.tar.gz 574560 BLAKE2B 3ac5b1f41acdf4dd725355cdb06e7642d67b5b51a533e933af1b451df424d3e81267ce945e577b21a07f943578119913a9a42dd4e65426223ff413ad52c3f110 SHA512 f2e123bd462097d0b7dc28cd960f723419f4fa2af59c8f5b7d30a05135c2f9fc6982e6d2855ea10b22936bdd4a96faeae73f87a495e2d1f10e6c63cdcb412665
+DIST slixmpp-1.8.6.tar.gz 581633 BLAKE2B 43482ae13020c8302ec432cb77da5bac53a4ed43368ee5398e05c300f63db5d14b4590aacbf592cbdf904b7ce6f07bcd72b152efd0614fba2028cf01f3663174 SHA512 b013145fbd44dd6f38fd7beb15af5d83bd9e6f843308a2124b2fbb1a70f0ead1f0739946c24d66a11aef60d660de6fcced846e91ecd1ad58ef84410be89b2356
EBUILD slixmpp-1.8.5.ebuild 1035 BLAKE2B be42b9c219db70e5b545f111789ef53a8c9bd21bf95a456f85702ed11cfda44beaeb1d3bef044227c1ba223c070af42aecdad8864602503a57bf7ad6fe073ec7 SHA512 c22f1e44637fc1feac81ff8308b7f394ae7c2e82efb66b5bf64389ee626d0d74266b322e273c21f2ac586184b191d9a0e69ce578ec5b6b9e52dafc66c1ecf4a0
+EBUILD slixmpp-1.8.6.ebuild 1042 BLAKE2B 766eca8d272fa6f9db809ca26b9d0384ec4bde2079004888f2fe48afaa275f0180d27134895ac0c9982571e0a599ec210e9ceea6454ed7a2dd3188910db49096 SHA512 3c5babb654081417feb4ae928a2d5ac1b282c04c0aa1db5d258e2c0c42e7868fb753c2adeaa6e632cabd13393004f00dd2151ab90a5e0add73dfa38da69a7df2
EBUILD slixmpp-9999.ebuild 1035 BLAKE2B be42b9c219db70e5b545f111789ef53a8c9bd21bf95a456f85702ed11cfda44beaeb1d3bef044227c1ba223c070af42aecdad8864602503a57bf7ad6fe073ec7 SHA512 c22f1e44637fc1feac81ff8308b7f394ae7c2e82efb66b5bf64389ee626d0d74266b322e273c21f2ac586184b191d9a0e69ce578ec5b6b9e52dafc66c1ecf4a0
MISC metadata.xml 474 BLAKE2B 0b9d76c7ec0cfb4a39790ccf24386fe0557b0fea16c0a71ceed651214df6d97747066b4d7b45767f0dd54849f378d05d715a032cd71ab42b5ba98ad0f4c53506 SHA512 ec3ced30b38cc132a2b07bb71f41d8e0990922ae56834288345f0e546c0b6c19c69982b666e9f40389424de33ed0c7737459764ed167db2ebefc3aa2bbccfc72
diff --git a/dev-python/slixmpp/slixmpp-1.8.6.ebuild b/dev-python/slixmpp/slixmpp-1.8.6.ebuild
new file mode 100644
index 000000000000..bfb50b4c7a14
--- /dev/null
+++ b/dev-python/slixmpp/slixmpp-1.8.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python 3 library for XMPP"
+HOMEPAGE="
+ https://codeberg.org/poezio/slixmpp/
+ https://pypi.org/project/slixmpp/
+"
+LICENSE="MIT"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://codeberg.org/poezio/slixmpp.git"
+ inherit git-r3
+else
+ inherit pypi
+ KEYWORDS="~amd64 ~riscv"
+fi
+
+DEPEND="
+ net-dns/libidn:=
+"
+RDEPEND="
+ >=dev-python/aiodns-1.0[${PYTHON_USEDEP}]
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ ${DEPEND}
+ $(python_gen_cond_dep '
+ >=dev-lang/python-3.12.1_p1:3.12
+ ' python3_12)
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ rm -rf slixmpp || die
+ eunittest -s tests
+}