summaryrefslogtreecommitdiff
path: root/dev-python/slixmpp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /dev-python/slixmpp
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'dev-python/slixmpp')
-rw-r--r--dev-python/slixmpp/Manifest4
-rw-r--r--dev-python/slixmpp/metadata.xml11
-rw-r--r--dev-python/slixmpp/slixmpp-1.4.0.ebuild36
-rw-r--r--dev-python/slixmpp/slixmpp-9999.ebuild36
4 files changed, 87 insertions, 0 deletions
diff --git a/dev-python/slixmpp/Manifest b/dev-python/slixmpp/Manifest
new file mode 100644
index 000000000000..c50d2d8303f4
--- /dev/null
+++ b/dev-python/slixmpp/Manifest
@@ -0,0 +1,4 @@
+DIST slixmpp-1.4.0.tar.gz 862826 BLAKE2B 940c6c66f7f98574c88da6fbfaadf7103c4469cd198e096fbad57978f5e206c53b86933a930a24a8b891415b961c4a255d4c9c25885a8bd630f5d6185486fb6e SHA512 586fa5156641d786f9e45df8e6a1a20b8cb2dc2b9baef2a0713daa9ab8a3321202fd4b31d5753cf2659cc9311a4842bee9991a7fc295e62dfd78a869d8619d20
+EBUILD slixmpp-1.4.0.ebuild 743 BLAKE2B f36566965aa8ed05c1f7d545ee212988563e02b07a885e2ffe48c92f417761d35bcc239b789d7d6811d812d87c69f26beb929dc7d352ea5849b9c0a481a5d995 SHA512 1ffc207ac454b9dcaf57c3c2f2a329096ffd0809bfaa9c617c39fe36e06798a4a3ebef0db4a1750799f19f9cddeba52c6948d19ef8072491722ba728174d8b31
+EBUILD slixmpp-9999.ebuild 743 BLAKE2B f36566965aa8ed05c1f7d545ee212988563e02b07a885e2ffe48c92f417761d35bcc239b789d7d6811d812d87c69f26beb929dc7d352ea5849b9c0a481a5d995 SHA512 1ffc207ac454b9dcaf57c3c2f2a329096ffd0809bfaa9c617c39fe36e06798a4a3ebef0db4a1750799f19f9cddeba52c6948d19ef8072491722ba728174d8b31
+MISC metadata.xml 321 BLAKE2B 263ceaeeaf4eb1405ad1fa44a5a064ad778b1759e9b4f72dd4e110b28c4bc904897029441ea4c5b1d577472f13dc1baebd2bca0dd11ec7f624708eefed6d4db6 SHA512 1d3070cf4fbf0feaf8473e8f9e354f401c64cbd526f94bf42721528fa94852146084219beee4c344138a1d1241783b12a47e6a4fd9de95cb330dd82baaab92e5
diff --git a/dev-python/slixmpp/metadata.xml b/dev-python/slixmpp/metadata.xml
new file mode 100644
index 000000000000..97309be0a01b
--- /dev/null
+++ b/dev-python/slixmpp/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrey_utkin@gentoo.org</email>
+ <name>Andrey Utkin</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">slixmpp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/slixmpp/slixmpp-1.4.0.ebuild b/dev-python/slixmpp/slixmpp-1.4.0.ebuild
new file mode 100644
index 000000000000..be8cfcfecb51
--- /dev/null
+++ b/dev-python/slixmpp/slixmpp-1.4.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6} )
+
+inherit eutils distutils-r1
+
+DESCRIPTION="Python 3 library for XMPP"
+HOMEPAGE="https://dev.louiz.org/projects/slixmpp"
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://lab.louiz.org/poezio/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="
+ dev-python/aiodns[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ net-dns/libidn
+ test? ( $RDEPEND )
+"
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/slixmpp/slixmpp-9999.ebuild b/dev-python/slixmpp/slixmpp-9999.ebuild
new file mode 100644
index 000000000000..be8cfcfecb51
--- /dev/null
+++ b/dev-python/slixmpp/slixmpp-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6} )
+
+inherit eutils distutils-r1
+
+DESCRIPTION="Python 3 library for XMPP"
+HOMEPAGE="https://dev.louiz.org/projects/slixmpp"
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://lab.louiz.org/poezio/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="
+ dev-python/aiodns[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ net-dns/libidn
+ test? ( $RDEPEND )
+"
+
+python_test() {
+ esetup.py test
+}