summaryrefslogtreecommitdiff
path: root/dev-python/smartypants
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/smartypants
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/smartypants')
-rw-r--r--dev-python/smartypants/Manifest3
-rw-r--r--dev-python/smartypants/smartypants-2.0.1-r1.ebuild39
-rw-r--r--dev-python/smartypants/smartypants-9999.ebuild31
3 files changed, 24 insertions, 49 deletions
diff --git a/dev-python/smartypants/Manifest b/dev-python/smartypants/Manifest
index e5978b3d7638..d2aa0c8e3ba4 100644
--- a/dev-python/smartypants/Manifest
+++ b/dev-python/smartypants/Manifest
@@ -1,4 +1,3 @@
DIST smartypants-2.0.1.tar.gz 24152 BLAKE2B 258c9692eec675054dc31f760cf3a9fc3995683d7a15fc549fb390611761c0b09f73e077f5917f9f071a8fc1ae3f06e36f745fdc0e2c368f465e29f6ce51457f SHA512 d47a866a5478c3520251f87a93a468a5eea10318b24b2e8d4bc918d533b5a5789aa56d3a8d5fb8ccff9572fb63e5b6f2eafc44f93fb57a19e6621ebef5d64d9d
-EBUILD smartypants-2.0.1-r1.ebuild 773 BLAKE2B 8f1e13e943965cf88f13a79ede6b60027038212640aac9152ae1ac6d952ae6dfd1127df31a60e7068fa7495dbd918d0ab8e0ee690edd714e605670a470545170 SHA512 cc6aa6eb135152eb94cb924ff24b0715b6ffb0d92ae186c11c28faaff562378072927146aeb9dd7bf427bd55a029dfa803cad3f51f51f5732071a0a30f6dc5e6
-EBUILD smartypants-9999.ebuild 781 BLAKE2B bc1b39dc4d11c02a138c47c34ddca756cc5d84154cef879b1161986688cbd3db1b6c6525993f7f6afc2bc440239d3a9b3a8a9d23fe66f96caf2d04ee8936ba53 SHA512 bbf11645cd3f53d16b37faa859f9f58fc1d18d9b170a20831e646d045c575d0b5fa057dc15c8efb376a92520743d5e0718a85705073759c26e95b62ef16db004
+EBUILD smartypants-2.0.1-r1.ebuild 838 BLAKE2B 3855486c3f578e7558bf508296492b8cf6b0444e5e3e7f57227409d3c9a69c62538da71d72362d680e9b018ec620dcbcab620d3433cf800069f2d1ed351218bb SHA512 fe3f5dbce97891dbf5230e4c03635427905deb628767754ceae28ea48b08930761ce7601eb633bfdfc314bde0e0e04d23e95aa719ef2fc0fbb80f0df40b34874
MISC metadata.xml 533 BLAKE2B fbdcaba39094feabf10101304a6ad33c261042a49adbfb0610f3c3c0c3cb210d16f5cf7b7033d0092b567029194b40af3470bab472d068883e4800c550c72d30 SHA512 72b1d23d6a0e0b25679cf5de859398606004891308a316e549cac1c615381e3c89bcb79428e21346856cddbd28740b9423abefbe9b55b397dbaf41a56d7763df
diff --git a/dev-python/smartypants/smartypants-2.0.1-r1.ebuild b/dev-python/smartypants/smartypants-2.0.1-r1.ebuild
index c4a5c111cae5..773d6e56c5d0 100644
--- a/dev-python/smartypants/smartypants-2.0.1-r1.ebuild
+++ b/dev-python/smartypants/smartypants-2.0.1-r1.ebuild
@@ -4,28 +4,35 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{6..10} )
-
-MY_PN="${PN}.py"
-MY_P="${MY_PN}-${PV}"
+PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
+MY_P="${PN}.py-${PV}"
DESCRIPTION="ASCII quote-dot-dash to HTML entity converter"
-HOMEPAGE="https://pypi.python.org/pypi/smartypants/"
-
-if [[ ${PV} = 9999* ]]; then
- EGIT_REPO_URI="https://github.com/leohemsted/smartypants.py.git"
- EGIT_BRANCH="master"
- inherit git-r3
-else
- SRC_URI="https://github.com/leohemsted/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv sparc x86"
- S="${WORKDIR}/${MY_P}"
-fi
+HOMEPAGE="
+ https://pypi.org/project/smartypants/
+ https://github.com/leohemsted/smartypants.py/
+"
+SRC_URI="
+ https://github.com/leohemsted/smartypants.py/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+S=${WORKDIR}/${MY_P}
LICENSE="MIT"
SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv sparc x86"
distutils_enable_sphinx docs
-distutils_enable_tests setup.py
+distutils_enable_tests unittest
+
+src_prepare() {
+ # relevant only to upstream packaging, requires docutils
+ rm tests/test_setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ eunittest -s tests
+}
diff --git a/dev-python/smartypants/smartypants-9999.ebuild b/dev-python/smartypants/smartypants-9999.ebuild
deleted file mode 100644
index c5c6b78000bf..000000000000
--- a/dev-python/smartypants/smartypants-9999.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{6..10} )
-
-MY_PN="${PN}.py"
-MY_P="${MY_PN}-${PV}"
-
-inherit distutils-r1
-
-DESCRIPTION="ASCII quote-dot-dash to HTML entity converter"
-HOMEPAGE="https://pypi.python.org/pypi/smartypants/"
-
-if [[ ${PV} = 9999* ]]; then
- EGIT_REPO_URI="https://github.com/leohemsted/smartypants.py.git"
- EGIT_BRANCH="master"
- inherit git-r3
-else
- SRC_URI="https://github.com/leohemsted/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~sparc ~x86"
- S="${WORKDIR}/${MY_P}"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-
-distutils_enable_sphinx docs
-distutils_enable_tests setup.py