summaryrefslogtreecommitdiff
path: root/dev-python/snapshottest
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /dev-python/snapshottest
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'dev-python/snapshottest')
-rw-r--r--dev-python/snapshottest/Manifest2
-rw-r--r--dev-python/snapshottest/snapshottest-0.5.1.ebuild20
2 files changed, 9 insertions, 13 deletions
diff --git a/dev-python/snapshottest/Manifest b/dev-python/snapshottest/Manifest
index da1e1cfb88a0..dca14c2bc9f3 100644
--- a/dev-python/snapshottest/Manifest
+++ b/dev-python/snapshottest/Manifest
@@ -1,4 +1,4 @@
AUX snapshottest-0.5.1-remove-fastdiff.patch 1978 BLAKE2B 49bbd2118bd8defc3134b1863614a6da7f45f8702c9b65db35329a74b270a511ef6c87952eafefa5e64080c136e21fe7abbfb1e304ff1744983bfa6fcbcc27ee SHA512 804223af644f67a7ad22996572bdb35c88d3c87bfd67ef821b4ebcfb581281f305f9d96edfda9d8a20d5cd1d07397899dc10b629f7d02b91c2b8804e02fd1ac0
DIST snapshottest-0.5.1.tar.gz 19312 BLAKE2B a8acfb09de9e58c7a929f71d10f3cc68d7eec31a9fa1ea0fe74ae8a574ceec315f7eab2f9e7cd326c34d981b5ede4c398b5f1352bd59c23be219eeb9a2c0e861 SHA512 1541c327c4238c816b55cf797f6104ad54ff62a2332517b3bf9a455bbee0abd49f6983a54dc7510d1e1c659d88e5f7d6c6aa396c0ece19e19957ea8cff42c673
-EBUILD snapshottest-0.5.1.ebuild 1260 BLAKE2B 6160ca5676deba6ec488e0a64bf8d5473965ab1880b509275910c0f9de6a88c3c21b36cd417b5a3419d942da676922654032a93c85dac578e65cf4f70ff4117d SHA512 e376d695907d6e7dcfc6ebd2e58d572a8ce63daefd5c40c5c4ed2746eaea93df234085decaa69e350a1da82c863ee613d3f795c516f200f43b5b46977461efed
+EBUILD snapshottest-0.5.1.ebuild 1116 BLAKE2B 4105aa10a0b6fe8229eefed46bd4ac456041a53064552c442ed7618833aa0cda7808edef055bd868c33ba9a801710e65df8ccf1d292d7a082f768a56f216d476 SHA512 da6567fae19195269dc8b78cdda647cffbe1266a24e1f9eec3d900d08902f882aa272c71d2e600ffb38f7b48d605f0a1c6d111c5fdd539519e368d89af052fc0
MISC metadata.xml 379 BLAKE2B dd820515dd1513206bf39c277ffdf7ff17e14b75fbb933475e642eafa75d2bbcb77c04cbb80a3db8cfde704b67ffb04d426de3609e9cd0f8db9b6907e4c74335 SHA512 35cda720f330a8807f7a8dbe518e7de5df037386689ecbe6cd9ea816cf78d350053a7744c3fa266d824d32205125ab75dca0a5dd187e33c9b9b48afaf35ce8c9
diff --git a/dev-python/snapshottest/snapshottest-0.5.1.ebuild b/dev-python/snapshottest/snapshottest-0.5.1.ebuild
index aec16c0b697d..c49cc1e8330a 100644
--- a/dev-python/snapshottest/snapshottest-0.5.1.ebuild
+++ b/dev-python/snapshottest/snapshottest-0.5.1.ebuild
@@ -1,10 +1,9 @@
-# Copyright 2020 Gentoo Authors
+# Copyright 2020-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..8} )
-DISTUTILS_USE_SETUPTOOLS=bdepend
+PYTHON_COMPAT=( python3_{7..10} )
inherit distutils-r1
# no tests on pypi, no tags on github
@@ -13,24 +12,21 @@ COMMIT_HASH="4ac2b4fb09e9e7728bebb11967c164a914775d1d"
DESCRIPTION="Snapshot Testing utils for Python"
HOMEPAGE="https://pypi.org/project/snapshottest/
https://github.com/syrusakbary/snapshottest"
-SRC_URI="https://github.com/syrusakbary/${PN}/archive/${COMMIT_HASH}.tar.gz -> ${P}.tar.gz"
+SRC_URI="
+ https://github.com/syrusakbary/${PN}/archive/${COMMIT_HASH}.tar.gz
+ -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${COMMIT_HASH}"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="
dev-python/six[${PYTHON_USEDEP}]
dev-python/termcolor[${PYTHON_USEDEP}]
"
-BDEPEND="${RDEPEND}
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
+
+distutils_enable_tests pytest
PATCHES=(
"${FILESDIR}/snapshottest-0.5.1-remove-fastdiff.patch"
@@ -44,6 +40,6 @@ python_prepare_all() {
python_test() {
distutils_install_for_testing
- pytest -vv tests examples/pytest || die "Tests failed with ${EPYTHON}"
+ epytest tests examples/pytest
"${EPYTHON}" examples/unittest/test_demo.py || die "Tests failed with ${EPYTHON}"
}