summaryrefslogtreecommitdiff
path: root/dev-python/socketio-client
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/socketio-client
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/socketio-client')
-rw-r--r--dev-python/socketio-client/Manifest2
-rw-r--r--dev-python/socketio-client/socketio-client-0.7.2.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/socketio-client/Manifest b/dev-python/socketio-client/Manifest
index f635aa9522ab..61eaf775ed1b 100644
--- a/dev-python/socketio-client/Manifest
+++ b/dev-python/socketio-client/Manifest
@@ -1,3 +1,5 @@
DIST socketio-client-0.6.6.tar.gz 21829 BLAKE2B 72e47f9aa4bae06767aa1860fc7d57f7f2ae78dd037e46aa50a8672f4e168982d6e602ed8f80f203081e5747cacb0f6fa2959311271bc578c1b8b5bf70ec506a SHA512 aa21d31bf9e9062578fc6892a7624ea41ef3437eff132ff3ef2829a589c0fd19953fc514ab05161a32d06578708fb7f41b2f636d3d60a2700094e676d72cee47
+DIST socketio-client-0.7.2.tar.gz 23488 BLAKE2B 8c638dcc8ed30fb01a31e36f8175ef7e6b77b37dac0a66f1ef663a372458ccb34bac2ed58fce31a3856eb3d067ad8dc20f7d4a332b2af10ae12717bbb786349f SHA512 850839f804953c706458467c9e35c4c3637d3a61ff55042ef0b6f98e39a277faa97a0a3d7b1e18210e68ec32bb4ca793cd404631e0e2b533e61ad5d05cbc18fa
EBUILD socketio-client-0.6.6.ebuild 1456 BLAKE2B 54f225fd0cce72b7653fb96169a1b7b4ff0371c9aaa53bf148ad82a6d6964e27b235f46be347dd2080ca5a86581c15b44aecdabf5ee13cef1ec971088fbabf82 SHA512 5fa5ceaff2b3b80b1cd134bf90c2fd3c05f4cbcb4cdaa327fab724fb65ba20d9dade94a76189bb8fa844eaad26fe4759229f56718cc198f337e9de98f8ef8add
+EBUILD socketio-client-0.7.2.ebuild 1710 BLAKE2B 271aca450bf95ff3186391d96c7ba573c9288a23c62cc875e4901c405660094898134028bb6d7465a26453277ee905046a3fbc8c7edf06a8094197dd68ded815 SHA512 02a8f24a7487d87577011bc432ab311fc1dc87062cda6479a5d0ecf7bd093428e2a2654cc92adb034581f9da7f349a5fec22ca043583ab5750c74912678fbbd9
MISC metadata.xml 466 BLAKE2B aeae4a6f57347d31b7eed388cc7beeb819174f5f07b438a418f99532eb01ae092e6fa9a5758512de10f96f9e8aecef0e234d6e893ba39a353ddb1e42f1574b41 SHA512 a5d48ac121de3b0334d12ff4e472aa04be849f87f8ef39222a5a112674d36390d1ca69936d675cb7a42d11e73cdc5019540091ac64b727842d515b2c96b68c09
diff --git a/dev-python/socketio-client/socketio-client-0.7.2.ebuild b/dev-python/socketio-client/socketio-client-0.7.2.ebuild
new file mode 100644
index 000000000000..bf5234946351
--- /dev/null
+++ b/dev-python/socketio-client/socketio-client-0.7.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+MY_PN="socketIO-client"
+DESCRIPTION="A socket.io client library for Python"
+HOMEPAGE="https://github.com/invisibleroads/socketIO-client/ https://pypi.org/project/socketIO-client/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.7.0[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_test() {
+ # https://github.com/invisibleroads/socketIO-client/issues/90
+ # This runs the suite but has nill output to the screen
+ # The bug filed will hopefully yield a more conventional testsuite
+
+ # The import of SocketIO need be made with abs path to run the tests
+ sed -e 's:from .. import:from socketIO_client import:' \
+ -i socketIO_client/tests/__init__.py || die
+ sed -e 's:from ..exceptions import:from socketIO_client.exceptions import:' \
+ -i socketIO_client/tests/__init__.py || die
+
+ "${PYTHON}" socketIO_client/tests/__init__.py || \
+ die "Tests failed under ${EPYTHON}"
+
+ # Return to original form for final install
+ sed -e 's:from socketIO_client import:from .. import:' \
+ -i socketIO_client/tests/__init__.py || die
+ sed -e 's:from socketIO_client.exceptions import:from ..exceptions import:' \
+ -i socketIO_client/tests/__init__.py || die
+}