summaryrefslogtreecommitdiff
path: root/dev-python/sortedcollections
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/sortedcollections
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/sortedcollections')
-rw-r--r--dev-python/sortedcollections/Manifest3
-rw-r--r--dev-python/sortedcollections/metadata.xml15
-rw-r--r--dev-python/sortedcollections/sortedcollections-0.5.3.ebuild25
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/sortedcollections/Manifest b/dev-python/sortedcollections/Manifest
new file mode 100644
index 000000000000..3254bcafce21
--- /dev/null
+++ b/dev-python/sortedcollections/Manifest
@@ -0,0 +1,3 @@
+DIST sortedcollections-0.5.3.tar.gz 7021 SHA256 d56d6708e36aec959b08e64c3e5a0e01df518d6e6693d0f5b5c89529288edde6 SHA512 e0076017d1a97d7dc18b02bc4e3739c535ab001260be739fab2784cb58deac4323957fe21b4c679f55a790d864ca696695a603298709225b04eae740d859ab28 WHIRLPOOL ce3693115a2e694c8908c8a1ce9027b9adccf15e38ebad36c456265440174b77620d525d898d1a914626a0a698fc75280aca549e8c78d082f6888b6c3433173f
+EBUILD sortedcollections-0.5.3.ebuild 611 SHA256 063f4c82077c2fffdd82281b8c2a150f0ed18dc543bbafc7baaf47778f622828 SHA512 1fd62359c0726bb6d4a143268119a72af47a6fa24a21f550a27f76c3778620997750c73060d6d4776c582c14d42b0ffd9b60d365fe7c650079810e28c0c0a3aa WHIRLPOOL fde06a7bde58611ecb28d45bfbc794c10854672b611fc778c12cc5a7695da7386e3fea137a936b6f4dbc86b54a930340f1a047d7d7d42904b5d6f776679c8791
+MISC metadata.xml 498 SHA256 334ec83b616ed46a85ad579be0c9a00cb1da2b41220d6577c9925aba14d96681 SHA512 d332e588cdf6194708c1e3f00e9e8159669eb36cb21b4c6eed8e5af44f09f7e71f12fe437ce889b96599994f7a9c9d7c4fa6642c2ab74cedb0490d21a3165d21 WHIRLPOOL d408a45e4c5e01377b9689ff5e6ac7e90d9a666a94007a831e6f5ec407139daf6e62d20a36190e61ef3620821fc533423f0a8bd7be6986b6857c28b202e9ce34
diff --git a/dev-python/sortedcollections/metadata.xml b/dev-python/sortedcollections/metadata.xml
new file mode 100644
index 000000000000..4c79be884169
--- /dev/null
+++ b/dev-python/sortedcollections/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ Pure python sorted collection library.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">sortedcollections</remote-id>
+ <remote-id type="github">grantjenks/sortedcollections</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sortedcollections/sortedcollections-0.5.3.ebuild b/dev-python/sortedcollections/sortedcollections-0.5.3.ebuild
new file mode 100644
index 000000000000..a000cde4c13a
--- /dev/null
+++ b/dev-python/sortedcollections/sortedcollections-0.5.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to sort collections and containers"
+HOMEPAGE="http://www.grantjenks.com/docs/sortedcontainers/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-python/sortedcontainers[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test -v || die
+}