summaryrefslogtreecommitdiff
path: root/dev-python/spake2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-25 03:04:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-25 03:04:18 +0100
commit4bc145ba9c79d57abcafc9b97c72bd5addd3e833 (patch)
tree6d3232c40367527f41a16208e51be62072e72efc /dev-python/spake2
parentcc6fb501ef0f4c443ce79d017dbfbd95072b14f4 (diff)
gentoo auto-resync : 25:05:2023 - 03:04:17
Diffstat (limited to 'dev-python/spake2')
-rw-r--r--dev-python/spake2/Manifest3
-rw-r--r--dev-python/spake2/metadata.xml13
-rw-r--r--dev-python/spake2/spake2-0.8.ebuild21
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/spake2/Manifest b/dev-python/spake2/Manifest
new file mode 100644
index 000000000000..d153a15128ea
--- /dev/null
+++ b/dev-python/spake2/Manifest
@@ -0,0 +1,3 @@
+DIST spake2-0.8.gh.tar.gz 62425 BLAKE2B 64215362af26fff0785fdabf4282f7111a4cc917750827075b616f009cb1fa6373fc2325382c26b43c051aa5b94e414ca2a5223d9ab666289eb2d04723b15cb5 SHA512 908c377c831f4a11551973ca917b113d51a66c533d35fd19b2692fdb7e575ed2a5045d9b632bc55c37b68ad092f01dff5da191e9dfbfb5599b72844788438d68
+EBUILD spake2-0.8.ebuild 559 BLAKE2B 19dde835446cf7568157684ed7c17af156b6ca23b48ad1981be5a94d3de0563bd4bec2a377a150916eb1083663805f963bfc5cb78351ff1ee39daeb2a5ec8555 SHA512 8b0037d4a53028345db60ace5b8b47d95a1df0d378ba1ae74d99ffd8b0701409c3ecce924e4c1a5f347fd2be6af76d4685af1a6b2eba8c776d775fead9d96e9e
+MISC metadata.xml 401 BLAKE2B a80b9d771ec1251af6e16f012257a7d1150644cdba64052ff5b70d282c6f27fa57685f675409a3edf30b2c2bc24c85f74b3dd8460999f8497a72e93653183abc SHA512 ecfbcd80d35348bbb1a5469bcca1b06a86ca6fe736d443707e00859400318e5c9bb399e5acf2faaf2771301518741ec93124277f6bf1834454b4406392cf0ea4
diff --git a/dev-python/spake2/metadata.xml b/dev-python/spake2/metadata.xml
new file mode 100644
index 000000000000..2041ad286cee
--- /dev/null
+++ b/dev-python/spake2/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tamiko@gentoo.org</email>
+ <name>Matthias Maier</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">spake2</remote-id>
+ <remote-id type="github">warner/python-spake2</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/spake2/spake2-0.8.ebuild b/dev-python/spake2/spake2-0.8.ebuild
new file mode 100644
index 000000000000..25d38c02d8b0
--- /dev/null
+++ b/dev-python/spake2/spake2-0.8.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="python implementation of SPAKE2 password-authenticated key exchange algorithm"
+HOMEPAGE="https://pypi.org/project/spake2/"
+SRC_URI="https://github.com/warner/python-${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+S="${WORKDIR}/python-${P}"
+
+RDEPEND="
+ dev-python/hkdf[${PYTHON_USEDEP}]"