summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-autoapi/sphinx-autoapi-2.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-05 11:25:00 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-05 11:25:00 +0100
commitad77dc19e91d2c023f80e11e8974536d80e3a743 (patch)
tree42bb312ab0eb61fd94103e3eddb65b134f6be5a4 /dev-python/sphinx-autoapi/sphinx-autoapi-2.0.0.ebuild
parent6de28447d66e6c47ee682740b840cdb67244d4b1 (diff)
gentoo auto-resync : 05:04:2023 - 11:25:00
Diffstat (limited to 'dev-python/sphinx-autoapi/sphinx-autoapi-2.0.0.ebuild')
-rw-r--r--dev-python/sphinx-autoapi/sphinx-autoapi-2.0.0.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/sphinx-autoapi/sphinx-autoapi-2.0.0.ebuild b/dev-python/sphinx-autoapi/sphinx-autoapi-2.0.0.ebuild
deleted file mode 100644
index f26014d3e974..000000000000
--- a/dev-python/sphinx-autoapi/sphinx-autoapi-2.0.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="A new approach to API documentation in Sphinx"
-HOMEPAGE="
- https://sphinx-autoapi.readthedocs.io/
- https://github.com/readthedocs/sphinx-autoapi/
- https://pypi.org/project/sphinx-autoapi/
-"
-SRC_URI="
- https://github.com/readthedocs/sphinx-autoapi/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 x86"
-
-RDEPEND="
- dev-python/astroid[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- >=dev-python/sphinx-4.0[${PYTHON_USEDEP}]
- dev-python/unidecode[${PYTHON_USEDEP}]
-"
-
-DOCS=( README.rst CHANGELOG.rst )
-
-# Test requires pypi download w/ internet: https://github.com/readthedocs/sphinx-autoapi/issues/329
-EPYTEST_DESELECT=(
- tests/test_integration.py::TestExtensionErrors::test_extension_setup_errors[dotnetexample-override_conf2-AutoAPI
-)
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
-
-python_test() {
- # https://github.com/readthedocs/sphinx-autoapi/issues/368
- if has_version ">=dev-python/sphinx-6.0"; then
- EPYTEST_DESELECT+=(
- tests/python/test_pyintegration.py::TestPositionalOnlyArgumentsModule::test_integration
- )
- fi
-
- distutils-r1_python_test
-}