summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-autoapi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-19 00:15:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-19 00:15:15 +0000
commit2e512e4e32285f8c4eb19586d014cb9d31454ec9 (patch)
treee5884cadbd260c6936495a63b92f4503d54e5428 /dev-python/sphinx-autoapi
parent5264c18a325553759d67fb4e059db03cf3fc5c81 (diff)
gentoo auto-resync : 19:02:2025 - 00:15:15
Diffstat (limited to 'dev-python/sphinx-autoapi')
-rw-r--r--dev-python/sphinx-autoapi/Manifest2
-rw-r--r--dev-python/sphinx-autoapi/sphinx-autoapi-3.6.0.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/sphinx-autoapi/Manifest b/dev-python/sphinx-autoapi/Manifest
index e235492234d5..fe91ec191987 100644
--- a/dev-python/sphinx-autoapi/Manifest
+++ b/dev-python/sphinx-autoapi/Manifest
@@ -1,5 +1,7 @@
DIST sphinx-autoapi-3.4.0.gh.tar.gz 72943 BLAKE2B 8d3187e6c86a9172e5cbeb441a283e5f694b96aade054c3c96c56327365f7310244d37c2643004011ffe9ebad91b5cc61c67d8d8bb12c2eaf9286efce0c5c7db SHA512 8d85497b620326a62c8abc6c638b1526e6d01b744aa200a37acf3f7e2468bf84fc24ce7b91e172cdfe1c419a635e137f690aa860c0ee6283be2028823842139f
DIST sphinx-autoapi-3.5.0.gh.tar.gz 73246 BLAKE2B 63fd39ed4a6dd8077161a0607d34dd3e499b48a3e88576813d50bd478a581451a09baf5dd1a92d00c4b48118526c87f68f2deb95ee79d52edbaa7f432694f9bb SHA512 6a39fcbe3a67711f681594444e45c12118f57b27d8cd9544913b6d673ea0d587ec1c40f1e182faad4b86f2ddb5809d4b940ca54dd5df6369026e07c805f25aae
+DIST sphinx-autoapi-3.6.0.gh.tar.gz 73411 BLAKE2B 0fbe15c138d72a32d224248d94652763d8303ff014dbf2d35d878232e021ebcd9a7b72a792dc4d81aea182ea9cc812290f70954242bffa989d08e1427bb3c94b SHA512 9b671e3ca66ae40e95ce6df89952e9c1f2bf644087d9deaeb0e305de217fc8154445ff947ad9806949603f0956d95ae6d97c711fea52dcd44aa8f828b74f6c3d
EBUILD sphinx-autoapi-3.4.0.ebuild 1231 BLAKE2B e481a82bfdc8edbb641cc0f18b3281022db2c4fc15399c7546542c35d5d69d40fec71a7f975349f1b14c425ececa404b766abcca536d7ab7b0e0d17a3068d975 SHA512 9ef420c1ec42b8b998fe70dbd5fd0bc28102eb7b25dec5d2649b0c21cd981ddb006cc8da3ba64d296a5e6bdf50becdebd62d0015697f3600de8a851187a762c5
EBUILD sphinx-autoapi-3.5.0.ebuild 1235 BLAKE2B 51782900c32f403e372c4a0f5a826704e486292795b47289f377a9d51cc11565c76bab1a3a393c0b61319891b454c5795ad311007caf0799b3185f396a568b59 SHA512 7477c53a68e3140e772157131f1f365f38070d3293b00a5d482a560f7b7c0b25a0cd234323caf508a3a0fe0f2d98926ef86ad1eb78f0cd002a2da920bf659c04
+EBUILD sphinx-autoapi-3.6.0.ebuild 1238 BLAKE2B 2f7495b272410bad15e819012315692948521714d5008aae70f861c2f5b7bf1c6529130fad03a1afa6cc908b6fa0ac356b10611e31f915a2a1a4fc0f2d1d4cdc SHA512 43ef6847d1d682f3520b0fef69da1966677910254e4ab9c57d0b912e70e4c9a711ab6055d7297503eae1b9050204248d84fc8132c3902a86f8b8cf02d501f2b3
MISC metadata.xml 769 BLAKE2B 6f85e487a2d2def289bb54a6addc2338bb8af85b323ec1c95851945f9c407ec22bfadd8079ac8b6e00cfbc85caa0e2b09d82329f1f87a365fc44b69c7bcd9a20 SHA512 68f02a5f98234c2a5cb15aa04ce90077b154a7e3a7a69dc0a1d0a6b5c7b42c60624878a7e2fff1576c8b586fc15e7ef042942274d4e8473835bb3d8bfdbd8393
diff --git a/dev-python/sphinx-autoapi/sphinx-autoapi-3.6.0.ebuild b/dev-python/sphinx-autoapi/sphinx-autoapi-3.6.0.ebuild
new file mode 100644
index 000000000000..7a40a3d868b8
--- /dev/null
+++ b/dev-python/sphinx-autoapi/sphinx-autoapi-3.6.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2022-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="A new approach to API documentation in Sphinx"
+HOMEPAGE="
+ https://sphinx-autoapi.readthedocs.io/
+ https://github.com/readthedocs/sphinx-autoapi/
+ https://pypi.org/project/sphinx-autoapi/
+"
+# sdist is missing docs, as of 2.1.0
+SRC_URI="
+ https://github.com/readthedocs/sphinx-autoapi/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/astroid-3.0.0[${PYTHON_USEDEP}]
+ dev-python/jinja2[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-7.4.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND+="
+ test? (
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( README.rst CHANGELOG.rst )
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Internet
+ tests/python/test_pyintegration.py::TestPEP695::test_integration
+ tests/python/test_pyintegration.py::TestPipeUnionModule::test_integration
+ "tests/test_integration.py::TestExtensionErrors::test_extension_setup_errors[dotnetexample"
+ )
+
+ distutils-r1_python_test
+}