summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-autoapi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-21 12:30:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-21 12:30:10 +0100
commit4968fd889f69d50cfcab1ffa12e56bdf476d9939 (patch)
treeb7b79ef2705cb29f73763bce76d98b1a8ceb667d /dev-python/sphinx-autoapi
parentd3ae3ea75073c53ed5f3a4418e76383436bb0f58 (diff)
gentoo auto-resync : 21:07:2024 - 12:30:10
Diffstat (limited to 'dev-python/sphinx-autoapi')
-rw-r--r--dev-python/sphinx-autoapi/Manifest2
-rw-r--r--dev-python/sphinx-autoapi/sphinx-autoapi-3.2.0.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/sphinx-autoapi/Manifest b/dev-python/sphinx-autoapi/Manifest
index 26907de6412d..033f993e1e26 100644
--- a/dev-python/sphinx-autoapi/Manifest
+++ b/dev-python/sphinx-autoapi/Manifest
@@ -1,3 +1,5 @@
DIST sphinx-autoapi-3.1.2.gh.tar.gz 68260 BLAKE2B 31315fb298f7dae78c10f839e2738340eaf68d5497f22368c50f14309a564d1c5636015a715a9f99080a4f753416a10c63147e63dfcd53a27d7466ad422f95c4 SHA512 18e4a49e831446fa14278ffda4fec703f3b2c86654ce78fa7f4b89e5a41f1e6b19ea76cb64e7290a3125dc027a2de8aa052495a8bfd4bcc1828780f762e81957
+DIST sphinx-autoapi-3.2.0.gh.tar.gz 68693 BLAKE2B f9d70febea444a12c4db906614223415f51e649c3cb02770ca24e7274cb1e6c64a86802545ff1cb7b22e0e63bb63ceaaf1c27e487982a3d8d45e750a497dda01 SHA512 d14d62d4ab414f54f0066a63de490c293fbbbb1ca364b3094ca915fcb7765f373650a933026bf9582aeafb5556efb83c72a907f17c5168888bcfd7cbad081583
EBUILD sphinx-autoapi-3.1.2.ebuild 1200 BLAKE2B 6d592fea773727b4882b9a746b8ccfa698cdaad175f5f5f69c4402033f421e9f11405f705159bf0fb919c344b789a2e1b04b072f10fd6ba015b72b5c998dd56e SHA512 ad99a6e142a665cfa937f9cfbb28ade0a05c769fd21ac4f574e392c59f5e73351e463ce73320809c3c6beaa14831daec3e37615828bbc99628b9dfe2b076be29
+EBUILD sphinx-autoapi-3.2.0.ebuild 1204 BLAKE2B 3f9e2e6a0d06b2c1b4ff703f44335f08cc4ad0680e50b42061be6faf3794180cff23e708546bdca7ab79233b43d1675deaae31e19e621e524d77138d5dae312d SHA512 29b68725683c54a6e3c5a930badcf5269185b3650b7aac19d4b8302de12fb612821d86116224112fc6e1fbc8594c060801cd3a50b0adb6624285c421f426dafb
MISC metadata.xml 769 BLAKE2B 6f85e487a2d2def289bb54a6addc2338bb8af85b323ec1c95851945f9c407ec22bfadd8079ac8b6e00cfbc85caa0e2b09d82329f1f87a365fc44b69c7bcd9a20 SHA512 68f02a5f98234c2a5cb15aa04ce90077b154a7e3a7a69dc0a1d0a6b5c7b42c60624878a7e2fff1576c8b586fc15e7ef042942274d4e8473835bb3d8bfdbd8393
diff --git a/dev-python/sphinx-autoapi/sphinx-autoapi-3.2.0.ebuild b/dev-python/sphinx-autoapi/sphinx-autoapi-3.2.0.ebuild
new file mode 100644
index 000000000000..2dfb0a4c4c8b
--- /dev/null
+++ b/dev-python/sphinx-autoapi/sphinx-autoapi-3.2.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="A new approach to API documentation in Sphinx"
+HOMEPAGE="
+ https://sphinx-autoapi.readthedocs.io/
+ https://github.com/readthedocs/sphinx-autoapi/
+ https://pypi.org/project/sphinx-autoapi/
+"
+# sdist is missing docs, as of 2.1.0
+SRC_URI="
+ https://github.com/readthedocs/sphinx-autoapi/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/astroid-3.0.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-6.1.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND+="
+ test? ( dev-python/beautifulsoup4[${PYTHON_USEDEP}] )
+"
+
+DOCS=( README.rst CHANGELOG.rst )
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Internet
+ tests/python/test_pyintegration.py::TestPEP695::test_integration
+ tests/python/test_pyintegration.py::TestPipeUnionModule::test_integration
+ "tests/test_integration.py::TestExtensionErrors::test_extension_setup_errors[dotnetexample"
+ )
+
+ distutils-r1_python_test
+}