summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-autoapi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/sphinx-autoapi
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/sphinx-autoapi')
-rw-r--r--dev-python/sphinx-autoapi/Manifest3
-rw-r--r--dev-python/sphinx-autoapi/metadata.xml22
-rw-r--r--dev-python/sphinx-autoapi/sphinx-autoapi-1.8.4.ebuild32
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/sphinx-autoapi/Manifest b/dev-python/sphinx-autoapi/Manifest
new file mode 100644
index 000000000000..eb39432be55e
--- /dev/null
+++ b/dev-python/sphinx-autoapi/Manifest
@@ -0,0 +1,3 @@
+DIST sphinx-autoapi-1.8.4.tar.gz 83541 BLAKE2B 05d706fda6da4aea55e535a995ef01dc54269fa8e452c51c9bf2cec2e596ccec20191b8cb3c0cde1b93daa4f5d85074a293c9fd449d99d3c494ba20c6cee2df8 SHA512 10b4d87e1046ad372a3491006cd4bece8334fc398025f98654781c83ee200045d707f3293a031f8cf0abe5d20a111e7ded864f2b6deffe5222b331ca8c9b688b
+EBUILD sphinx-autoapi-1.8.4.ebuild 983 BLAKE2B f5abf9afce95376f69f1f099edbe3fe142508b1ed2ff396f97d3be5a19b1867df585c4e4195ac8544a9793a8864b3576a013a6dc69e56bc0fae14d2c72d8f705 SHA512 b7e550caab6b21322431a3e45029871ffbb9b1f9fd3847f6a3a84f3e67cc07e41b25c9f659c5ad5f6c3eb030633b623c559e3cfa76313ee1f75492ce0f92f0ac
+MISC metadata.xml 769 BLAKE2B 6f85e487a2d2def289bb54a6addc2338bb8af85b323ec1c95851945f9c407ec22bfadd8079ac8b6e00cfbc85caa0e2b09d82329f1f87a365fc44b69c7bcd9a20 SHA512 68f02a5f98234c2a5cb15aa04ce90077b154a7e3a7a69dc0a1d0a6b5c7b42c60624878a7e2fff1576c8b586fc15e7ef042942274d4e8473835bb3d8bfdbd8393
diff --git a/dev-python/sphinx-autoapi/metadata.xml b/dev-python/sphinx-autoapi/metadata.xml
new file mode 100644
index 000000000000..d9cd2dc6c337
--- /dev/null
+++ b/dev-python/sphinx-autoapi/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person" proxied="yes">
+ <email>marco@sirabella.org</email>
+ <name>Marco Sirabella</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">readthedocs/sphinx-autoapi</remote-id>
+ <remote-id type="pypi">sphinx-autoapi</remote-id>
+ <doc>https://sphinx-autoapi.readthedocs.io</doc>
+ <bugs-to>https://github.com/readthedocs/sphinx-autoapi/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinx-autoapi/sphinx-autoapi-1.8.4.ebuild b/dev-python/sphinx-autoapi/sphinx-autoapi-1.8.4.ebuild
new file mode 100644
index 000000000000..2b40b485267b
--- /dev/null
+++ b/dev-python/sphinx-autoapi/sphinx-autoapi-1.8.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A new approach to API documentation in Sphinx"
+HOMEPAGE="https://sphinx-autoapi.readthedocs.io/"
+SRC_URI="https://github.com/readthedocs/sphinx-autoapi/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+# pypi lacks docs/
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/astroid[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/unidecode[${PYTHON_USEDEP}]
+"
+
+DOCS=( README.rst CHANGELOG.rst )
+
+# Test requires pypi download w/ internet: https://github.com/readthedocs/sphinx-autoapi/issues/329
+EPYTEST_DESELECT="tests/test_integration.py::TestExtensionErrors::test_extension_setup_errors[dotnetexample-override_conf2-AutoAPI"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs --no-autodoc