summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-autoapi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-01 02:06:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-01 02:06:43 +0000
commitc635a4b7ddb6105bfc6fef130b188a087726677b (patch)
tree6707959596af4883f9621a0cdf56d35c06dbc63e /dev-python/sphinx-autoapi
parent080d89feff80cae2fc974ff2f24d463141c20635 (diff)
gentoo auto-resync : 01:12:2024 - 02:06:42
Diffstat (limited to 'dev-python/sphinx-autoapi')
-rw-r--r--dev-python/sphinx-autoapi/Manifest2
-rw-r--r--dev-python/sphinx-autoapi/sphinx-autoapi-3.4.0.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/sphinx-autoapi/Manifest b/dev-python/sphinx-autoapi/Manifest
index a93b580bacf3..baa0419fe214 100644
--- a/dev-python/sphinx-autoapi/Manifest
+++ b/dev-python/sphinx-autoapi/Manifest
@@ -1,3 +1,5 @@
DIST sphinx-autoapi-3.3.3.gh.tar.gz 72123 BLAKE2B 85b7c8f1eae4d9366f8e8afd526bdb5e6c0e3f14de44c9e94f4922e021bd15f31117942dc1c542a903c1fa4b3f138e0eacbfaccc744bf28c211283acbfc4268c SHA512 c6de80ceb7b394627ca19dbd59e8f7361ff1d14b5ab401134d149131b69f6be05348189ae97dcc6daa6e99276a99072d62990a8594be653d449659b556d86655
+DIST sphinx-autoapi-3.4.0.gh.tar.gz 72943 BLAKE2B 8d3187e6c86a9172e5cbeb441a283e5f694b96aade054c3c96c56327365f7310244d37c2643004011ffe9ebad91b5cc61c67d8d8bb12c2eaf9286efce0c5c7db SHA512 8d85497b620326a62c8abc6c638b1526e6d01b744aa200a37acf3f7e2468bf84fc24ce7b91e172cdfe1c419a635e137f690aa860c0ee6283be2028823842139f
EBUILD sphinx-autoapi-3.3.3.ebuild 1231 BLAKE2B e481a82bfdc8edbb641cc0f18b3281022db2c4fc15399c7546542c35d5d69d40fec71a7f975349f1b14c425ececa404b766abcca536d7ab7b0e0d17a3068d975 SHA512 9ef420c1ec42b8b998fe70dbd5fd0bc28102eb7b25dec5d2649b0c21cd981ddb006cc8da3ba64d296a5e6bdf50becdebd62d0015697f3600de8a851187a762c5
+EBUILD sphinx-autoapi-3.4.0.ebuild 1235 BLAKE2B ac551f7db98294c0dd88424fde8364696ffd3744388fb14bb3b177cf6d9d6b2681adda52708623219d62c3c8976cdc785bdb2b86fd4123444bcf362328e8e682 SHA512 db56fbb3a40cfeb0af15cab12a3ffcf5ae138cddb475c4d9711dee2d379abaecc64c537eb4aa946966b58f6f669f2529c98beebcaa214ab27bbb71c6f3528561
MISC metadata.xml 769 BLAKE2B 6f85e487a2d2def289bb54a6addc2338bb8af85b323ec1c95851945f9c407ec22bfadd8079ac8b6e00cfbc85caa0e2b09d82329f1f87a365fc44b69c7bcd9a20 SHA512 68f02a5f98234c2a5cb15aa04ce90077b154a7e3a7a69dc0a1d0a6b5c7b42c60624878a7e2fff1576c8b586fc15e7ef042942274d4e8473835bb3d8bfdbd8393
diff --git a/dev-python/sphinx-autoapi/sphinx-autoapi-3.4.0.ebuild b/dev-python/sphinx-autoapi/sphinx-autoapi-3.4.0.ebuild
new file mode 100644
index 000000000000..9a5c751f0a1f
--- /dev/null
+++ b/dev-python/sphinx-autoapi/sphinx-autoapi-3.4.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="A new approach to API documentation in Sphinx"
+HOMEPAGE="
+ https://sphinx-autoapi.readthedocs.io/
+ https://github.com/readthedocs/sphinx-autoapi/
+ https://pypi.org/project/sphinx-autoapi/
+"
+# sdist is missing docs, as of 2.1.0
+SRC_URI="
+ https://github.com/readthedocs/sphinx-autoapi/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/astroid-3.0.0[${PYTHON_USEDEP}]
+ dev-python/jinja2[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-6.1.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND+="
+ test? ( dev-python/beautifulsoup4[${PYTHON_USEDEP}] )
+"
+
+DOCS=( README.rst CHANGELOG.rst )
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Internet
+ tests/python/test_pyintegration.py::TestPEP695::test_integration
+ tests/python/test_pyintegration.py::TestPipeUnionModule::test_integration
+ "tests/test_integration.py::TestExtensionErrors::test_extension_setup_errors[dotnetexample"
+ )
+
+ distutils-r1_python_test
+}